camelot

An OCaml Linter / Style Checker
README

An OCaml Linter / Style Checker for the OCaml compiler version 4.09.0.
Make sure you have ocaml version 4.09.0, otherwise the parsetree will be different

Acknowledgements

This project wouldn't have been possible without the following three repos:

sml-style-check from the folks at CMU: for guiding the design of the linter, as well as basically contributing the structure of our project (especially the extendable checker modules :) ),

hlint for a good reference on building a linter,

and ppx_tools/rewriter, for giving us useful starter code and being the building block on which camelot started.

Dependencies

  • dune (v 2.4.0) - dune will manage installing the appropriate dependencies for you I believe

  • ocaml-base-compiler >= v4.09.0

  • compiler-libs.common

  • fswatch (for Build + Watch)

  • ANSITerminal

Note:

This project is dependent on compiler-libs, an inherently unstable library that
changes between OCaml installations.

Build and run instructions

Build:
dune build bin/camelot.exe

Build + Watch:
dune build bin/camelot.exe -w

Run 'tests':
dune exec -- bin/camelot.exe <camelot args here>

Camelot flags

-d <lintdir> : Specify the directory in which to lint

-show <ta | student | gradescope> : Specify the reporting type - does a student see this output or a ta?
If this argument is malformed or not present, the reporting type defaults to student

-f <filename> : Lints the given file

Install
Published
21 May 2020
Sources
0.4.3.tar.gz
md5=de2842663cff7fb0247b587569cce44e
sha512=9e6b7059333c1f30e487894b617506dd0f3d653dbe8579da91917c97136b38fddc01b137778e4c84d37cf4365b7b5ed29173712438b505b48fac0c5c470cc72d
Dependencies
ocaml
>= "4.09.0"
dune
>= "2.5"
Reverse Dependencies