esperanto

An OCaml compiler with Cosmopolitan

Error log

The package failed to build. The error log from opam follows.

Opam plugin "depext" may require upgrading/reinstalling. Reinstall the plugin on the current switch? [Y/n] y
The following actions will be performed:
  - recompile opam-depext 1.2.1-1

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved opam-depext.1.2.1-1  (https://github.com/ocaml-opam/opam-depext/releases/download/v1.2.1/opam-depext-full-1.2.1.tbz)
-> removed   opam-depext.1.2.1-1
-> installed opam-depext.1.2.1-1
Done.

<><> opam-depext.1.2.1-1 installed successfully <><><><><><><><><><><><><><><><>
=> opam-depext is unnecessary when used with opam >= 2.1. Please use opam install directly instead
# Run eval $(opam env) to update the current shell environment

<><> Carrying on to "opam depext -viy esperanto.0.0.1 conf-which.1 esperanto-cosmopolitan.0.0.2" 

You are using opam 2.1+, where external dependency handling has been integrated: consider calling opam directly, the 'depext' plugin interface is provided for backwards compatibility only
# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
[ERROR] No solution for esperanto.0.0.1 & conf-which.1 & esperanto-cosmopolitan.0.0.2:   * No agreement on the version of ocaml:
            - (invariant) -> ocaml-base-compiler = 4.14.1 -> ocaml = 4.14.1
            - esperanto < 0.0.2 -> ocaml < 4.14.1
            You can temporarily relax the switch invariant with `--update-invariant'
          * Incompatible packages:
            - (invariant) -> ocaml-base-compiler = 4.14.1
            - esperanto < 0.0.2 -> ocaml < 4.14.1 -> dkml-base-compiler
          * Missing dependency:
            - esperanto < 0.0.2 -> ocaml < 4.14.1 -> ocaml-base-compiler < 3.07+1 | ocaml-system < 3.07+1 | ocaml-variants < 3.8~
            not available because the package is pinned to version 4.14.1
            unmet availability conditions: 'sys-ocaml-version = "3.07"'
            no matching version
          * Missing dependency:
            - esperanto < 0.0.2 -> ocaml < 4.14.1 -> ocaml-base-compiler = 3.07+1 | ocaml-system = 3.07+1 | ocaml-variants < 3.8~
            not available because the package is pinned to version 4.14.1
            unmet availability conditions: 'sys-ocaml-version = "3.07+1"'
            no matching version
          * Missing dependency:
            - esperanto < 0.0.2 -> ocaml < 4.14.1 -> ocaml-base-compiler = 3.07+2 | ocaml-system = 3.07+2 | ocaml-variants < 3.8~
            not available because the package is pinned to version 4.14.1
            unmet availability conditions: 'sys-ocaml-version = "3.07+2"'
            no matching version
          * Missing dependency:
            - esperanto < 0.0.2 -> ocaml < 4.14.1 -> ocaml-base-compiler = 3.08.0 | ocaml-system < 3.08.1~ | ocaml-variants < 3.08.1~
            not available because the package is pinned to version 4.14.1
            unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.0"'
            no matching version
          * Missing dependency:
            - esperanto < 0.0.2 -> ocaml < 4.14.1 -> ocaml-base-compiler = 3.08.1 | ocaml-system < 3.08.2~ | ocaml-variants < 3.08.2~
            not available because the package is pinned to version 4.14.1
            unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.1"'
            no matching version
          * Missing dependency:
            - esperanto < 0.0.2 -> ocaml < 4.14.1 -> ocaml-base-compiler = 3.08.2 | ocaml-system < 3.08.3~ | ocaml-variants < 3.08.3~
            not available because the package is pinned to version 4.14.1
            unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.2"'
            no matching version
          * Missing dependency:
            - esperanto < 0.0.2 -> ocaml < 4.14.1 -> ocaml-base-compiler = 3.08.3 | ocaml-system < 3.08.4~ | ocaml-variants < 3.08.4~
            not available because the package is pinned to version 4.14.1
            unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.3"'
            no matching version
          * Missing dependency:
            - esperanto < 0.0.2 -> ocaml < 4.14.1 -> ocaml-base-compiler = 3.08.4 | ocaml-system < 3.08.5~ | ocaml-variants < 3.08.5~
            not available because the package is pinned to version 4.14.1
            unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.4"'
            no matching version
          * Missing dependency:
            - esperanto < 0.0.2 -> ocaml < 4.14.1 -> ocaml-base-compiler = 3.09.0 | ocaml-system < 3.09.1~ | ocaml-variants < 3.09.1~
            not available because the package is pinned to version 4.14.1
            unmet availability conditions, e.g. 'sys-ocaml-version = "3.09.0"'
            no matching version
          * Missing dependency:
            - esperanto < 0.0.2 -> ocaml < 4.14.1 -> ocaml-variants >= 4.05.1 -> ocaml-beta
            unmet availability conditions: 'enable-ocaml-beta-repository'


Command failed: opam --cli=2.1 list --readonly --external '--resolve=esperanto.0.0.1,conf-which.1,esperanto-cosmopolitan.0.0.2' returned 20