ON THIS PAGE

expect_test_helpers_kernel v0.13.0

Error log

The package failed to build. The error log from opam follows.

You are using opam 2.1+, where external dependency handling has been integrated: consider calling opam directly, the 'depext' plugin interface is provided for backwards compatibility only
# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
[ERROR] No solution for pa_ppx.0.02 & astring.0.8.5 & async.v0.13.0 & async_kernel.v0.13.0 & async_rpc_kernel.v0.13.0 & async_unix.v0.13.1 & base.v0.13.2 & base-bytes.base & base_bigstring.v0.13.0 & base_quickcheck.v0.13.0 & bin_prot.v0.13.0 & bos.0.2.1 & camlp-streams.5.0.1 & camlp5.8.00~alpha02 & conf-libpcre.1 & conf-m4.1 & conf-perl.2 & conf-perl-ipc-system-simple.3 & conf-perl-string-shellquote.3 & conf-pkg-config.2 & conf-which.1 & core.v0.13.0 & core_kernel.v0.13.1 & cppo.1.6.9 & csexp.1.5.1 & dune.3.6.1 & dune-configurator.3.6.1 & expect_test_helpers.v0.13.0 & expect_test_helpers_kernel.v0.13.0 & fieldslib.v0.13.0 & fmt.0.9.0 & fpath.0.7.3 & jane-street-headers.v0.13.0 & jst-config.v0.13.0 & logs.0.7.0 & not-ocamlfind.0.09 & num.1.4 & ocaml-compiler-libs.v0.12.4 & ocaml-migrate-parsetree.1.8.0 & ocamlbuild.0.14.2 & ocamlfind.1.9.5 & ocamlgraph.2.0.0 & octavius.1.2.2 & ounit2.2.2.6 & parsexp.v0.13.0 & pcre.7.4.6 & ppx_assert.v0.13.0 & ppx_base.v0.13.0 & ppx_bench.v0.13.0 & ppx_bin_prot.v0.13.0 & ppx_cold.v0.13.0 & ppx_compare.v0.13.0 & ppx_custom_printf.v0.13.0 & ppx_derivers.1.2.1 & ppx_deriving.4.5-1 & ppx_deriving_protobuf.2.7 & ppx_deriving_yojson.3.5.3 & ppx_enumerate.v0.13.0 & ppx_expect.v0.13.1 & ppx_fail.v0.13.0 & ppx_fields_conv.v0.13.0 & ppx_hash.v0.13.0 & ppx_here.v0.13.0 & ppx_import.1.8.0 & ppx_inline_test.v0.13.1 & ppx_jane.v0.13.0 & ppx_js_style.v0.13.0 & ppx_let.v0.13.0 & ppx_module_timer.v0.13.0 & ppx_optcomp.v0.13.0 & ppx_optional.v0.13.0 & ppx_pipebang.v0.13.0 & ppx_sexp_conv.v0.13.0 & ppx_sexp_message.v0.13.0 & ppx_sexp_value.v0.13.0 & ppx_stable.v0.13.0 & ppx_tools.6.6 & ppx_tools_versioned.5.4.0 & ppx_typerep_conv.v0.13.0 & ppx_variants_conv.v0.13.0 & ppxfind.1.4 & ppxlib.0.13.0 & protocol_version_header.v0.13.0 & re.1.10.4 & result.1.5 & rresult.0.7.0 & seq.base & sexp_pretty.v0.13.0 & sexplib.v0.13.0 & sexplib0.v0.13.0 & spawn.v0.15.1 & splittable_random.v0.13.0 & stdint.0.7.2 & stdio.v0.13.0 & stdlib-shims.0.3.0 & textutils.v0.13.0 & time_now.v0.13.0 & topkg.1.0.6 & typerep.v0.13.0 & uint.2.0.1 & variantslib.v0.13.0 & yojson.2.0.2:   * No agreement on the version of ocaml:
            - (invariant) -> ocaml-base-compiler = 4.10.2 -> ocaml = 4.10.2
            - camlp5 = 8.00~alpha02 -> ocaml != 4.10.2
            You can temporarily relax the switch invariant with `--update-invariant'
          * Missing dependency:
            - camlp5 = 8.00~alpha02 -> ocaml != 4.10.2 -> ocaml-base-compiler < 3.07+1 | ocaml-system < 3.07+1 | ocaml-variants < 3.8~
            not available because the package is pinned to version 4.10.2
            unmet availability conditions: 'sys-ocaml-version = "3.07"'
            no matching version
          * Missing dependency:
            - camlp5 = 8.00~alpha02 -> ocaml != 4.10.2 -> ocaml-base-compiler = 3.07+1 | ocaml-system = 3.07+1 | ocaml-variants < 3.8~
            not available because the package is pinned to version 4.10.2
            unmet availability conditions: 'sys-ocaml-version = "3.07+1"'
            no matching version
          * Missing dependency:
            - camlp5 = 8.00~alpha02 -> ocaml != 4.10.2 -> ocaml-base-compiler = 3.07+2 | ocaml-system = 3.07+2 | ocaml-variants < 3.8~
            not available because the package is pinned to version 4.10.2
            unmet availability conditions: 'sys-ocaml-version = "3.07+2"'
            no matching version
          * Missing dependency:
            - camlp5 = 8.00~alpha02 -> ocaml != 4.10.2 -> ocaml-base-compiler = 3.08.0 | ocaml-system < 3.08.1~ | ocaml-variants < 3.08.1~
            not available because the package is pinned to version 4.10.2
            unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.0"'
            no matching version
          * Missing dependency:
            - camlp5 = 8.00~alpha02 -> ocaml != 4.10.2 -> ocaml-base-compiler = 3.08.1 | ocaml-system < 3.08.2~ | ocaml-variants < 3.08.2~
            not available because the package is pinned to version 4.10.2
            unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.1"'
            no matching version
          * Missing dependency:
            - camlp5 = 8.00~alpha02 -> ocaml != 4.10.2 -> ocaml-base-compiler = 3.08.2 | ocaml-system < 3.08.3~ | ocaml-variants < 3.08.3~
            not available because the package is pinned to version 4.10.2
            unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.2"'
            no matching version
          * Missing dependency:
            - camlp5 = 8.00~alpha02 -> ocaml != 4.10.2 -> ocaml-base-compiler = 3.08.3 | ocaml-system < 3.08.4~ | ocaml-variants < 3.08.4~
            not available because the package is pinned to version 4.10.2
            unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.3"'
            no matching version
          * Missing dependency:
            - camlp5 = 8.00~alpha02 -> ocaml != 4.10.2 -> ocaml-base-compiler = 3.08.4 | ocaml-system < 3.08.5~ | ocaml-variants < 3.08.5~
            not available because the package is pinned to version 4.10.2
            unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.4"'
            no matching version
          * Missing dependency:
            - camlp5 = 8.00~alpha02 -> ocaml != 4.10.2 -> ocaml-base-compiler = 3.09.0 | ocaml-system < 3.09.1~ | ocaml-variants < 3.09.1~
            not available because the package is pinned to version 4.10.2
            unmet availability conditions, e.g. 'sys-ocaml-version = "3.09.0"'
            no matching version


Command failed: opam --cli=2.1 list --readonly --external '--resolve=pa_ppx.0.02,astring.0.8.5,async.v0.13.0,async_kernel.v0.13.0,async_rpc_kernel.v0.13.0,async_unix.v0.13.1,base.v0.13.2,base-bytes.base,base_bigstring.v0.13.0,base_quickcheck.v0.13.0,bin_prot.v0.13.0,bos.0.2.1,camlp-streams.5.0.1,camlp5.8.00~alpha02,conf-libpcre.1,conf-m4.1,conf-perl.2,conf-perl-ipc-system-simple.3,conf-perl-string-shellquote.3,conf-pkg-config.2,conf-which.1,core.v0.13.0,core_kernel.v0.13.1,cppo.1.6.9,csexp.1.5.1,dune.3.6.1,dune-configurator.3.6.1,expect_test_helpers.v0.13.0,expect_test_helpers_kernel.v0.13.0,fieldslib.v0.13.0,fmt.0.9.0,fpath.0.7.3,jane-street-headers.v0.13.0,jst-config.v0.13.0,logs.0.7.0,not-ocamlfind.0.09,num.1.4,ocaml-compiler-libs.v0.12.4,ocaml-migrate-parsetree.1.8.0,ocamlbuild.0.14.2,ocamlfind.1.9.5,ocamlgraph.2.0.0,octavius.1.2.2,ounit2.2.2.6,parsexp.v0.13.0,pcre.7.4.6,ppx_assert.v0.13.0,ppx_base.v0.13.0,ppx_bench.v0.13.0,ppx_bin_prot.v0.13.0,ppx_cold.v0.13.0,ppx_compare.v0.13.0,ppx_custom_printf.v0.13.0,ppx_derivers.1.2.1,ppx_deriving.4.5-1,ppx_deriving_protobuf.2.7,ppx_deriving_yojson.3.5.3,ppx_enumerate.v0.13.0,ppx_expect.v0.13.1,ppx_fail.v0.13.0,ppx_fields_conv.v0.13.0,ppx_hash.v0.13.0,ppx_here.v0.13.0,ppx_import.1.8.0,ppx_inline_test.v0.13.1,ppx_jane.v0.13.0,ppx_js_style.v0.13.0,ppx_let.v0.13.0,ppx_module_timer.v0.13.0,ppx_optcomp.v0.13.0,ppx_optional.v0.13.0,ppx_pipebang.v0.13.0,ppx_sexp_conv.v0.13.0,ppx_sexp_message.v0.13.0,ppx_sexp_value.v0.13.0,ppx_stable.v0.13.0,ppx_tools.6.6,ppx_tools_versioned.5.4.0,ppx_typerep_conv.v0.13.0,ppx_variants_conv.v0.13.0,ppxfind.1.4,ppxlib.0.13.0,protocol_version_header.v0.13.0,re.1.10.4,result.1.5,rresult.0.7.0,seq.base,sexp_pretty.v0.13.0,sexplib.v0.13.0,sexplib0.v0.13.0,spawn.v0.15.1,splittable_random.v0.13.0,stdint.0.7.2,stdio.v0.13.0,stdlib-shims.0.3.0,textutils.v0.13.0,time_now.v0.13.0,topkg.1.0.6,typerep.v0.13.0,uint.2.0.1,variantslib.v0.13.0,yojson.2.0.2' returned 20