frag

File fragment extraction
IN THIS PACKAGE
Empty package map

Error log

The package failed to build. The error log from opam follows.

# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
# No extra OS packages requirements found.
# All required OS packages found.
# Now letting opam install the packages
[NOTE] Package ocamlfind is already installed (current version is 1.9.5).
[NOTE] Package dune is already installed (current version is 1.11.4).
The following actions will be performed:
  - install ppx_derivers            1.2.1
  - install seq                     0.2.2
  - install ocamlbuild              0.14.1
  - install stdlib-shims            0.3.0
  - install jbuilder                transition
  - install octavius                1.2.2
  - install result                  1.5
  - install base-num                base
  - install re                      1.9.0
  - install mpp                     0.3.5
  - install spawn                   v0.9.0
  - install ppx_traverse_builtins   v0.9.0
  - install ocaml-compiler-libs     v0.9.0
  - install jane-street-headers     v0.9.0
  - install ocaml-migrate-parsetree 1.8.0
  - install num                     0
  - install ppx_ast                 v0.9.1
  - install sexplib                 v0.9.3
  - install base                    v0.9.4
  - install typerep                 v0.9.0
  - install stdio                   v0.9.1
  - install ppx_core                v0.9.3
  - install ppx_optcomp             v0.9.0
  - install ppx_driver              v0.9.2
  - install variantslib             v0.9.0
  - install ppx_metaquot            v0.9.0
  - install ppx_let                 v0.9.0
  - install ppx_here                v0.9.1
  - install fieldslib               v0.9.0
  - install ppx_type_conv           v0.9.1
  - install ppx_pipebang            v0.9.0
  - install ppx_optional            v0.9.0
  - install ppx_js_style            v0.9.0
  - install ppx_inline_test         v0.9.2
  - install ppx_fail                v0.9.0
  - install ppx_variants_conv       v0.9.0
  - install ppx_typerep_conv        v0.9.0
  - install ppx_traverse            v0.9.0
  - install ppx_sexp_conv           v0.9.0
  - install ppx_fields_conv         v0.9.0
  - install ppx_enumerate           v0.9.0
  - install ppx_compare             v0.9.0
  - install ppx_bench               v0.9.1
  - install ppx_sexp_value          v0.9.0
  - install ppx_sexp_message        v0.9.0
  - install ppx_custom_printf       v0.9.0
  - install ppx_hash                v0.9.0
  - install ppx_assert              v0.9.0
  - install bin_prot                v0.9.2
  - install ppx_base                v0.9.0
  - install ppx_expect              v0.9.0
  - install ppx_bin_prot            v0.9.0
  - install configurator            v0.9.1
  - install ppx_jane                v0.9.0
  - install core_kernel             v0.9.1
  - install core                    v0.9.2
  - install frag                    0.1.0
===== 57 to install =====

<><> Gathering sources ><><><><><><><><><><><><><><><><><><><><><><><><><><><><>
[base.v0.9.4] found in cache
Processing  1/57:
Processing  2/57:
Processing  3/57: [bin_prot.v0.9.2: http]
[configurator.v0.9.1] found in cache
Processing  4/57: [bin_prot.v0.9.2: http]
Processing  5/57: [bin_prot.v0.9.2: http] [core.v0.9.2: http]
Processing  6/57: [bin_prot.v0.9.2: http] [core.v0.9.2: http] [core_kernel.v0.9.1: http]
[bin_prot.v0.9.2] downloaded from https://github.com/janestreet/bin_prot/archive/v0.9.2.tar.gz
Processing  6/57: [core.v0.9.2: http] [core_kernel.v0.9.1: http]
[fieldslib.v0.9.0] found in cache
Processing  7/57: [core.v0.9.2: http] [core_kernel.v0.9.1: http]
Processing  8/57: [core.v0.9.2: http] [core_kernel.v0.9.1: http] [frag.0.1.0: http]
[core_kernel.v0.9.1] downloaded from https://github.com/janestreet/core_kernel/archive/v0.9.1.tar.gz
Processing  8/57: [core.v0.9.2: http] [frag.0.1.0: http]
[core.v0.9.2] downloaded from https://github.com/janestreet/core/archive/v0.9.2.tar.gz
Processing  8/57: [frag.0.1.0: http]
[jane-street-headers.v0.9.0] found in cache
Processing  9/57: [frag.0.1.0: http]
Processing 10/57: [frag.0.1.0: http]
[mpp.0.3.5] found in cache
Processing 11/57: [frag.0.1.0: http]
Processing 12/57: [frag.0.1.0: http]
[ocaml-compiler-libs.v0.9.0] found in cache
Processing 13/57: [frag.0.1.0: http]
[ocaml-migrate-parsetree.1.8.0] found in cache
Processing 14/57: [frag.0.1.0: http]
Processing 14/57:
[ocamlbuild.0.14.1] found in cache
Processing 15/57:
[octavius.1.2.2] found in cache
Processing 16/57:
[ppx_assert.v0.9.0] found in cache
Processing 17/57:
[ppx_ast.v0.9.1] found in cache
Processing 18/57:
[ppx_base.v0.9.0] found in cache
Processing 19/57:
[ppx_bench.v0.9.1] found in cache
Processing 20/57:
[ppx_bin_prot.v0.9.0] found in cache
Processing 21/57:
[ppx_compare.v0.9.0] found in cache
Processing 22/57:
[ppx_core.v0.9.3] found in cache
Processing 23/57:
[ppx_custom_printf.v0.9.0] found in cache
Processing 24/57:
[ppx_derivers.1.2.1] found in cache
Processing 25/57:
[ppx_driver.v0.9.2] found in cache
Processing 26/57:
[ppx_enumerate.v0.9.0] found in cache
Processing 27/57:
[ppx_expect.v0.9.0] found in cache
Processing 28/57:
[ppx_fail.v0.9.0] found in cache
Processing 29/57:
[ppx_fields_conv.v0.9.0] found in cache
Processing 30/57:
[ppx_hash.v0.9.0] found in cache
Processing 31/57:
[ppx_here.v0.9.1] found in cache
Processing 32/57:
[ppx_inline_test.v0.9.2] found in cache
Processing 33/57:
[ppx_jane.v0.9.0] found in cache
Processing 34/57:
[ppx_js_style.v0.9.0] found in cache
Processing 35/57:
[ppx_let.v0.9.0] found in cache
Processing 36/57:
[ppx_metaquot.v0.9.0] found in cache
Processing 37/57:
[ppx_optcomp.v0.9.0] found in cache
Processing 38/57:
[ppx_optional.v0.9.0] found in cache
Processing 39/57:
[ppx_pipebang.v0.9.0] found in cache
Processing 40/57:
[ppx_sexp_conv.v0.9.0] found in cache
Processing 41/57:
[ppx_sexp_message.v0.9.0] found in cache
Processing 42/57:
[ppx_sexp_value.v0.9.0] found in cache
Processing 43/57:
[ppx_traverse.v0.9.0] found in cache
Processing 44/57:
[ppx_traverse_builtins.v0.9.0] found in cache
Processing 45/57:
[ppx_type_conv.v0.9.1] found in cache
Processing 46/57:
[ppx_typerep_conv.v0.9.0] found in cache
Processing 47/57:
[ppx_variants_conv.v0.9.0] found in cache
Processing 48/57:
[re.1.9.0] found in cache
Processing 49/57:
[result.1.5] found in cache
Processing 50/57:
[seq.0.2.2] found in cache
Processing 51/57:
[sexplib.v0.9.3] found in cache
Processing 52/57:
[spawn.v0.9.0] found in cache
Processing 53/57:
[stdio.v0.9.1] found in cache
Processing 54/57:
[stdlib-shims.0.3.0] found in cache
Processing 55/57:
[typerep.v0.9.0] found in cache
Processing 56/57:
[variantslib.v0.9.0] found in cache
Processing 57/57:
[ERROR] The sources of the following couldn't be obtained, aborting:
          - frag.0.1.0:
            http://pw374.github.io/distrib/frag/frag-0.1.0.tar.gz (curl: code 404 while downloading http://pw374.github.io/distrib/frag/frag-0.1.0.tar.gz)

'opam install --verbose --yes frag.0.1.0 base.v0.9.4 base-num.base bin_prot.v0.9.2 configurator.v0.9.1 core.v0.9.2 core_kernel.v0.9.1 dune.1.11.4 fieldslib.v0.9.0 jane-street-headers.v0.9.0 jbuilder.transition mpp.0.3.5 num.0 ocaml-compiler-libs.v0.9.0 ocaml-migrate-parsetree.1.8.0 ocamlbuild.0.14.1 ocamlfind.1.9.5 octavius.1.2.2 ppx_assert.v0.9.0 ppx_ast.v0.9.1 ppx_base.v0.9.0 ppx_bench.v0.9.1 ppx_bin_prot.v0.9.0 ppx_compare.v0.9.0 ppx_core.v0.9.3 ppx_custom_printf.v0.9.0 ppx_derivers.1.2.1 ppx_driver.v0.9.2 ppx_enumerate.v0.9.0 ppx_expect.v0.9.0 ppx_fail.v0.9.0 ppx_fields_conv.v0.9.0 ppx_hash.v0.9.0 ppx_here.v0.9.1 ppx_inline_test.v0.9.2 ppx_jane.v0.9.0 ppx_js_style.v0.9.0 ppx_let.v0.9.0 ppx_metaquot.v0.9.0 ppx_optcomp.v0.9.0 ppx_optional.v0.9.0 ppx_pipebang.v0.9.0 ppx_sexp_conv.v0.9.0 ppx_sexp_message.v0.9.0 ppx_sexp_value.v0.9.0 ppx_traverse.v0.9.0 ppx_traverse_builtins.v0.9.0 ppx_type_conv.v0.9.1 ppx_typerep_conv.v0.9.0 ppx_variants_conv.v0.9.0 re.1.9.0 result.1.5 seq.0.2.2 sexplib.v0.9.3 spawn.v0.9.0 stdio.v0.9.1 stdlib-shims.0.3.0 typerep.v0.9.0 variantslib.v0.9.0' failed.