ocaml

The OCaml compiler (virtual package)
Description

This package requires a matching implementation of OCaml, and polls it to initialise specific variables like ocaml:native-dynlink

Install
Published
28 Mar 2018
Authors
Maintainers
Dependencies
ocaml-system >= "4.05.0" & < "4.05.1~"
ocaml-variants >= "4.05.0" & < "4.05.1~"
Reverse Dependencies
0install != "2.8" & < "2.17"
acpc < "2.0.0"
alba < "0.4.1"
alcotest < "0.4.6" | >= "0.4.10"
alsa >= "0.2.3"
amqp-client >= "1.0.1"
ancient >= "0.9.1"
ao < "0.2.2"
arakoon >= "1.8.6"
archimedes >= "0.4.18"
archsat < "1.1"
arp < "2.2.0"
arp-mirage < "2.2.0"
async < "109.19.00" | >= "113.24.00" & != "113.33.03" & < "v0.12.0"
async_core < "109.19.00"
async_durable < "v0.12.0"
async_extended >= "113.24.00" & != "113.33.03"
async_extra < "109.19.00" | = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.12.0"
async_find != "111.28.00" & != "113.33.03" & < "v0.12.0"
async_inotify != "113.00.00" & != "113.33.03" & < "v0.12.0"
async_js < "v0.12.0"
async_kernel >= "113.24.00" & != "113.33.03" & < "v0.12.0"
async_parallel >= "113.24.00" & != "113.33.03"
async_rpc_kernel >= "113.24.00" & != "113.33.03" & < "v0.12.0"
async_sendfile < "v0.12.0"
async_shell != "109.28.03" & != "113.33.03" & < "v0.12.0"
async_smtp < "112.35.00" | >= "113.24.00" & != "113.33.03" & < "v0.12.0"
async_ssl < "112.35.00" | = "113.24.00" | >= "113.33.06" & < "v0.12.0"
async_unix < "109.19.00" | = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.12.0"
atd < "2.3.3"
atdgen >= "1.9.1" & < "2.3.3"
atdj < "2.3.3" | >= "20151001.01"
atds < "2.3.3"
atomic < "base"
awa-lwt < "0.0.2"
awa-mirage < "0.0.2"
aws-s3 < "4.6.0"
aws-s3-async < "4.6.0"
b0 < "0.0.2"
bap = "0.9.5" | >= "1.2.0" & < "2.1.0"
bap-abi < "2.1.0"
bap-api < "2.1.0"
bap-arm < "2.1.0"
bap-beagle < "2.1.0"
bap-bil < "2.1.0"
bap-build < "2.1.0"
bap-bundle < "2.1.0"
bap-c < "2.1.0"
bap-cache < "2.1.0"
bap-callsites < "2.1.0"
bap-cxxfilt < "2.1.0"
bap-demangle < "2.1.0"
bap-dwarf < "2.1.0"
bap-elf < "2.1.0"
bap-frontc < "2.1.0"
bap-frontend < "2.1.0"
bap-future < "2.1.0"
bap-ida < "2.1.0"
bap-knowledge < "2.1.0"
bap-llvm < "2.1.0"
bap-main < "2.1.0"
bap-mc < "2.1.0"
bap-microx < "2.1.0"
bap-mips < "2.1.0"
bap-objdump < "2.1.0"
bap-phoenix < "2.1.0"
bap-piqi < "2.1.0"
bap-plugins < "2.1.0"
bap-powerpc < "2.1.0"
bap-primus < "2.1.0"
bap-print < "2.1.0"
bap-raw < "2.1.0"
bap-recipe < "2.1.0"
bap-report < "2.1.0"
bap-run < "2.1.0"
bap-ssa < "2.1.0"
bap-std < "2.1.0"
bap-strings < "2.1.0"
bap-taint < "2.1.0"
bap-trace < "2.1.0"
bap-traces < "2.1.0"
bap-veri < "0.2.5"
bap-x86 < "2.1.0"
bare < "2.1.0"
base < "v0.14.0"
base-bytes >= "base"
base64 != "2.3.0"
base_quickcheck < "v0.15.0"
batteries = "2.5.0" | >= "2.7.0"
bau >= "0.0.4"
beluga >= "0.8.1" & < "1.0"
benchmark >= "1.3.1"
bignum < "112.35.00" | >= "113.24.00" & != "113.33.03" & < "v0.12.0"
bigstringaf < "0.9.0"
bimage < "0.2.1"
bimage-gtk < "0.2.1"
bimage-sdl < "0.2.1"
bin_prot < "109.15.00" | = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.14.1"
bindlib < "6.0.0"
binsec < "0.4.0"
biocaml != "0.5.0" & != "0.10.0" & < "0.11.0"
bisect >= "1.3"
bisect_ppx >= "1.2.0"
bistro < "0.5.0"
bitmasks >= "1.1.0"
bitstring >= "2.0.4"
bitvec < "2.1.0"
bitvec-order < "2.1.0"
bitvec-sexp < "2.1.0"
bjack < "0.1.6"
bloomf < "0.2.0"
bogue < "20210514"
bolt >= "1.3"
bos < "0.2.1"
cairo >= "0.4.2"
calculon < "0.7"
calendar != "2.03.1"
caml2html >= "1.4.4"
camlimages >= "4.1.2" & != "4.2.1" & < "4.2.5"
camllib >= "1.3.1"
camlon < "3.0.0"
camlp-streams >= "5.0.1"
camlp4 = "4.02.0-1modular-implicits" | >= "4.05+1" & < "4.06+1"
camlp5 >= "7.00" & != "7.09"
camlpdf >= "2.1.1" & < "2.5"
camltc != "0.9.2"
camlzip >= "1.05" & < "1.11"
camomile >= "0.8.5"
capnp-rpc < "1.2"
capnp-rpc-net < "0.9.0"
cbor < "0.5"
certify < "0.3.3"
cfg < "2.3.0"
charrua < "1.2.0"
charrua-unix < "1.2.0"
checkseum < "0.1.1"
cil >= "1.7.3"
cinaps < "v0.12.0" | >= "v0.15.0"
clangml != "3.8.0" & < "3.9.1.2" | >= "4.0.0beta1" & < "4.3.0"
clangml-transforms >= "0.24" & < "0.26"
cmdliner < "1.1.0"
coccinelle != "1.0.0-rc23"
codept >= "0.9.1"
cohttp < "3.0.0"
cohttp-async < "3.0.0"
cohttp-lwt < "3.0.0"
cohttp-mirage < "3.0.0"
cohttp-top < "3.0.0"
colombe != "0.2.0"
color >= "0.2.0"
command_rpc < "v0.12.0"
comparelib < "113.00.00"
conduit != "3.0.0" & < "6.1.0"
conduit-async != "3.0.0" & < "6.1.0"
conduit-lwt != "3.0.0" & < "6.1.0"
conjury < "2.1"
coq >= "8.5.0~camlp4" & < "8.16.0"
coqide != "8.7.0" & < "8.10.0"
core >= "113.24.00" & != "113.33.00" & != "113.33.02" & < "113.33.03" | >= "v0.9.1" & < "v0.12.0"
core_bench != "112.35.00" & != "113.33.00" & != "113.33.03" & < "v0.12.0"
core_extended >= "108.00.02" & < "109.19.00" | = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.12.0"
core_kernel = "113.24.00" | >= "113.33.01+4.03" & != "113.33.03" & < "v0.12.0"
core_profiler >= "113.24.00" & != "113.33.03" & < "v0.12.0"
cow >= "1.0.0" & != "2.0.0"
cpdf < "2.4"
crowbar < "0.2"
crunch < "3.3.0"
cryptokit >= "1.10" & < "1.17"
cstruct < "1.8.0" | >= "2.3.2" & < "6.1.0"
cstruct-async < "6.1.0"
cstruct-lwt < "6.1.0"
cstruct-sexp < "6.1.0"
cstruct-unix < "3.5.0"
csv >= "1.2.4"
csvfields < "v0.12.0"
ctypes >= "0.4.0"
cubicle >= "1.0.2" & < "1.2.0"
cudf < "0.10"
custom_printf >= "111.21.00" & < "113.00.00"
daft < "0.0.4"
decompress < "0.9.1"
dedukti < "2.7"
delimcc >= "2017.03.02" & < "2020.10.08"
depyt < "0.3.0"
deriving >= "0.7.1"
devkit >= "0.4"
dht < "0.2.0"
digestif < "1.1.2"
dns < "4.0.0"
doc-ock >= "1.1.0"
dockerfile < "8.1.0"
dolmen < "0.5"
down < "0.1.0"
dropbox < "0.2"
dssi < "0.1.3"
duff < "0.5"
dum != "1.0.2"
dune-configurator = "1.11.4" | >= "2.7.0"
duppy < "0.9.0"
dyntype >= "0.8.3"
earley < "3.0.0"
earley-ocaml >= "1.0.1"
earlybird >= "0.1.2" & < "1.0.0"
easy-format < "1.3.3"
easy_logging < "0.8.1"
ecaml < "v0.12.0"
edn < "0.2.0"
electrod < "0.8.0"
eliom < "6.4.0"
elpi < "1.15.0"
email_message < "112.35.00" | = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.12.0"
encore < "0.6"
enumerate < "111.08.00"
eqaf < "0.8"
erssical < "1.1.0"
ethernet < "2.2.0"
extlib = "1.7.0" | >= "1.7.2"
extlib-compat >= "1.7.2"
extprot >= "1.1.2"
extunix >= "0.1.4" & < "0.3.1"
ez_cmdliner < "0.2.0"
ez_config < "0.2.0"
ez_file < "0.2.0"
ez_hash >= "0.5.3"
ezjs_fetch < "0.3"
ezjs_min < "0.3.0"
ezjsonm >= "0.4.3" & < "1.3.0"
FrontC < "4.0.0"
faad < "0.5.0"
faraday-async < "0.7.2"
fat-filesystem < "0.14.0"
fd-send-recv < "2.0.2"
fdkaac < "0.3.2"
feather < "0.2.0"
ffmpeg < "1.0.0~beta1"
fftw3 >= "0.7.2"
fiat-p256 < "0.2.1"
fieldslib < "109.19.00" | = "113.24.00" | >= "v0.9.0" & < "v0.15.0"
flow >= "0.3"
flow_parser < "0.159.0"
flowtype >= "0.49.1"
fluent-logger < "1.1.0"
fmt < "0.8.10"
frama-c >= "11.0" & < "22.0"
frama-c-base >= "14.0"
freetds < "0.7"
frei0r < "0.1.2"
frenetic < "5.0.5"
fstar != "0.9.4.0-beta0"
functoria >= "1.1.0" & < "3.1.2"
gasoline >= "0.3.0"
gdal != "0.8.0"
gen-bs < "0.1.0"
gen_js_api = "1.0.4"
get_line < "5.0.0"
gettext >= "0.3.7"
gg < "1.0.0"
git != "1.4.3" & != "1.7.2" & < "2.1.3"
git-http < "2.1.3"
git-mirage < "2.1.3"
git-unix < "2.1.3"
github < "4.4.0"
github-jsoo < "4.4.0"
github-unix < "4.4.0"
glMLite = "0.03.52"
glpk != "0.1.7"
gobba < "0.4.2"
goblint < "1.1.1"
gpr < "1.5.0"
graphics < "3.07" | = "4.05.0"
graphlib < "2.1.0"
graphql < "0.14.0"
graphql-async < "0.14.0"
graphql-cohttp < "0.14.0"
graphql-lwt < "0.14.0"
graphql_parser < "0.14.0"
grenier < "0.12"
gsl < "1.24.2"
h2 < "0.5.0"
h2-lwt < "0.5.0"
h2-lwt-unix < "0.5.0"
h2-mirage < "0.5.0"
hacl-star < "0.4.0"
hacl-star-raw < "0.4.0"
hardcaml < "v0.12.0"
hdf5 >= "0.1.2"
headache < "1.04" | >= "1.06"
herelib < "112.35.00"
hevea < "2.35"
hex < "1.5.0"
higlo < "0.8"
hkdf < "1.0.4"
ibx < "0.8.1"
icalendar < "0.1.5"
imagelib < "20200929"
imaplet-lwt < "0.1.15"
incr_dom < "v0.12.0"
incr_dom_widgets < "v0.12.0"
incr_map < "v0.12.0"
incr_select < "v0.12.0"
incremental >= "113.24.00" & != "113.33.03" & < "v0.12.0"
incremental_kernel != "113.33.03"
inferno < "20211222"
interval < "1.6"
io-page < "3.0.0"
iocaml >= "0.4.6"
iocaml-kernel >= "0.4.6"
iocamljs-kernel < "0.4.3" | >= "0.4.6"
ipaddr >= "2.7.2" & < "5.3.1"
ipaddr-sexp < "5.3.1"
iri < "0.5.0"
irmin < "0.9.0" | >= "0.9.5" & != "0.9.10" & < "2.0.0"
irmin-mirage < "2.0.0"
irmin-pack < "2.3.0"
irmin-tezos >= "3.2.1" & < "3.4.0"
JsOfOCairo >= "1.0.0"
javalib < "3.2.2"
jenga < "109.19.00" | >= "113.24.00" & != "113.33.00" & != "113.33.03"
jhupllib < "0.2.2"
js-build-tools >= "113.33.04"
js_of_ocaml >= "3.0"
json-wheel < "1.0.6+safe-string"
jsonm != "1.0.0"
jsoo_storage >= "1.0.1"
jst-config < "v0.15.0"
junit < "2.0.1"
junit_ounit < "2.0.1"
jupyter < "2.7.8"
jwto < "0.4.0"
kafka >= "0.3"
kaputt >= "1.2"
ke < "0.6"
ketrew >= "1.1.1" & != "3.0.0"
key-parsers < "1.2.1"
kicadsch < "0.5.1"
kremlin < "1.0.0"
lablgtk = "2.18.5" | >= "2.18.7" & < "2.18.12"
lablgtk3 < "3.1.2"
lablqml >= "0.5.2" & < "0.7"
labltk < "8.06.4"
lacaml < "11.0.6"
ladspa < "0.2.0"
lambda-term < "3.2.0"
lambdapi < "2.0.0"
lame < "0.3.4"
landmarks < "1.4"
lascar < "0.6-alpha"
lastfm < "0.3.3"
lbfgs != "0.8.5"
lbvs_consent < "2.0.0"
learn-ocaml < "0.13.0"
lem < "2022-12-10"
lens < "1.2.4"
letsencrypt < "0.1.1"
letters < "0.1.1"
leveldb != "1.0.3" & < "1.3.0"
libdash < "0.3"
libsvm != "0.9.3"
line-up-words < "v0.12.0"
links < "0.7.3"
liquidsoap < "1.4.0"
lmdb >= "1.0"
lo < "0.2.0"
loga < "0.0.5"
logs >= "0.6.2"
logtk < "2.0"
lru != "0.3.0-1"
lustre-v6 < "6.107.1"
lwt >= "2.7.1" & < "5.6.0"
lwt-parallel < "1.0.0"
lwt_domain < "0.2.0"
lwt_eio < "0.2"
lwt_ppx < "2.1.0"
lwt_react < "1.2.0"
lz4_chans >= "3.0.0"
macaddr < "5.3.1"
macaddr-sexp < "5.3.1"
mad < "0.5.0"
mariadb < "1.1.4"
mbr-format < "1.0.0"
md2mld < "0.6"
mdx >= "1.2.0" & < "2.0.0"
memcad < "1.1.0"
menhir != "20211125"
merlin >= "3.0.0" & != "3.3.4~4.10preview1" & != "3.3.7~4.11preview1" & < "4.1-411"
metapp < "0.3.0"
metaquot < "0.3.0"
metrics-lwt >= "0.3.0"
metrics-mirage >= "0.3.0"
metrics-unix >= "0.3.0"
mikmatch = "1.0.8"
milter >= "1.0.2"
mindstorm >= "0.6"
minisat != "0.3"
mirage < "3.7.1"
mirage-block < "2.0.0"
mirage-clock < "3.0.0"
mirage-console != "2.1.0" & < "3.0.0"
mirage-device < "2.0.0"
mirage-flow < "2.0.0"
mirage-fs < "3.0.0"
mirage-fs-unix >= "1.1.1" & < "1.7.0"
mirage-kv < "3.0.0"
mirage-kv-mem < "3.0.0"
mirage-logs < "1.2.0"
mirage-nat < "1.1.0"
mirage-net < "3.0.0"
mirage-net-unix != "2.2.0" & < "2.7.0"
mirage-net-xen >= "1.4.2" & < "1.6.0" | >= "1.7.0" & < "1.13.0"
mirage-qubes < "0.8.0"
mirage-random < "2.0.0"
mirage-solo5 < "0.6.1"
mirage-stack < "2.0.0"
mirage-time < "2.0.0"
mirage-types < "3.7.1"
mirage-unix < "4.0.0"
mirage-vnetif < "0.5.0"
mirage-xen >= "2.6.0" & < "5.0.0"
mkocaml >= "1.2"
mldonkey >= "3.1.6"
mlpost = "0.8.2"
mlt_parser < "v0.12.0"
mm >= "0.3.0" & < "0.5.0"
modelica_ml >= "0.2.0"
molenc < "15.4.0"
monads < "2.1.0"
mpi < "1.05"
msgpck < "1.5"
mtime < "1.4.0"
mysql >= "1.2.1"
naboris < "0.1.1"
nbd < "6.0.0"
netchannel < "1.13.0"
nocrypto >= "0.2.0"
not-ocamlfind != "0.07" & < "0.09"
notty < "0.2.3"
npy < "0.0.7"
num < "1.0"
nunchaku >= "0.3.1"
OCanren < "0.2.0"
OCanren-ppx < "0.3.0~alpha1"
oasis >= "0.4.6"
obeam < "0.1.0" | = "0.1.2"
obelisk < "0.5.0"
objsize >= "0.18"
obus >= "1.1.7"
obytelib != "1.5"
ocaml-basics != "0.4.0"
ocaml-freestanding >= "0.2.2" & < "0.5.0"
ocaml-lua >= "1.6" & < "1.8"
ocaml-makefile < "6.39.2"
ocaml-manual = "4.05.0"
ocaml-migrate-parsetree != "1.3.0~4.08.0+beta2"
ocaml-monadic >= "0.3.2"
ocaml-r < "0.4.0"
ocaml-src = "4.05.0"
ocaml-top < "1.1.0" | >= "1.1.4"
ocaml-variants >= "4.05.0+32bit" & < "4.05.1+trunk"
ocaml-version < "3.0.0"
ocaml-xdg-basedir < "transition"
ocaml_plugin < "112.35.00" | >= "113.24.00" & != "113.33.00" & != "113.33.03" & < "v0.12.0"
ocamlbuild != "0.9.0"
ocamlclean != "2.2"
ocamlcodoc < "1.0.1"
ocamldap >= "2.2"
ocamldot < "1.1"
ocamlfind >= "1.5.1"
ocamlnet >= "4.1.4"
ocamlpp >= "1.1"
ocamlscript < "3.0.0"
ocamlspot = "4.05.0.2.3.2"
ocamltter < "2.0.1" | = "2.1.1" | >= "4.1.0"
ocapic = "3.3"
ocf = "0.5.0"
ocp-browser != "1.2.1" & < "1.3.4"
ocp-build >= "1.99.18-beta"
ocp-indent < "0.9.2" | >= "1.4.2"
ocp-index >= "1.1.5" & < "1.3.4"
ocplib_stuff < "0.3.0"
ocsigen-i18n < "3.2.0"
ocsigen-start < "1.2.0"
odate < "0.6"
odds < "1.1"
odepack >= "0.6.7"
odig < "0.0.6"
ogen != "0.1.2"
ogg != "0.6.0" & < "0.7.0"
ogre < "2.1.0"
ojs-base < "0.3.0" | = "0.5.0"
omd < "2.0.0~alpha3"
omod < "0.0.3"
omonad >= "0.3.2" & < "0.4.0"
opam-core != "2.0.0~rc"
opam_bin_lib < "0.9.5"
opasswd < "0.9.3" | >= "1.3.1"
opium < "0.19.0"
optint < "0.0.3"
opus < "0.2.0"
orakuda < "2.0.0"
orm >= "0.7.0"
osc < "0.2.0"
ospec >= "0.3.1"
otr >= "0.3.2" & < "0.3.7"
ott < "0.33"
ounit < "2.2.0"
ounit-lwt < "2.2.0"
override < "0.4.0"
owee < "0.3"
owl < "0.3.7"
pa_bench < "113.00.00"
pa_ounit < "112.35.00"
pa_test < "112.24.00"
parany < "13.0.0"
parsexp < "v0.15.0"
parsexp_io < "v0.15.0"
patdiff != "113.00.00" & != "113.33.03" & < "v0.12.0"
patience_diff != "112.24.00" & != "113.33.03" & < "v0.12.0"
pattern != "0.1.1" & < "0.3.0"
pbkdf < "1.1.0"
pcap-format < "0.6.0"
pcre < "7.4.2"
pfff >= "0.37.1"
pgocaml < "4.0"
pgx < "1.0"
pgx_async < "1.0"
pgx_lwt < "1.0"
pgx_unix < "1.0"
pilat < "1.6"
pipebang < "113.00.00"
pkcs11 < "1.0.1"
pkcs11-driver < "1.0.1"
pla < "2.0"
planck >= "2.2.0"
planets >= "0.1.14"
plotkicadsch < "0.4.0"
pomap >= "3.0.7"
portaudio = "0.2.1"
posix-getopt < "2.0.0"
posixat >= "v0.10.0" & < "v0.12.0"
postgresql < "4.5.1"
pp < "1.1.2"
ppx_assert >= "113.24.00" & != "113.33.03" & < "v0.15.0"
ppx_ast != "v0.9.2"
ppx_base < "v0.15.0"
ppx_bench = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.15.0"
ppx_bigarray >= "2.0.0"
ppx_bin_prot >= "113.24.00" & != "113.33.00" & != "113.33.03" & < "v0.15.0"
ppx_bitstring = "1.1.0" | >= "1.3.3" & < "4.0.0"
ppx_blob >= "0.2"
ppx_cold < "v0.15.0"
ppx_compare = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.15.0"
ppx_conv_func = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.12.0"
ppx_core >= "v0.9.0"
ppx_cstruct < "6.0.0"
ppx_csv_conv = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.12.0"
ppx_custom_printf = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.15.0"
ppx_defer < "0.5.0"
ppx_deriving >= "4.1.5"
ppx_deriving_yojson < "2.0" | >= "3.1"
ppx_driver = "113.24.00" | >= "113.33.00+4.03" & < "113.33.03" | = "v0.9.0" | >= "v0.9.2"
ppx_enumerate = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.15.0"
ppx_expect != "113.33.00" & != "113.33.01" & != "113.33.03" & < "v0.15.0"
ppx_fail = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0"
ppx_fields_conv = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.15.0"
ppx_getenv >= "1.2"
ppx_hash < "v0.15.0"
ppx_here >= "113.24.00" & != "113.33.03" & < "v0.15.0"
ppx_implicits = "0.2.0"
ppx_include >= "1.1"
ppx_inline_test = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.15.0"
ppx_jane != "113.33.03" & < "v0.15.0"
ppx_js_style < "v0.15.0"
ppx_jsobject_conv >= "0.2.1" & < "0.6.0"
ppx_let != "113.33.00" & != "113.33.03" & < "v0.15.0"
ppx_log < "v0.15.0"
ppx_meta_conv = "4.0.0"
ppx_module_timer < "v0.15.0"
ppx_monadic >= "1.0.4"
ppx_netblob >= "1.1"
ppx_optcomp = "113.24.00" | = "113.33.01+4.03" | >= "v0.9.0" & < "v0.14.3"
ppx_optional < "v0.15.0"
ppx_orakuda = "3.0.1" | >= "3.1.0"
ppx_pipebang = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.15.0"
ppx_python < "v0.15.0"
ppx_regexp >= "0.3.0"
ppx_seq >= "0.2.0"
ppx_sexp_conv >= "113.24.00" & != "113.33.03" & < "v0.15.0"
ppx_sexp_message != "113.33.00" & != "113.33.03" & < "v0.15.0"
ppx_sexp_value = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.15.0"
ppx_stable < "v0.15.0"
ppx_string < "v0.15.0"
ppx_test >= "1.4.0" & < "1.7.0"
ppx_tools = "5.0+4.05.0"
ppx_type_conv = "113.24.00" | >= "113.33.00+4.03" & != "113.33.03"
ppx_typerep_conv = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.15.0"
ppx_tyre >= "0.4.3"
ppx_variants_conv = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.15.0"
ppx_xml_conv >= "113.24.00" & != "113.33.03" & < "v0.12.0"
ppx_yojson < "1.2.0"
ppx_yojson_conv < "v0.15.0"
ppxlib < "0.14.0" | >= "0.16.0" & < "0.19.0" | >= "0.21.0" & != "0.25.0~5.00preview"
ppxx >= "2.1.0" & < "2.3.2"
pratter != "1.0" & < "2.0.0"
ptime < "1.0.0"
ptmap != "2.0.1" & != "2.0.4"
ptset >= "1.0.1"
pulseaudio < "0.1.4"
qbf < "0.3"
qcheck < "0.18"
qcheck-core < "0.18"
qfs < "0.12"
qocamlbrowser >= "0.2.9" & < "0.2.11"
quickcheck != "1.0.0"
rawlink < "2.1"
rdbg >= "1.175"
rdf < "0.7.0" | = "0.11.0"
re2 < "112.35.00" | = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.12.0"
react < "1.2.2"
reactiveData < "0.2.2"
reason = "1.13.7" | >= "3.0.0"
record_builder < "v0.12.0"
redirect >= "0.1.1"
redis >= "0.3.0"
refl < "0.4.0"
regular >= "1.2.0" & < "2.1.0"
resource_cache < "v0.12.0"
resp < "0.10.0"
resp-client < "0.10.0"
resp-mirage < "0.10.0"
resp-server < "0.10.0"
resp-unix < "0.10.0"
rfc1951 < "0.9.1"
rfc6287 < "1.0.4"
rfsm < "1.6-alpha-3"
riakc_ppx != "3.1.2"
ringo < "1.0.0"
river < "0.2"
rml >= "1.09.00" & < "1.09.06"
routes != "0.7.0" & < "2.0.0"
rpc < "1.3.0" | >= "1.9.51" & != "8.0.0"
rpc_parallel >= "113.24.00" & != "113.33.03" & < "v0.12.0"
rpclib != "8.0.0" & < "9.0.0"
rresult < "0.7.0"
salsa20 < "1.1.0"
samplerate < "0.1.5"
sanddb < "0.3.0"
sawja < "1.5.8"
scrypt-kdf < "1.1.0"
sedlex >= "1.99.3" & < "2.6"
sendmail >= "0.2.0"
sendmail-lwt >= "0.2.0"
seq != "0.3" & < "base"
sequencer_table < "v0.12.0"
session < "0.5.0"
sexp_pretty < "v0.12.0"
sexplib = "113.33.00+4.03" | >= "v0.9.0" & < "v0.15.0"
sexplib0 < "v0.15.1"
shcaml >= "0.2.0"
shexp < "v0.12.0"
slacko < "0.15.0"
slap >= "3.0.1"
spdx_licenses < "1.1.0"
speex < "0.4.0"
spelll != "0.3"
splay_tree < "v0.12.0"
spoc = "20170724"
spotlib >= "2.4.1" & < "4.1.0"
sqlexpr != "0.7.1"
sqlite3 < "5.0.2"
srt < "0.1.1"
ssh-agent < "0.4.0"
ssl >= "0.5.3"
statsd-client >= "1.0.2"
stdint != "0.6.0"
stdio < "v0.15.0"
stog = "0.11.1" | >= "0.13.0" & < "0.19.0"
stog-writing < "0.19.0"
string_dict < "v0.15.0"
systemverilog < "0.0.2"
taglib < "0.3.7"
tar < "2.0.0"
tar-mirage < "2.0.0"
tcpip < "4.0.0"
tensorflow < "0.0.11"
terminal_size < "0.2.0"
text >= "0.8.0"
text-tags < "2.1.0"
textutils != "112.17.00" & != "113.33.03" & < "v0.12.0"
textutils_kernel < "v0.12.0"
tgls < "0.8.6"
theora < "0.4.0"
time_now < "v0.15.0"
timed < "1.1"
tip-parser < "0.5"
tls < "0.11.0"
toml < "7.0.0"
toml_cconv < "7.0.0"
tophide >= "1.0.4"
toplevel_expect_test < "113.33.02" | >= "v0.9.1" & < "v0.12.0"
topological_sort < "v0.12.0"
trax < "0.4.0"
treeprint >= "2.1.1" & < "2.3.0"
tsdl < "0.9.9"
type_conv >= "113.00.02"
typerep < "112.35.00" | = "113.24.00" | >= "v0.9.0" & < "v0.15.0"
typerep_extended != "113.00.00" & != "113.33.03"
typerex-attic >= "1.0.2"
typpx = "1.3.0" | = "1.4.1"
ubase < "0.20"
uecc >= "0.3"
uint >= "1.1.5" & < "2.0.1"
unison >= "2.48.15v4" & < "2.52.0"
unmagic < "1.0.3"
uritemplate >= "0.2.0"
usbmux >= "1.2.0"
utop >= "1.19.3" & < "2.11.0"
uuidm < "0.9.8"
uunf != "2.0.0"
uuseg != "1.0.0"
uutf != "1.0.0"
variantslib != "109.15.03" & != "113.33.03" & < "v0.15.0"
vcardgen < "1.2"
vchan < "5.0.0"
vchan-unix < "5.0.0"
vchan-xen < "5.0.0"
virtual_dom < "v0.12.0"
visitors >= "20170828" & != "20210127"
vpt < "5.0.0"
vue-jsoo = "0.2"
wasm < "1.1"
webdav >= "1.1.5"
websocket < "2.12"
why >= "2.32"
wyrd >= "1.4.6"
x509 < "0.10.0"
xapi-inventory != "1.2.1"
xapi-rrd != "1.8.2" & < "1.9.1"
xen-gnt < "4.0.1"
xen-gnt-unix < "4.0.1"
xenctrl >= "0.9.29"
xmldiff < "0.6.0"
xtmpl = "0.10" | >= "0.14.0" & < "0.18.0"
yaml != "0.2.1" & < "3.0.1"
z3 < "4.8.14"
zarith >= "1.3"
zenon < "0.8.5"
zero < "109.19.00"
zlist < "0.4.0"
zmq < "4.0-1" | >= "4.0-8"