sparrow

A Static Analyzer for C

Error log

The package failed to build. The error log from opam follows.

You are using opam 2.1+, where external dependency handling has been integrated: consider calling opam directly, the 'depext' plugin interface is provided for backwards compatibility only
# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
[ERROR] No solution for sparrow.0.2 & apron.v0.9.13 & base-num.base & batteries.3.5.1 & camlidl.1.09 & cil.1.7.3 & conf-gmp.4 & conf-mpfr.3 & conf-perl.2 & conf-pkg-config.2 & cppo.1.6.9 & dune.1.11.4 & lymp.0.2.5 & mlgmpidl.1.2.14 & num.0 & ocaml-migrate-parsetree.1.5.0 & ocamlbuild.0.14.1 & ocamlfind.1.9.5 & ocamlgraph.1.8.8 & ppx_compare.113.33.00+4.03 & ppx_core.113.33.01+4.03 & ppx_derivers.1.2.1 & ppx_deriving.4.5-1 & ppx_driver.113.33.02+4.03 & ppx_optcomp.113.33.01+4.03 & ppx_tools.5.0 & ppx_type_conv.113.33.02+4.03 & ppxfind.1.3 & result.1.5 & seq.0.2.2 & yojson.2.0.0:   * Incompatible packages:
            - (invariant) -> ocaml-base-compiler = 4.04.2
            - sparrow >= 0.2 -> ocaml = 4.04.0 -> ocaml-system >= 4.04.0
            You can temporarily relax the switch invariant with `--update-invariant'
          * Missing dependency:
            - sparrow >= 0.2 -> ocaml = 4.04.0 -> ocaml-variants >= 4.04.0 -> ocaml-beta
            unmet availability conditions: 'enable-ocaml-beta-repository'


Command failed: opam --cli=2.1 list --readonly --external '--resolve=sparrow.0.2,apron.v0.9.13,base-num.base,batteries.3.5.1,camlidl.1.09,cil.1.7.3,conf-gmp.4,conf-mpfr.3,conf-perl.2,conf-pkg-config.2,cppo.1.6.9,dune.1.11.4,lymp.0.2.5,mlgmpidl.1.2.14,num.0,ocaml-migrate-parsetree.1.5.0,ocamlbuild.0.14.1,ocamlfind.1.9.5,ocamlgraph.1.8.8,ppx_compare.113.33.00+4.03,ppx_core.113.33.01+4.03,ppx_derivers.1.2.1,ppx_deriving.4.5-1,ppx_driver.113.33.02+4.03,ppx_optcomp.113.33.01+4.03,ppx_tools.5.0,ppx_type_conv.113.33.02+4.03,ppxfind.1.3,result.1.5,seq.0.2.2,yojson.2.0.0' returned 20