why3-base

Why3 environment for deductive program verification (base)

Error log

The package failed to build. The error log from opam follows.

You are using opam 2.1+, where external dependency handling has been integrated: consider calling opam directly, the 'depext' plugin interface is provided for backwards compatibility only
# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
[ERROR] No solution for why.2.41 & alt-ergo.2.3.3 & alt-ergo-lib.2.3.3 & alt-ergo-parsers.2.3.3 & camlzip.1.10 & conf-autoconf.0.1 & conf-gmp.4 & conf-gnomecanvas.2 & conf-gtk2.1 & conf-gtksourceview.2 & conf-pkg-config.2 & conf-which.1 & conf-zlib.1 & dune.2.0.1 & frama-c.17.0 & lablgtk.2.18.12 & menhir.20200123 & menhirLib.20200123 & menhirSdk.20200123 & num.1.4 & ocamlfind.1.9.5 & ocamlgraph.1.8.8 & ocplib-simplex.0.4 & psmt2-frontend.0.2 & seq.0.2.2 & stdlib-shims.0.3.0 & why3.0.88.3 & why3-base.0.88.3 & zarith.1.12:   * Missing dependency:
            - conf-gtksourceview
            depends on the unavailable system package 'libgtksourceview2.0-dev'. Use `--no-depexts' to attempt installation anyway, or it is possible that a depext package name in the opam file is incorrect.


Command failed: opam --cli=2.1 list --readonly --external '--resolve=why.2.41,alt-ergo.2.3.3,alt-ergo-lib.2.3.3,alt-ergo-parsers.2.3.3,camlzip.1.10,conf-autoconf.0.1,conf-gmp.4,conf-gnomecanvas.2,conf-gtk2.1,conf-gtksourceview.2,conf-pkg-config.2,conf-which.1,conf-zlib.1,dune.2.0.1,frama-c.17.0,lablgtk.2.18.12,menhir.20200123,menhirLib.20200123,menhirSdk.20200123,num.1.4,ocamlfind.1.9.5,ocamlgraph.1.8.8,ocplib-simplex.0.4,psmt2-frontend.0.2,seq.0.2.2,stdlib-shims.0.3.0,why3.0.88.3,why3-base.0.88.3,zarith.1.12' returned 20