package bap-byteweight-frontend

  1. Overview
  2. Docs
On This Page
  1. Error log

bap-byteweight-frontend 1.2.0

Error log

The package failed to build. The error log from opam follows.

Opam plugin "depext" may require upgrading/reinstalling. Reinstall the plugin on the current switch? [Y/n] y
The following actions will be performed:
  - recompile opam-depext 1.2.1-1

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved opam-depext.1.2.1-1  (cached)
-> removed   opam-depext.1.2.1-1
-> installed opam-depext.1.2.1-1
Done.

<><> opam-depext.1.2.1-1 installed successfully <><><><><><><><><><><><><><><><>
=> opam-depext is unnecessary when used with opam >= 2.1. Please use opam install directly instead
# Run eval $(opam env) to update the current shell environment

<><> Carrying on to "opam depext -viy bap-fsi-benchmark.1.2.0 zed.3.1.0 zarith.1.13 variantslib.113.24.00 uuidm.0.9.7 utop.2.9.2 uri.4.2.0 typerep.113.24.00 trie.1.0.0 topkg.1.0.4 text-tags.1.2.0 stringext.1.6.0 stdlib-shims.0.3.0 sexplib.113.33.00+4.03 seq.0.3.1 result.1.5 regular.1.3.0 react.1.2.1 re.1.11.0 ppxfind.1.4 ppx_variants_conv.113.33.00+4.03 ppx_typerep_conv.113.33.00+4.03 ppx_type_conv.113.33.02+4.03 ppx_tools.5.0 ppx_sexp_value.113.33.00+4.03 ppx_sexp_message.113.33.00+4.03 ppx_sexp_conv.113.33.01+4.03 ppx_pipebang.113.33.00+4.03 ppx_optcomp.113.33.01+4.03 ppx_let.113.33.00+4.03 ppx_jane.113.33.00 ppx_inline_test.113.33.00+4.03 ppx_here.113.33.00 ppx_fields_conv.113.33.00+4.03 ppx_fail.113.33.00+4.03 ppx_expect.113.33.01+4.03 ppx_enumerate.113.33.00+4.03 ppx_driver.113.33.02+4.03 ppx_deriving.4.5-1 ppx_derivers.1.2.1 ppx_custom_printf.113.33.00+4.03 ppx_core.113.33.01+4.03 ppx_compare.113.33.00+4.03 ppx_bin_prot.113.33.00+4.03 ppx_bench.113.33.00+4.03 ppx_assert.113.33.00 ocurl.0.9.2 ocplib-endian.1.2 ocamlmod.0.0.9 ocamlify.0.0.1 ocamlgraph.2.0.0 ocamlfind.1.9.6 ocamlbuild.0.14.3 ocaml-syntax-shims.1.0.0 ocaml-migrate-parsetree.1.8.0 oasis.0.4.7 mmap.1.2.0 mew_vi.0.5.0 mew.0.1.0 lwt_react.1.1.5 lwt_log.1.1.2 lwt.5.5.0 lambda-term.3.1.0 graphlib.1.2.0 fileutils.0.6.4 fieldslib.113.24.00 FrontC.3.4.3-1 dune-configurator.3.13.0 dune.3.13.0 csexp.1.5.2 cppo.1.6.9 core_kernel.113.33.02+4.03 conf-zlib.1 conf-which.1 conf-pkg-config.3 conf-libcurl.2 conf-ida.0.3 conf-gmp.4 conf-env-travis.1 conf-clang.1 conf-binutils.0.2 conf-bap-llvm.1.6 cmdliner.0.9.8 charInfo_width.1.1.0 camomile.1.0.2 camlzip.1.10 bin_prot.113.33.00+4.03 bigstringaf.0.8.0 bigarray-compat.1.1.0 base-bytes.base bap-x86.1.2.0 bap-warn-unused.1.2.0 bap-traces.1.2.0 bap-trace.1.2.0 bap-term-mapper.1.2.0 bap-taint-propagator.1.2.0 bap-taint.1.2.0 bap-symbol-reader.1.2.0 bap-std.1.2.0 bap-signatures.1.2.0 bap-print.1.2.0 bap-objdump.1.2.0 bap-microx.1.2.0 bap-mc.1.2.0 bap-llvm.1.2.0 bap-ida-python.1.2.0 bap-ida-plugin.1.2.0 bap-ida.1.2.0 bap-future.1.2.0 bap-frontend.1.2.0 bap-frontc.1.2.0 bap-dump-symbols.1.2.0 bap-demangle.1.2.0 bap-cxxfilt.1.2.0 bap-callsites.1.2.0 bap-cache.1.2.0 bap-c.1.2.0 bap-byteweight-frontend.1.2.0 bap-byteweight.1.2.0 bap-beagle.1.2.0 bap-arm.1.2.0 bap-api.1.2.0 bap-abi.1.2.0 bap.1.2.0 angstrom.0.16.0" 

You are using opam 2.1+, where external dependency handling has been integrated: consider calling opam directly, the 'depext' plugin interface is provided for backwards compatibility only
# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
[ERROR] No solution for bap-fsi-benchmark.1.2.0 & zed.3.1.0 & zarith.1.13 & variantslib.113.24.00 & uuidm.0.9.7 & utop.2.9.2 & uri.4.2.0 & typerep.113.24.00 & trie.1.0.0 & topkg.1.0.4 & text-tags.1.2.0 & stringext.1.6.0 & stdlib-shims.0.3.0 & sexplib.113.33.00+4.03 & seq.0.3.1 & result.1.5 & regular.1.3.0 & react.1.2.1 & re.1.11.0 & ppxfind.1.4 & ppx_variants_conv.113.33.00+4.03 & ppx_typerep_conv.113.33.00+4.03 & ppx_type_conv.113.33.02+4.03 & ppx_tools.5.0 & ppx_sexp_value.113.33.00+4.03 & ppx_sexp_message.113.33.00+4.03 & ppx_sexp_conv.113.33.01+4.03 & ppx_pipebang.113.33.00+4.03 & ppx_optcomp.113.33.01+4.03 & ppx_let.113.33.00+4.03 & ppx_jane.113.33.00 & ppx_inline_test.113.33.00+4.03 & ppx_here.113.33.00 & ppx_fields_conv.113.33.00+4.03 & ppx_fail.113.33.00+4.03 & ppx_expect.113.33.01+4.03 & ppx_enumerate.113.33.00+4.03 & ppx_driver.113.33.02+4.03 & ppx_deriving.4.5-1 & ppx_derivers.1.2.1 & ppx_custom_printf.113.33.00+4.03 & ppx_core.113.33.01+4.03 & ppx_compare.113.33.00+4.03 & ppx_bin_prot.113.33.00+4.03 & ppx_bench.113.33.00+4.03 & ppx_assert.113.33.00 & ocurl.0.9.2 & ocplib-endian.1.2 & ocamlmod.0.0.9 & ocamlify.0.0.1 & ocamlgraph.2.0.0 & ocamlfind.1.9.6 & ocamlbuild.0.14.3 & ocaml-syntax-shims.1.0.0 & ocaml-migrate-parsetree.1.8.0 & oasis.0.4.7 & mmap.1.2.0 & mew_vi.0.5.0 & mew.0.1.0 & lwt_react.1.1.5 & lwt_log.1.1.2 & lwt.5.5.0 & lambda-term.3.1.0 & graphlib.1.2.0 & fileutils.0.6.4 & fieldslib.113.24.00 & FrontC.3.4.3-1 & dune-configurator.3.13.0 & dune.3.13.0 & csexp.1.5.2 & cppo.1.6.9 & core_kernel.113.33.02+4.03 & conf-zlib.1 & conf-which.1 & conf-pkg-config.3 & conf-libcurl.2 & conf-ida.0.3 & conf-gmp.4 & conf-env-travis.1 & conf-clang.1 & conf-binutils.0.2 & conf-bap-llvm.1.6 & cmdliner.0.9.8 & charInfo_width.1.1.0 & camomile.1.0.2 & camlzip.1.10 & bin_prot.113.33.00+4.03 & bigstringaf.0.8.0 & bigarray-compat.1.1.0 & base-bytes.base & bap-x86.1.2.0 & bap-warn-unused.1.2.0 & bap-traces.1.2.0 & bap-trace.1.2.0 & bap-term-mapper.1.2.0 & bap-taint-propagator.1.2.0 & bap-taint.1.2.0 & bap-symbol-reader.1.2.0 & bap-std.1.2.0 & bap-signatures.1.2.0 & bap-print.1.2.0 & bap-objdump.1.2.0 & bap-microx.1.2.0 & bap-mc.1.2.0 & bap-llvm.1.2.0 & bap-ida-python.1.2.0 & bap-ida-plugin.1.2.0 & bap-ida.1.2.0 & bap-future.1.2.0 & bap-frontend.1.2.0 & bap-frontc.1.2.0 & bap-dump-symbols.1.2.0 & bap-demangle.1.2.0 & bap-cxxfilt.1.2.0 & bap-callsites.1.2.0 & bap-cache.1.2.0 & bap-c.1.2.0 & bap-byteweight-frontend.1.2.0 & bap-byteweight.1.2.0 & bap-beagle.1.2.0 & bap-arm.1.2.0 & bap-api.1.2.0 & bap-abi.1.2.0 & bap.1.2.0 & angstrom.0.16.0:   * Missing dependency:
            - conf-bap-llvm
            depends on the unavailable system package 'llvm-9-dev'. Use `--no-depexts' to attempt installation anyway, or it is possible that a depext package name in the opam file is incorrect.


Command failed: opam --cli=2.1 list --readonly --external '--resolve=bap-fsi-benchmark.1.2.0,zed.3.1.0,zarith.1.13,variantslib.113.24.00,uuidm.0.9.7,utop.2.9.2,uri.4.2.0,typerep.113.24.00,trie.1.0.0,topkg.1.0.4,text-tags.1.2.0,stringext.1.6.0,stdlib-shims.0.3.0,sexplib.113.33.00+4.03,seq.0.3.1,result.1.5,regular.1.3.0,react.1.2.1,re.1.11.0,ppxfind.1.4,ppx_variants_conv.113.33.00+4.03,ppx_typerep_conv.113.33.00+4.03,ppx_type_conv.113.33.02+4.03,ppx_tools.5.0,ppx_sexp_value.113.33.00+4.03,ppx_sexp_message.113.33.00+4.03,ppx_sexp_conv.113.33.01+4.03,ppx_pipebang.113.33.00+4.03,ppx_optcomp.113.33.01+4.03,ppx_let.113.33.00+4.03,ppx_jane.113.33.00,ppx_inline_test.113.33.00+4.03,ppx_here.113.33.00,ppx_fields_conv.113.33.00+4.03,ppx_fail.113.33.00+4.03,ppx_expect.113.33.01+4.03,ppx_enumerate.113.33.00+4.03,ppx_driver.113.33.02+4.03,ppx_deriving.4.5-1,ppx_derivers.1.2.1,ppx_custom_printf.113.33.00+4.03,ppx_core.113.33.01+4.03,ppx_compare.113.33.00+4.03,ppx_bin_prot.113.33.00+4.03,ppx_bench.113.33.00+4.03,ppx_assert.113.33.00,ocurl.0.9.2,ocplib-endian.1.2,ocamlmod.0.0.9,ocamlify.0.0.1,ocamlgraph.2.0.0,ocamlfind.1.9.6,ocamlbuild.0.14.3,ocaml-syntax-shims.1.0.0,ocaml-migrate-parsetree.1.8.0,oasis.0.4.7,mmap.1.2.0,mew_vi.0.5.0,mew.0.1.0,lwt_react.1.1.5,lwt_log.1.1.2,lwt.5.5.0,lambda-term.3.1.0,graphlib.1.2.0,fileutils.0.6.4,fieldslib.113.24.00,FrontC.3.4.3-1,dune-configurator.3.13.0,dune.3.13.0,csexp.1.5.2,cppo.1.6.9,core_kernel.113.33.02+4.03,conf-zlib.1,conf-which.1,conf-pkg-config.3,conf-libcurl.2,conf-ida.0.3,conf-gmp.4,conf-env-travis.1,conf-clang.1,conf-binutils.0.2,conf-bap-llvm.1.6,cmdliner.0.9.8,charInfo_width.1.1.0,camomile.1.0.2,camlzip.1.10,bin_prot.113.33.00+4.03,bigstringaf.0.8.0,bigarray-compat.1.1.0,base-bytes.base,bap-x86.1.2.0,bap-warn-unused.1.2.0,bap-traces.1.2.0,bap-trace.1.2.0,bap-term-mapper.1.2.0,bap-taint-propagator.1.2.0,bap-taint.1.2.0,bap-symbol-reader.1.2.0,bap-std.1.2.0,bap-signatures.1.2.0,bap-print.1.2.0,bap-objdump.1.2.0,bap-microx.1.2.0,bap-mc.1.2.0,bap-llvm.1.2.0,bap-ida-python.1.2.0,bap-ida-plugin.1.2.0,bap-ida.1.2.0,bap-future.1.2.0,bap-frontend.1.2.0,bap-frontc.1.2.0,bap-dump-symbols.1.2.0,bap-demangle.1.2.0,bap-cxxfilt.1.2.0,bap-callsites.1.2.0,bap-cache.1.2.0,bap-c.1.2.0,bap-byteweight-frontend.1.2.0,bap-byteweight.1.2.0,bap-beagle.1.2.0,bap-arm.1.2.0,bap-api.1.2.0,bap-abi.1.2.0,bap.1.2.0,angstrom.0.16.0' returned 20
OCaml

Innovation. Community. Security.