cppo_ocamlbuild

Plugin to use cppo with ocamlbuild
Overview Documentation
Description

This ocamlbuild plugin lets you use cppo in ocamlbuild projects.

To use it, you can call ocamlbuild with the argument -plugin-tag package(cppo_ocamlbuild) (only since ocaml 4.01 and cppo >= 0.9.4).

Install
Published
20 May 2022
Sources
v1.6.9.tar.gz
md5=d23ffe85ac7dc8f0afd1ddf622770d09
sha512=26ff5a7b7f38c460661974b23ca190f0feae3a99f1974e0fd12ccf08745bd7d91b7bc168c70a5385b837bfff9530e0e4e41cf269f23dd8cf16ca658008244b44
Dependencies
Reverse Dependencies
0install
= "2.12.3"
bau
>= "0.0.4"
bisect_ppx
= "1.2.0"
cconv
= "0.4"
decompress
= "0.2"
General
< "0.4.0"
hdf5
>= "0.1.2" & < "0.1.5"
jupyter
< "2.0.0"
lilis
>= "0.2.1"
lwt
>= "2.7.1" & < "3.1.0"
oml
= "0.0.6"
pla
< "1.2"
ppx_bigarray
>= "0.0.1" & < "3.0.0"
ppx_deriving
>= "3.3" & < "4.3"
ppx_deriving_protobuf
>= "2.4" & < "2.7"
ppx_deriving_yojson
>= "3.0" & < "3.3"
ppx_getenv
= "1.2"
ppx_import
< "1.5-3-gbd627d5"
ppx_include
>= "1.1"
rpc
>= "1.9.51" & < "5.9.0"
shcaml
>= "0.2.0"
sqlexpr
>= "0.7.1" & < "0.9.0"
touist
>= "3.1.0" & != "3.4.0" & < "3.5.0"
utop
>= "1.16" & < "2.0.0"
visitors
>= "20170404" & < "20200207"
websocket
>= "2.3" & < "2.10"