package git

  1. Overview
  2. No Docs
Git format and protocol in pure OCaml

Install

Dune Dependency

Authors

Maintainers

Sources

git-3.4.0.tbz
sha256=6eef1240c7c85a8e495b82ef863c509ad41d75e0c45cf73c34ed1bdafd03413f
sha512=5fc02e4ea5fccf2386ddfcf5a15f1c11f49c982ffce0296bd5c00ba3f6510de3515e1ac80add7fe20cc8e3dc6516bbf233156ab9dd70eab7a12f7097ae49da27

Description

Support for on-disk and in-memory Git stores. Can read and write all the Git objects: the usual blobs, trees, commits and tags but also the pack files, pack indexes and the index file (where the staging area lives).

All the objects share a consistent API, and convenience functions are provided to manipulate the different objects.

Published: 23 Apr 2021

Dependencies (33)

  1. uri >= "4.1.0"
  2. psq >= "0.2.0"
  3. ipaddr >= "5.0.1"
  4. emile >= "1.1"
  5. domain-name >= "0.3.0"
  6. mirage-flow >= "2.0.1"
  7. hxd >= "0.3.1"
  8. fpath
  9. encore >= "0.8"
  10. fpath
  11. astring
  12. ocamlgraph >= "1.8.8"
  13. checkseum >= "0.2.1"
  14. fmt >= "0.8.7"
  15. ke >= "0.4"
  16. carton-git >= "0.4.1"
  17. carton-lwt >= "0.4.1"
  18. carton >= "0.4.1"
  19. angstrom >= "0.14.0"
  20. cstruct >= "5.0.0" & < "6.1.0"
  21. mimic
  22. lwt
  23. logs
  24. decompress >= "1.4.0" & < "1.4.3"
  25. optint
  26. bigarray-compat
  27. bigstringaf < "0.9.0"
  28. result
  29. base64 >= "3.0.0"
  30. rresult
  31. digestif >= "0.8.1"
  32. dune >= "2.8.0"
  33. ocaml >= "4.08.0"

Dev Dependencies (6)

  1. crowbar >= "0.2" & with-test
  2. base-unix with-test
  3. cmdliner with-test
  4. mirage-crypto-rng with-test & >= "0.8.0"
  5. alcotest-lwt with-test & >= "1.1.0"
  6. alcotest with-test & >= "1.1.0"

Used by (18)

  1. datakit != "0.12.0"
  2. docteur < "0.0.3"
  3. docteur-solo5 < "0.0.3"
  4. docteur-unix < "0.0.3"
  5. dog
  6. git-cohttp = "3.4.0"
  7. git-cohttp-unix = "3.4.0"
  8. git-mirage < "1.11.4" | = "3.4.0"
  9. git-paf < "3.5.0"
  10. git-unix = "3.4.0"
  11. imaplet-lwt >= "0.1.3"
  12. irmin >= "0.9.0" & != "0.10.1" & < "0.11.1"
  13. irmin-git >= "2.6.0" & < "2.8.0"
  14. irmin-mirage-git >= "2.5.1" & < "2.8.0"
  15. irmin-mirage-graphql >= "2.5.1"
  16. irmin-unix < "0.9.9" | >= "2.5.4" & < "2.8.0"
  17. merge-queues >= "0.2.0"
  18. plotkicadsch >= "0.5.0" & < "0.6.1" | >= "0.9.0"

Conflicts

None

OCaml

Innovation. Community. Security.