labrys

A toy language based on LLVM that implements the System Fω type-system

Error log

The package failed to build. The error log from opam follows.

You are using opam 2.1+, where external dependency handling has been integrated: consider calling opam directly, the 'depext' plugin interface is provided for backwards compatibility only
# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
[ERROR] No solution for labrys.0.1 & base-bytes.base & bigarray-compat.1.1.0 & cmdliner.1.1.1 & conf-cmake.1 & conf-llvm.12.0.1 & conf-python-2-7.1.2 & containers.2.8.1 & csexp.1.5.1 & ctypes.0.20.1 & dune.3.5.0 & dune-configurator.3.5.0 & integers.0.7.0 & llvm.12.0.1 & menhir.20211128 & menhirLib.20211128 & menhirSdk.20211128 & msgpack.1.3.0 & num.1.4 & ocamlbuild.0.14.2 & ocamlfind.1.9.5 & pprint.20211129 & re.1.10.4 & seq.base & stdlib-shims.0.3.0 & topkg.1.0.5 & uutf.1.0.3:   * Missing dependency:
            - conf-llvm = 12.0.1
            depends on the unavailable system package 'llvm-12-dev'. Use `--no-depexts' to attempt installation anyway, or it is possible that a depext package name in the opam file is incorrect.


Command failed: opam --cli=2.1 list --readonly --external '--resolve=labrys.0.1,base-bytes.base,bigarray-compat.1.1.0,cmdliner.1.1.1,conf-cmake.1,conf-llvm.12.0.1,conf-python-2-7.1.2,containers.2.8.1,csexp.1.5.1,ctypes.0.20.1,dune.3.5.0,dune-configurator.3.5.0,integers.0.7.0,llvm.12.0.1,menhir.20211128,menhirLib.20211128,menhirSdk.20211128,msgpack.1.3.0,num.1.4,ocamlbuild.0.14.2,ocamlfind.1.9.5,pprint.20211129,re.1.10.4,seq.base,stdlib-shims.0.3.0,topkg.1.0.5,uutf.1.0.3' returned 20