package lbvs_consent

  1. Overview
  2. Docs
On This Page
  1. Error log

lbvs_consent 2.2.0

Error log

The package failed to build. The error log from opam follows.

Opam plugin "depext" may require upgrading/reinstalling. Reinstall the plugin on the current switch? [Y/n] y
The following actions will be performed:
  - recompile opam-depext 1.2.1-1

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved opam-depext.1.2.1-1  (cached)
-> removed   opam-depext.1.2.1-1
-> installed opam-depext.1.2.1-1
Done.

<><> opam-depext.1.2.1-1 installed successfully <><><><><><><><><><><><><><><><>
=> opam-depext is unnecessary when used with opam >= 2.1. Please use opam install directly instead
# Run eval $(opam env) to update the current shell environment

<><> Carrying on to "opam depext -viy lbvs_consent.2.2.0 vpt.5.0.0 stdlib-shims.0.3.0 sexplib0.v0.16.0 seq.base qcheck-ounit.0.21.2 qcheck-core.0.21.2 qcheck.0.21.2 ppxlib.0.30.0 ppx_derivers.1.2.1 parany.14.0.0 ounit2.2.2.7 ocamlfind.1.9.6 ocaml-compiler-libs.v0.12.4 num.1.4 minicli.5.0.2 extunix.0.4.1 dune-configurator.3.10.0 dune.3.10.0 dolog.6.0.0 dokeysto.4.0.1 csexp.1.5.2 cpu.2.0.0 cpm.12.2.0 conf-zlib.1 conf-which.1 conf-rdkit.1 conf-python-3.9.0.0 conf-pkg-config.3 conf-openbabel.0.1 conf-boost.1 conf-autoconf.0.1 camlzip.1.11 camlp-streams.5.0.1 bitv.1.6 batteries.3.7.1 base-bytes.base" 

You are using opam 2.1+, where external dependency handling has been integrated: consider calling opam directly, the 'depext' plugin interface is provided for backwards compatibility only
# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
# The following system packages are needed:
autoconf
debianutils
libboost-dev
libopenbabel-dev
librdkit-dev
pkg-config
python3
python3-rdkit
zlib1g-dev
[NOTE] Package dune is already installed (current version is 3.10.0).
[NOTE] Package ocamlfind is already installed (current version is 1.9.6).
The following actions will be performed:
  - install ppx_derivers        1.2.1
  - install minicli             5.0.2
  - install dolog               6.0.0
  - install conf-openbabel      0.1
  - install seq                 base
  - install conf-rdkit          1
  - install ocaml-compiler-libs v0.12.4
  - install base-bytes          base
  - install stdlib-shims        0.3.0
  - install conf-python-3       9.0.0
  - install vpt                 5.0.0
  - install conf-pkg-config     3
  - install conf-boost          1
  - install csexp               1.5.2
  - install conf-which          1
  - install num                 1.4
  - install camlp-streams       5.0.1
  - install bitv                1.6
  - install sexplib0            v0.16.0
  - install qcheck-core         0.21.2
  - install ounit2              2.2.7
  - install conf-zlib           1
  - install dune-configurator   3.10.0
  - install conf-autoconf       0.1
  - install batteries           3.7.1
  - install ppxlib              0.30.0
  - install qcheck-ounit        0.21.2
  - install camlzip             1.11
  - install cpu                 2.0.0
  - install cpm                 12.2.0
  - install extunix             0.4.1
  - install qcheck              0.21.2
  - install parany              14.0.0
  - install dokeysto            4.0.1
  - install lbvs_consent        2.2.0
===== 35 to install =====

The following system packages will first need to be installed:
    autoconf libboost-dev libopenbabel-dev librdkit-dev pkg-config python3 python3-rdkit zlib1g-dev

<><> Handling external dependencies <><><><><><><><><><><><><><><><><><><><><><>
Let opam run your package manager to install the required system packages?
(answer 'n' for other options) [Y/n] y
+ /usr/bin/sudo "apt-get" "install" "-qq" "-yy" "autoconf" "libboost-dev" "libopenbabel-dev" "librdkit-dev" "pkg-config" "python3" "python3-rdkit" "zlib1g-dev"
- debconf: delaying package configuration, since apt-utils is not installed
- Selecting previously unselected package libpython3.11-minimal:amd64.
- (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 18774 files and directories currently installed.)
- Preparing to unpack .../libpython3.11-minimal_3.11.2-6_amd64.deb ...
- Unpacking libpython3.11-minimal:amd64 (3.11.2-6) ...
- Selecting previously unselected package python3.11-minimal.
- Preparing to unpack .../python3.11-minimal_3.11.2-6_amd64.deb ...
- Unpacking python3.11-minimal (3.11.2-6) ...
- Setting up libpython3.11-minimal:amd64 (3.11.2-6) ...
- Setting up python3.11-minimal (3.11.2-6) ...
- Selecting previously unselected package python3-minimal.
- (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 19081 files and directories currently installed.)
- Preparing to unpack .../python3-minimal_3.11.2-1+b1_amd64.deb ...
- Unpacking python3-minimal (3.11.2-1+b1) ...
- Selecting previously unselected package media-types.
- Preparing to unpack .../media-types_10.0.0_all.deb ...
- Unpacking media-types (10.0.0) ...
- Selecting previously unselected package libpython3.11-stdlib:amd64.
- Preparing to unpack .../libpython3.11-stdlib_3.11.2-6_amd64.deb ...
- Unpacking libpython3.11-stdlib:amd64 (3.11.2-6) ...
- Selecting previously unselected package python3.11.
- Preparing to unpack .../python3.11_3.11.2-6_amd64.deb ...
- Unpacking python3.11 (3.11.2-6) ...
- Selecting previously unselected package libpython3-stdlib:amd64.
- Preparing to unpack .../libpython3-stdlib_3.11.2-1+b1_amd64.deb ...
- Unpacking libpython3-stdlib:amd64 (3.11.2-1+b1) ...
- Setting up python3-minimal (3.11.2-1+b1) ...
- Selecting previously unselected package python3.
- (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 19491 files and directories currently installed.)
- Preparing to unpack .../00-python3_3.11.2-1+b1_amd64.deb ...
- Unpacking python3 (3.11.2-1+b1) ...
- Selecting previously unselected package m4.
- Preparing to unpack .../01-m4_1.4.19-3_amd64.deb ...
- Unpacking m4 (1.4.19-3) ...
- Selecting previously unselected package autoconf.
- Preparing to unpack .../02-autoconf_2.71-3_all.deb ...
- Unpacking autoconf (2.71-3) ...
- Selecting previously unselected package autotools-dev.
- Preparing to unpack .../03-autotools-dev_20220109.1_all.deb ...
- Unpacking autotools-dev (20220109.1) ...
- Selecting previously unselected package automake.
- Preparing to unpack .../04-automake_1%3a1.16.5-1.3_all.deb ...
- Unpacking automake (1:1.16.5-1.3) ...
- Selecting previously unselected package fonts-freefont-ttf.
- Preparing to unpack .../05-fonts-freefont-ttf_20120503-10_all.deb ...
- Unpacking fonts-freefont-ttf (20120503-10) ...
- Selecting previously unselected package libblas3:amd64.
- Preparing to unpack .../06-libblas3_3.11.0-2_amd64.deb ...
- Unpacking libblas3:amd64 (3.11.0-2) ...
- Selecting previously unselected package libboost1.74-dev:amd64.
- Preparing to unpack .../07-libboost1.74-dev_1.74.0+ds1-21_amd64.deb ...
- Unpacking libboost1.74-dev:amd64 (1.74.0+ds1-21) ...
- Selecting previously unselected package libboost-dev:amd64.
- Preparing to unpack .../08-libboost-dev_1.74.0.3_amd64.deb ...
- Unpacking libboost-dev:amd64 (1.74.0.3) ...
- Selecting previously unselected package libboost-iostreams1.74.0:amd64.
- Preparing to unpack .../09-libboost-iostreams1.74.0_1.74.0+ds1-21_amd64.deb ...
- Unpacking libboost-iostreams1.74.0:amd64 (1.74.0+ds1-21) ...
- Selecting previously unselected package libboost-python1.74.0.
- Preparing to unpack .../10-libboost-python1.74.0_1.74.0+ds1-21_amd64.deb ...
- Unpacking libboost-python1.74.0 (1.74.0+ds1-21) ...
- Selecting previously unselected package libboost-serialization1.74.0:amd64.
- Preparing to unpack .../11-libboost-serialization1.74.0_1.74.0+ds1-21_amd64.deb ...
- Unpacking libboost-serialization1.74.0:amd64 (1.74.0+ds1-21) ...
- Selecting previously unselected package libpixman-1-0:amd64.
- Preparing to unpack .../12-libpixman-1-0_0.42.2-1_amd64.deb ...
- Unpacking libpixman-1-0:amd64 (0.42.2-1) ...
- Selecting previously unselected package libxcb-render0:amd64.
- Preparing to unpack .../13-libxcb-render0_1.15-1_amd64.deb ...
- Unpacking libxcb-render0:amd64 (1.15-1) ...
- Selecting previously unselected package libxcb-shm0:amd64.
- Preparing to unpack .../14-libxcb-shm0_1.15-1_amd64.deb ...
- Unpacking libxcb-shm0:amd64 (1.15-1) ...
- Selecting previously unselected package libxrender1:amd64.
- Preparing to unpack .../15-libxrender1_1%3a0.9.10-1.1_amd64.deb ...
- Unpacking libxrender1:amd64 (1:0.9.10-1.1) ...
- Selecting previously unselected package libcairo2:amd64.
- Preparing to unpack .../16-libcairo2_1.16.0-7_amd64.deb ...
- Unpacking libcairo2:amd64 (1.16.0-7) ...
- Selecting previously unselected package libcoordgen3:amd64.
- Preparing to unpack .../17-libcoordgen3_3.0.1-1_amd64.deb ...
- Unpacking libcoordgen3:amd64 (3.0.1-1) ...
- Selecting previously unselected package libgfortran5:amd64.
- Preparing to unpack .../18-libgfortran5_12.2.0-14_amd64.deb ...
- Unpacking libgfortran5:amd64 (12.2.0-14) ...
- Selecting previously unselected package libicu72:amd64.
- Preparing to unpack .../19-libicu72_72.1-3_amd64.deb ...
- Unpacking libicu72:amd64 (72.1-3) ...
- Selecting previously unselected package libinchi1.
- Preparing to unpack .../20-libinchi1_1.03+dfsg-4+b2_amd64.deb ...
- Unpacking libinchi1 (1.03+dfsg-4+b2) ...
- Selecting previously unselected package liblapack3:amd64.
- Preparing to unpack .../21-liblapack3_3.11.0-2_amd64.deb ...
- Unpacking liblapack3:amd64 (3.11.0-2) ...
- Selecting previously unselected package libmaeparser1:amd64.
- Preparing to unpack .../22-libmaeparser1_1.3.0-1_amd64.deb ...
- Unpacking libmaeparser1:amd64 (1.3.0-1) ...
- Selecting previously unselected package libxml2:amd64.
- Preparing to unpack .../23-libxml2_2.9.14+dfsg-1.3~deb12u1_amd64.deb ...
- Unpacking libxml2:amd64 (2.9.14+dfsg-1.3~deb12u1) ...
- Selecting previously unselected package libopenbabel7.
- Preparing to unpack .../24-libopenbabel7_3.1.1+dfsg-9+b3_amd64.deb ...
- Unpacking libopenbabel7 (3.1.1+dfsg-9+b3) ...
- Selecting previously unselected package libopenbabel-dev.
- Preparing to unpack .../25-libopenbabel-dev_3.1.1+dfsg-9+b3_amd64.deb ...
- Unpacking libopenbabel-dev (3.1.1+dfsg-9+b3) ...
- Selecting previously unselected package libpkgconf3:amd64.
- Preparing to unpack .../26-libpkgconf3_1.8.1-1_amd64.deb ...
- Unpacking libpkgconf3:amd64 (1.8.1-1) ...
- Selecting previously unselected package libpython3.11:amd64.
- Preparing to unpack .../27-libpython3.11_3.11.2-6_amd64.deb ...
- Unpacking libpython3.11:amd64 (3.11.2-6) ...
- Selecting previously unselected package librdkit1.
- Preparing to unpack .../28-librdkit1_202209.3-1_amd64.deb ...
- Unpacking librdkit1 (202209.3-1) ...
- Selecting previously unselected package librdkit-dev.
- Preparing to unpack .../29-librdkit-dev_202209.3-1_amd64.deb ...
- Unpacking librdkit-dev (202209.3-1) ...
- Selecting previously unselected package pkgconf-bin.
- Preparing to unpack .../30-pkgconf-bin_1.8.1-1_amd64.deb ...
- Unpacking pkgconf-bin (1.8.1-1) ...
- Selecting previously unselected package pkgconf:amd64.
- Preparing to unpack .../31-pkgconf_1.8.1-1_amd64.deb ...
- Unpacking pkgconf:amd64 (1.8.1-1) ...
- Selecting previously unselected package pkg-config:amd64.
- Preparing to unpack .../32-pkg-config_1.8.1-1_amd64.deb ...
- Unpacking pkg-config:amd64 (1.8.1-1) ...
- Selecting previously unselected package python3-pkg-resources.
- Preparing to unpack .../33-python3-pkg-resources_66.1.1-1_all.deb ...
- Unpacking python3-pkg-resources (66.1.1-1) ...
- Selecting previously unselected package python3-numpy.
- Preparing to unpack .../34-python3-numpy_1%3a1.24.2-1_amd64.deb ...
- Unpacking python3-numpy (1:1.24.2-1) ...
- Selecting previously unselected package rdkit-data.
- Preparing to unpack .../35-rdkit-data_202209.3-1_all.deb ...
- Unpacking rdkit-data (202209.3-1) ...
- Selecting previously unselected package python3-rdkit.
- Preparing to unpack .../36-python3-rdkit_202209.3-1_amd64.deb ...
- Unpacking python3-rdkit (202209.3-1) ...
- Selecting previously unselected package zlib1g-dev:amd64.
- Preparing to unpack .../37-zlib1g-dev_1%3a1.2.13.dfsg-1_amd64.deb ...
- Unpacking zlib1g-dev:amd64 (1:1.2.13.dfsg-1) ...
- Setting up media-types (10.0.0) ...
- Setting up libpixman-1-0:amd64 (0.42.2-1) ...
- Setting up libboost1.74-dev:amd64 (1.74.0+ds1-21) ...
- Setting up libicu72:amd64 (72.1-3) ...
- Setting up libxrender1:amd64 (1:0.9.10-1.1) ...
- Setting up libxcb-render0:amd64 (1.15-1) ...
- Setting up libboost-iostreams1.74.0:amd64 (1.74.0+ds1-21) ...
- Setting up libpython3.11-stdlib:amd64 (3.11.2-6) ...
- Setting up fonts-freefont-ttf (20120503-10) ...
- Setting up m4 (1.4.19-3) ...
- Setting up libxcb-shm0:amd64 (1.15-1) ...
- Setting up rdkit-data (202209.3-1) ...
- Setting up libcairo2:amd64 (1.16.0-7) ...
- Setting up libmaeparser1:amd64 (1.3.0-1) ...
- Setting up autotools-dev (20220109.1) ...
- Setting up libblas3:amd64 (3.11.0-2) ...
- update-alternatives: using /usr/lib/x86_64-linux-gnu/blas/libblas.so.3 to provide /usr/lib/x86_64-linux-gnu/libblas.so.3 (libblas.so.3-x86_64-linux-gnu) in auto mode
- Setting up libpkgconf3:amd64 (1.8.1-1) ...
- Setting up pkgconf-bin (1.8.1-1) ...
- Setting up libgfortran5:amd64 (12.2.0-14) ...
- Setting up autoconf (2.71-3) ...
- Setting up libboost-serialization1.74.0:amd64 (1.74.0+ds1-21) ...
- Setting up zlib1g-dev:amd64 (1:1.2.13.dfsg-1) ...
- Setting up libboost-dev:amd64 (1.74.0.3) ...
- Setting up libcoordgen3:amd64 (3.0.1-1) ...
- Setting up libboost-python1.74.0 (1.74.0+ds1-21) ...
- Setting up libxml2:amd64 (2.9.14+dfsg-1.3~deb12u1) ...
- Setting up libpython3-stdlib:amd64 (3.11.2-1+b1) ...
- Setting up libinchi1 (1.03+dfsg-4+b2) ...
- Setting up automake (1:1.16.5-1.3) ...
- update-alternatives: using /usr/bin/automake-1.16 to provide /usr/bin/automake (automake) in auto mode
- Setting up python3.11 (3.11.2-6) ...
- Setting up liblapack3:amd64 (3.11.0-2) ...
- update-alternatives: using /usr/lib/x86_64-linux-gnu/lapack/liblapack.so.3 to provide /usr/lib/x86_64-linux-gnu/liblapack.so.3 (liblapack.so.3-x86_64-linux-gnu) in auto mode
- Setting up libpython3.11:amd64 (3.11.2-6) ...
- Setting up librdkit1 (202209.3-1) ...
- Setting up libopenbabel7 (3.1.1+dfsg-9+b3) ...
- Setting up python3 (3.11.2-1+b1) ...
- running python rtupdate hooks for python3.11...
- running python post-rtupdate hooks for python3.11...
- Setting up pkgconf:amd64 (1.8.1-1) ...
- Setting up libopenbabel-dev (3.1.1+dfsg-9+b3) ...
- Setting up librdkit-dev (202209.3-1) ...
- Setting up pkg-config:amd64 (1.8.1-1) ...
- Setting up python3-pkg-resources (66.1.1-1) ...
- Setting up python3-numpy (1:1.24.2-1) ...
- Setting up python3-rdkit (202209.3-1) ...
- Processing triggers for libc-bin (2.36-9+deb12u1) ...

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
Processing  2/105:
Processing  3/105:
Processing  4/105:
Processing  5/105:
-> installed base-bytes.base
Processing  6/105:
-> retrieved batteries.3.7.1  (cached)
Processing  7/105:
-> retrieved bitv.1.6  (cached)
Processing  8/105:
Processing  9/105:
Processing 10/105:
Processing 11/105:
Processing 12/105:
Processing 13/105:
Processing 14/105:
Processing 15/105:
Processing 16/105:
Processing 17/105: [bitv: dune build]
Processing 18/105: [bitv: dune build]
Processing 19/105: [bitv: dune build] [conf-openbabel: c++ test.cpp]
Processing 20/105: [bitv: dune build] [conf-openbabel: c++ test.cpp] [conf-pkg-config: pkg-config]
Processing 21/105: [bitv: dune build] [conf-openbabel: c++ test.cpp] [conf-pkg-config: pkg-config] [conf-python-3: python3 test.py]
Processing 22/105: [bitv: dune build] [conf-openbabel: c++ test.cpp] [conf-pkg-config: pkg-config] [conf-python-3: python3 test.py] [conf-rdkit: sh]
Processing 23/105: [bitv: dune build] [conf-openbabel: c++ test.cpp] [conf-pkg-config: pkg-config] [conf-python-3: python3 test.py] [conf-rdkit: sh] [conf-which: which which]
-> installed conf-boost.1
Processing 24/105: [bitv: dune build] [conf-openbabel: c++ test.cpp] [conf-pkg-config: pkg-config] [conf-python-3: python3 test.py] [conf-rdkit: sh] [conf-which: which which]
-> retrieved camlp-streams.5.0.1  (cached)
Processing 25/105: [bitv: dune build] [conf-openbabel: c++ test.cpp] [conf-pkg-config: pkg-config] [conf-python-3: python3 test.py] [conf-rdkit: sh] [conf-which: which which]
Processing 26/105: [bitv: dune build] [camlp-streams: dune build] [conf-openbabel: c++ test.cpp] [conf-pkg-config: pkg-config] [conf-python-3: python3 test.py] [conf-rdkit: sh] [conf-which: which which]
-> retrieved camlzip.1.11  (cached)
Processing 27/105: [bitv: dune build] [camlp-streams: dune build] [conf-openbabel: c++ test.cpp] [conf-pkg-config: pkg-config] [conf-python-3: python3 test.py] [conf-rdkit: sh] [conf-which: which which]
-> retrieved cpm.12.2.0  (cached)
Processing 28/105: [bitv: dune build] [camlp-streams: dune build] [conf-openbabel: c++ test.cpp] [conf-pkg-config: pkg-config] [conf-python-3: python3 test.py] [conf-rdkit: sh] [conf-which: which which]
- test.cpp:1:10: fatal error: openbabel/mol.h: No such file or directory
-     1 | #include <openbabel/mol.h>
-       |          ^~~~~~~~~~~~~~~~~
- compilation terminated.
[ERROR] The compilation of conf-openbabel.0.1 failed at "c++ -I/usr/include/openbabel-2.0 test.cpp -lopenbabel".
Processing 28/105: [bitv: dune build] [camlp-streams: dune build] [conf-pkg-config: pkg-config] [conf-python-3: python3 test.py] [conf-rdkit: sh] [conf-which: which which]
Processing 29/105: [bitv: dune build] [camlp-streams: dune build] [conf-pkg-config: pkg-config] [conf-python-3: python3 test.py] [conf-rdkit: sh] [conf-which: which which]
- usage: pkgconf [OPTIONS] [LIBRARIES]
- 
- basic options:
- 
-   --help                            this message
-   --about                           print pkgconf version and license to stdout
-   --version                         print supported pkg-config version to stdout
-   --atleast-pkgconfig-version       check whether or not pkgconf is compatible
-                                     with a specified pkg-config version
-   --errors-to-stdout                print all errors on stdout instead of stderr
-   --print-errors                    ensure all errors are printed
-   --short-errors                    be less verbose about some errors
-   --silence-errors                  explicitly be silent about errors
-   --list-all                        list all known packages
-   --list-package-names              list all known package names
-   --simulate                        simulate walking the calculated dependency graph
-   --no-cache                        do not cache already seen packages when
-                                     walking the dependency graph
-   --log-file=filename               write an audit log to a specified file
-   --with-path=path                  adds a directory to the search path
-   --define-prefix                   override the prefix variable with one that is guessed based on
-                                     the location of the .pc file
-   --dont-define-prefix              do not override the prefix variable under any circumstances
-   --prefix-variable=varname         sets the name of the variable that pkgconf considers
-                                     to be the package prefix
-   --relocate=path                   relocates a path and exits (mostly for testsuite)
-   --dont-relocate-paths             disables path relocation support
- 
- cross-compilation personality support:
- 
-   --personality=triplet|filename    sets the personality to 'triplet' or a file named 'filename'
-   --dump-personality                dumps details concerning selected personality
- 
- checking specific pkg-config database entries:
- 
-   --atleast-version                 require a specific version of a module
-   --exact-version                   require an exact version of a module
-   --max-version                     require a maximum version of a module
-   --exists                          check whether or not a module exists
-   --uninstalled                     check whether or not an uninstalled module will be used
-   --no-uninstalled                  never use uninstalled modules when satisfying dependencies
-   --no-provides                     do not use 'provides' rules to resolve dependencies
-   --maximum-traverse-depth          maximum allowed depth for dependency graph
-   --static                          be more aggressive when computing dependency graph
-                                     (for static linking)
-   --shared                          use a simplified dependency graph (usually default)
-   --pure                            optimize a static dependency graph as if it were a normal
-                                     dependency graph
-   --env-only                        look only for package entries in PKG_CONFIG_PATH
-   --ignore-conflicts                ignore 'conflicts' rules in modules
-   --validate                        validate specific .pc files for correctness
- 
- querying specific pkg-config database fields:
- 
-   --define-variable=varname=value   define variable 'varname' as 'value'
-   --variable=varname                print specified variable entry to stdout
-   --cflags                          print required CFLAGS to stdout
-   --cflags-only-I                   print required include-dir CFLAGS to stdout
-   --cflags-only-other               print required non-include-dir CFLAGS to stdout
-   --libs                            print required linker flags to stdout
-   --libs-only-L                     print required LDPATH linker flags to stdout
-   --libs-only-l                     print required LIBNAME linker flags to stdout
-   --libs-only-other                 print required other linker flags to stdout
-   --print-requires                  print required dependency frameworks to stdout
-   --print-requires-private          print required dependency frameworks for static
-                                     linking to stdout
-   --print-provides                  print provided dependencies to stdout
-   --print-variables                 print all known variables in module to stdout
-   --digraph                         print entire dependency graph in graphviz 'dot' format
-   --keep-system-cflags              keep -I/usr/include entries in cflags output
-   --keep-system-libs                keep -L/lib:/lib/i386-linux-gnu:/lib/x86_64-linux-gnu:/lib/x86_64-linux-gnux32:/lib32:/libx32:/usr/lib:/usr/lib/i386-linux-gnu:/usr/lib/x86_64-linux-gnu:/usr/lib/x86_64-linux-gnux32:/usr/lib32:/usr/libx32 entries in libs output
-   --path                            show the exact filenames for any matching .pc files
-   --modversion                      print the specified module's version to stdout
-   --internal-cflags                 do not filter 'internal' cflags from output
- 
- filtering output:
- 
-   --msvc-syntax                     print translatable fragments in MSVC syntax
-   --fragment-filter=types           filter output fragments to the specified types
- 
- report bugs to <https://github.com/pkgconf/pkgconf/issues/new>.
-> compiled  conf-pkg-config.3
Processing 29/105: [bitv: dune build] [camlp-streams: dune build] [conf-python-3: python3 test.py] [conf-rdkit: sh] [conf-which: which which]
-> installed conf-pkg-config.3
Processing 30/105: [bitv: dune build] [camlp-streams: dune build] [conf-python-3: python3 test.py] [conf-rdkit: sh] [conf-which: which which]
Processing 31/105: [bitv: dune build] [camlp-streams: dune build] [conf-python-3: python3 test.py] [conf-rdkit: sh] [conf-which: which which] [conf-zlib: pkg-config zlib]
- python-3 OK
-> compiled  conf-python-3.9.0.0
Processing 31/105: [bitv: dune build] [camlp-streams: dune build] [conf-rdkit: sh] [conf-which: which which] [conf-zlib: pkg-config zlib]
-> installed conf-python-3.9.0.0
Processing 32/105: [bitv: dune build] [camlp-streams: dune build] [conf-rdkit: sh] [conf-which: which which] [conf-zlib: pkg-config zlib]
- /usr/bin/which
-> compiled  conf-which.1
Processing 32/105: [bitv: dune build] [camlp-streams: dune build] [conf-rdkit: sh] [conf-zlib: pkg-config zlib]
-> installed conf-which.1
Processing 33/105: [bitv: dune build] [camlp-streams: dune build] [conf-rdkit: sh] [conf-zlib: pkg-config zlib]
Processing 34/105: [bitv: dune build] [camlp-streams: dune build] [conf-autoconf: which autoconf] [conf-rdkit: sh] [conf-zlib: pkg-config zlib]
-> retrieved cpu.2.0.0  (cached)
Processing 35/105: [bitv: dune build] [camlp-streams: dune build] [conf-autoconf: which autoconf] [conf-rdkit: sh] [conf-zlib: pkg-config zlib]
-> retrieved csexp.1.5.2  (cached)
Processing 36/105: [bitv: dune build] [camlp-streams: dune build] [conf-autoconf: which autoconf] [conf-rdkit: sh] [conf-zlib: pkg-config zlib]
Processing 37/105: [bitv: dune build] [camlp-streams: dune build] [conf-autoconf: which autoconf] [conf-rdkit: sh] [conf-zlib: pkg-config zlib] [csexp: dune build]
-> retrieved dokeysto.4.0.1  (cached)
Processing 38/105: [bitv: dune build] [camlp-streams: dune build] [conf-autoconf: which autoconf] [conf-rdkit: sh] [conf-zlib: pkg-config zlib] [csexp: dune build]
-> compiled  conf-zlib.1
Processing 38/105: [bitv: dune build] [camlp-streams: dune build] [conf-autoconf: which autoconf] [conf-rdkit: sh] [csexp: dune build]
-> installed conf-zlib.1
Processing 39/105: [bitv: dune build] [camlp-streams: dune build] [conf-autoconf: which autoconf] [conf-rdkit: sh] [csexp: dune build]
Processing 40/105: [bitv: dune build] [camlp-streams: dune build] [camlzip: make all] [conf-autoconf: which autoconf] [conf-rdkit: sh] [csexp: dune build]
Processing 40/105: [bitv: dune build] [camlp-streams: dune build] [camlzip: make all] [conf-autoconf: which autoconf] [conf-rdkit: ./test] [csexp: dune build]
- /usr/bin/autoconf
-> compiled  conf-autoconf.0.1
Processing 40/105: [bitv: dune build] [camlp-streams: dune build] [camlzip: make all] [conf-rdkit: ./test] [csexp: dune build]
-> installed conf-autoconf.0.1
Processing 41/105: [bitv: dune build] [camlp-streams: dune build] [camlzip: make all] [conf-rdkit: ./test] [csexp: dune build]
Processing 42/105: [bitv: dune build] [camlp-streams: dune build] [camlzip: make all] [conf-rdkit: ./test] [cpu: autoconf] [csexp: dune build]
-> retrieved dolog.6.0.0  (cached)
Processing 43/105: [bitv: dune build] [camlp-streams: dune build] [camlzip: make all] [conf-rdkit: ./test] [cpu: autoconf] [csexp: dune build]
Processing 44/105: [bitv: dune build] [camlp-streams: dune build] [camlzip: make all] [conf-rdkit: ./test] [cpu: autoconf] [csexp: dune build] [dolog: dune build]
-> retrieved extunix.0.4.1  (cached)
Processing 45/105: [bitv: dune build] [camlp-streams: dune build] [camlzip: make all] [conf-rdkit: ./test] [cpu: autoconf] [csexp: dune build] [dolog: dune build]
- 2022.09.3
-> compiled  conf-rdkit.1
Processing 45/105: [bitv: dune build] [camlp-streams: dune build] [camlzip: make all] [cpu: autoconf] [csexp: dune build] [dolog: dune build]
-> installed conf-rdkit.1
Processing 46/105: [bitv: dune build] [camlp-streams: dune build] [camlzip: make all] [cpu: autoconf] [csexp: dune build] [dolog: dune build]
-> retrieved lbvs_consent.2.2.0  (cached)
Processing 47/105: [bitv: dune build] [camlp-streams: dune build] [camlzip: make all] [cpu: autoconf] [csexp: dune build] [dolog: dune build]
-> retrieved minicli.5.0.2  (cached)
Processing 48/105: [bitv: dune build] [camlp-streams: dune build] [camlzip: make all] [cpu: autoconf] [csexp: dune build] [dolog: dune build]
Processing 49/105: [bitv: dune build] [camlp-streams: dune build] [camlzip: make all] [cpu: autoconf] [csexp: dune build] [dolog: dune build] [minicli: dune build]
-> retrieved num.1.4  (cached)
Processing 50/105: [bitv: dune build] [camlp-streams: dune build] [camlzip: make all] [cpu: autoconf] [csexp: dune build] [dolog: dune build] [minicli: dune build]
Processing 51/105: [bitv: dune build] [camlp-streams: dune build] [camlzip: make all] [cpu: autoconf] [csexp: dune build] [dolog: dune build] [minicli: dune build] [num: make]
-> retrieved ocaml-compiler-libs.v0.12.4  (cached)
Processing 52/105: [bitv: dune build] [camlp-streams: dune build] [camlzip: make all] [cpu: autoconf] [csexp: dune build] [dolog: dune build] [minicli: dune build] [num: make]
Processing 53/105: [bitv: dune build] [camlp-streams: dune build] [camlzip: make all] [cpu: autoconf] [csexp: dune build] [dolog: dune build] [minicli: dune build] [num: make] [ocaml-compiler-libs: dune build]
-> retrieved ounit2.2.2.7  (cached)
Processing 54/105: [bitv: dune build] [camlp-streams: dune build] [camlzip: make all] [cpu: autoconf] [csexp: dune build] [dolog: dune build] [minicli: dune build] [num: make] [ocaml-compiler-libs: dune build]
-> retrieved parany.14.0.0  (cached)
Processing 55/105: [bitv: dune build] [camlp-streams: dune build] [camlzip: make all] [cpu: autoconf] [csexp: dune build] [dolog: dune build] [minicli: dune build] [num: make] [ocaml-compiler-libs: dune build]
-> retrieved ppx_derivers.1.2.1  (cached)
Processing 56/105: [bitv: dune build] [camlp-streams: dune build] [camlzip: make all] [cpu: autoconf] [csexp: dune build] [dolog: dune build] [minicli: dune build] [num: make] [ocaml-compiler-libs: dune build]
Processing 57/105: [bitv: dune build] [camlp-streams: dune build] [camlzip: make all] [cpu: autoconf] [csexp: dune build] [dolog: dune build] [minicli: dune build] [num: make] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build]
-> retrieved qcheck.0.21.2  (cached)
Processing 58/105: [bitv: dune build] [camlp-streams: dune build] [camlzip: make all] [cpu: autoconf] [csexp: dune build] [dolog: dune build] [minicli: dune build] [num: make] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build]
-> retrieved qcheck-core.0.21.2  (cached)
Processing 59/105: [bitv: dune build] [camlp-streams: dune build] [camlzip: make all] [cpu: autoconf] [csexp: dune build] [dolog: dune build] [minicli: dune build] [num: make] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build]
Processing 60/105: [bitv: dune build] [camlp-streams: dune build] [camlzip: make all] [cpu: autoconf] [csexp: dune build] [dolog: dune build] [minicli: dune build] [num: make] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [qcheck-core: dune build]
-> compiled  bitv.1.6
Processing 60/105: [camlp-streams: dune build] [camlzip: make all] [cpu: autoconf] [csexp: dune build] [dolog: dune build] [minicli: dune build] [num: make] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [qcheck-core: dune build]
-> installed bitv.1.6
Processing 61/105: [camlp-streams: dune build] [camlzip: make all] [cpu: autoconf] [csexp: dune build] [dolog: dune build] [minicli: dune build] [num: make] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [qcheck-core: dune build]
- configure.ac:8: warning: The macro `AC_HEADER_STDC' is obsolete.
- configure.ac:8: You should run autoupdate.
- ./lib/autoconf/headers.m4:704: AC_HEADER_STDC is expanded from...
- configure.ac:8: the top level
Processing 61/105: [camlp-streams: dune build] [camlzip: make all] [cpu: autoheader] [csexp: dune build] [dolog: dune build] [minicli: dune build] [num: make] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [qcheck-core: dune build]
-> retrieved qcheck-ounit.0.21.2  (cached)
Processing 62/105: [camlp-streams: dune build] [camlzip: make all] [cpu: autoheader] [csexp: dune build] [dolog: dune build] [minicli: dune build] [num: make] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [qcheck-core: dune build]
Processing 63/105: [camlp-streams: dune build] [camlzip: make all] [cpu: autoheader] [csexp: dune build] [dolog: dune build] [minicli: dune build] [num: make] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [qcheck-core: dune build]
Processing 64/105: [camlp-streams: dune build] [camlzip: make all] [cpu: autoheader] [csexp: dune build] [dolog: dune build] [minicli: dune build] [num: make] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [qcheck-core: dune build]
-> installed seq.base
Processing 65/105: [camlp-streams: dune build] [camlzip: make all] [cpu: autoheader] [csexp: dune build] [dolog: dune build] [minicli: dune build] [num: make] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [qcheck-core: dune build]
-> retrieved ppxlib.0.30.0  (cached)
Processing 66/105: [camlp-streams: dune build] [camlzip: make all] [cpu: autoheader] [csexp: dune build] [dolog: dune build] [minicli: dune build] [num: make] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [qcheck-core: dune build]
-> compiled  csexp.1.5.2
Processing 66/105: [camlp-streams: dune build] [camlzip: make all] [cpu: autoheader] [dolog: dune build] [minicli: dune build] [num: make] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [qcheck-core: dune build]
-> installed csexp.1.5.2
Processing 67/105: [camlp-streams: dune build] [camlzip: make all] [cpu: autoheader] [dolog: dune build] [minicli: dune build] [num: make] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [qcheck-core: dune build]
-> compiled  dolog.6.0.0
Processing 67/105: [camlp-streams: dune build] [camlzip: make all] [cpu: autoheader] [minicli: dune build] [num: make] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [qcheck-core: dune build]
-> installed dolog.6.0.0
Processing 68/105: [camlp-streams: dune build] [camlzip: make all] [cpu: autoheader] [minicli: dune build] [num: make] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [qcheck-core: dune build]
-> retrieved sexplib0.v0.16.0  (cached)
Processing 69/105: [camlp-streams: dune build] [camlzip: make all] [cpu: autoheader] [minicli: dune build] [num: make] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [qcheck-core: dune build]
Processing 70/105: [camlp-streams: dune build] [camlzip: make all] [cpu: autoheader] [minicli: dune build] [num: make] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [qcheck-core: dune build] [sexplib0: dune build]
-> retrieved stdlib-shims.0.3.0  (cached)
Processing 71/105: [camlp-streams: dune build] [camlzip: make all] [cpu: autoheader] [minicli: dune build] [num: make] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [qcheck-core: dune build] [sexplib0: dune build] [stdlib-shims: dune build]
-> retrieved vpt.5.0.0  (cached)
Processing 72/105: [camlp-streams: dune build] [camlzip: make all] [cpu: autoheader] [minicli: dune build] [num: make] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [qcheck-core: dune build] [sexplib0: dune build] [stdlib-shims: dune build] [vpt: dune build]
-> compiled  minicli.5.0.2
Processing 72/105: [camlp-streams: dune build] [camlzip: make all] [cpu: autoheader] [num: make] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [qcheck-core: dune build] [sexplib0: dune build] [stdlib-shims: dune build] [vpt: dune build]
-> installed minicli.5.0.2
Processing 73/105: [camlp-streams: dune build] [camlzip: make all] [cpu: autoheader] [num: make] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [qcheck-core: dune build] [sexplib0: dune build] [stdlib-shims: dune build] [vpt: dune build]
-> compiled  ppx_derivers.1.2.1
Processing 73/105: [camlp-streams: dune build] [camlzip: make all] [cpu: autoheader] [num: make] [ocaml-compiler-libs: dune build] [qcheck-core: dune build] [sexplib0: dune build] [stdlib-shims: dune build] [vpt: dune build]
-> installed ppx_derivers.1.2.1
Processing 74/105: [camlp-streams: dune build] [camlzip: make all] [cpu: autoheader] [num: make] [ocaml-compiler-libs: dune build] [qcheck-core: dune build] [sexplib0: dune build] [stdlib-shims: dune build] [vpt: dune build]
-> compiled  camlp-streams.5.0.1
Processing 74/105: [camlzip: make all] [cpu: autoheader] [num: make] [ocaml-compiler-libs: dune build] [qcheck-core: dune build] [sexplib0: dune build] [stdlib-shims: dune build] [vpt: dune build]
-> installed camlp-streams.5.0.1
Processing 75/105: [camlzip: make all] [cpu: autoheader] [num: make] [ocaml-compiler-libs: dune build] [qcheck-core: dune build] [sexplib0: dune build] [stdlib-shims: dune build] [vpt: dune build]
Processing 75/105: [camlzip: make all] [cpu: ./configure] [num: make] [ocaml-compiler-libs: dune build] [qcheck-core: dune build] [sexplib0: dune build] [stdlib-shims: dune build] [vpt: dune build]
-> retrieved dune-configurator.3.10.0  (cached)
Processing 76/105: [camlzip: make all] [cpu: ./configure] [dune-configurator: rm] [num: make] [ocaml-compiler-libs: dune build] [qcheck-core: dune build] [sexplib0: dune build] [stdlib-shims: dune build] [vpt: dune build]
- ocamlfind ocamlc -g -safe-string -bin-annot -c -ccopt -g  zlibstubs.c
- ocamlfind ocamlmklib -oc camlzip zlibstubs.o  -lz
- ocamlfind ocamlc -g -safe-string -bin-annot -c zlib.mli
- ocamlfind ocamlc -g -safe-string -bin-annot -c zlib.ml
- ocamlfind ocamlc -g -safe-string -bin-annot -c zip.mli
- ocamlfind ocamlc -g -safe-string -bin-annot -c zip.ml
- File "_none_", line 1:
- Alert ocaml_deprecated_auto_include: 
- OCaml's lib directory layout changed in 5.0. The unix subdirectory has been
- automatically added to the search path, but you should add -I +unix to the
- command-line to silence this alert (e.g. by adding unix to the list of
- libraries in your dune file, or adding use_unix to your _tags file for
- ocamlbuild, or using -package unix for ocamlfind).
- ocamlfind ocamlc -g -safe-string -bin-annot -c gzip.mli
- ocamlfind ocamlc -g -safe-string -bin-annot -c gzip.ml
- ocamlfind ocamlmklib -o zip -oc camlzip zlib.cmo zip.cmo gzip.cmo  -lz
- ocamlfind ocamlopt -safe-string -c zlib.ml
- ocamlfind ocamlopt -safe-string -c zip.ml
- File "_none_", line 1:
- Alert ocaml_deprecated_auto_include: 
- OCaml's lib directory layout changed in 5.0. The unix subdirectory has been
- automatically added to the search path, but you should add -I +unix to the
- command-line to silence this alert (e.g. by adding unix to the list of
- libraries in your dune file, or adding use_unix to your _tags file for
- ocamlbuild, or using -package unix for ocamlfind).
- ocamlfind ocamlopt -safe-string -c gzip.ml
- ocamlfind ocamlmklib -o zip -oc camlzip zlib.cmx zip.cmx gzip.cmx  -lz
- ocamlfind ocamlopt -safe-string -shared -linkall -I ./ -o zip.cmxs zip.cmxa libcamlzip.a
-> compiled  camlzip.1.11
Processing 76/105: [cpu: ./configure] [dune-configurator: rm] [num: make] [ocaml-compiler-libs: dune build] [qcheck-core: dune build] [sexplib0: dune build] [stdlib-shims: dune build] [vpt: dune build]
Processing 77/105: [cpu: ./configure] [dune-configurator: rm] [num: make] [ocaml-compiler-libs: dune build] [qcheck-core: dune build] [sexplib0: dune build] [stdlib-shims: dune build] [vpt: dune build] [camlzip: make install]
- /usr/bin/make -C src all
- make[1]: Entering directory '/home/opam/.opam/5.1/.opam-switch/build/num.1.4/src'
- ocamlc -ccopt -DBNG_ARCH_amd64 -c bng.c
- ocamlc -ccopt -DBNG_ARCH_amd64 -c nat_stubs.c
- ocamlmklib -oc nums bng.o nat_stubs.o
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c int_misc.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c int_misc.ml
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c nat.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c nat.ml
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c big_int.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c big_int.ml
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c arith_flags.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c arith_flags.ml
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c ratio.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c ratio.ml
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c num.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c num.ml
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c arith_status.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c arith_status.ml
- ocamlmklib -o nums -oc nums -linkall int_misc.cmo nat.cmo big_int.cmo arith_flags.cmo ratio.cmo num.cmo arith_status.cmo
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c int_misc.ml
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c nat.ml
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c big_int.ml
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c arith_flags.ml
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c ratio.ml
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c num.ml
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c arith_status.ml
- ocamlmklib -o nums -oc nums -linkall int_misc.cmx nat.cmx big_int.cmx arith_flags.cmx ratio.cmx num.cmx arith_status.cmx
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -I . -shared -o nums.cmxs nums.cmxa
- make[1]: Leaving directory '/home/opam/.opam/5.1/.opam-switch/build/num.1.4/src'
- /usr/bin/make -C toplevel all
- make[1]: Entering directory '/home/opam/.opam/5.1/.opam-switch/build/num.1.4/toplevel'
- ocamlc -I ../src -I +compiler-libs -w +a-4-9-41-42-44-45-48 -warn-error A -safe-string -strict-sequence -strict-formats -c num_top_printers.mli
- ocamlc -I ../src -I +compiler-libs -w +a-4-9-41-42-44-45-48 -warn-error A -safe-string -strict-sequence -strict-formats -c num_top_printers.ml
- ocamlc -I ../src -I +compiler-libs -w +a-4-9-41-42-44-45-48 -warn-error A -safe-string -strict-sequence -strict-formats -c num_top.mli
- ocamlc -I ../src -I +compiler-libs -w +a-4-9-41-42-44-45-48 -warn-error A -safe-string -strict-sequence -strict-formats -c num_top.ml
- ocamlc -I ../src -I +compiler-libs -w +a-4-9-41-42-44-45-48 -warn-error A -safe-string -strict-sequence -strict-formats -a -o num_top.cma num_top_printers.cmo num_top.cmo
- make[1]: Leaving directory '/home/opam/.opam/5.1/.opam-switch/build/num.1.4/toplevel'
-> compiled  num.1.4
Processing 77/105: [cpu: ./configure] [dune-configurator: rm] [ocaml-compiler-libs: dune build] [qcheck-core: dune build] [sexplib0: dune build] [stdlib-shims: dune build] [vpt: dune build] [camlzip: make install]
-> compiled  ocaml-compiler-libs.v0.12.4
Processing 77/105: [cpu: ./configure] [dune-configurator: rm] [qcheck-core: dune build] [sexplib0: dune build] [stdlib-shims: dune build] [vpt: dune build] [camlzip: make install]
- (cd _build/default && /home/opam/.opam/5.1/bin/ocamlc.opt -w -40 -w +a-4-42-44-48-50-58-32-60@8 -safe-string -g -bin-annot -I src/core/.qcheck_core.objs/byte -I /home/opam/.opam/5.1/lib/bytes -I /home/opam/.opam/5.1/lib/ocaml/unix -intf-suffix .ml -no-alias-deps -o src/core/.qcheck_core.objs/byte/qCheck2.cmo -c -impl src/core/QCheck2.ml)
- File "src/core/QCheck2.ml", line 1172, characters 2-20:
- 1172 |   fun_gen: 'b Gen.t; (** How to generate output values *)
-          ^^^^^^^^^^^^^^^^^^
- Warning 69 [unused-field]: record field fun_gen is never read.
- (However, this field is used to build or mutate values.)
- 
- File "src/core/QCheck2.ml", line 1570, characters 4-33:
- 1570 |     mutable res: 'a TestResult.t;
-            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 69 [unused-field]: mutable record field res is never mutated.
- (cd _build/default && /home/opam/.opam/5.1/bin/ocamlopt.opt -w -40 -w +a-4-42-44-48-50-58-32-60@8 -safe-string -g -I src/core/.qcheck_core.objs/byte -I src/core/.qcheck_core.objs/native -I /home/opam/.opam/5.1/lib/bytes -I /home/opam/.opam/5.1/lib/ocaml/unix -intf-suffix .ml -no-alias-deps -o src/core/.qcheck_core.objs/native/qCheck2.cmx -c -impl src/core/QCheck2.ml)
- File "src/core/QCheck2.ml", line 1172, characters 2-20:
- 1172 |   fun_gen: 'b Gen.t; (** How to generate output values *)
-          ^^^^^^^^^^^^^^^^^^
- Warning 69 [unused-field]: record field fun_gen is never read.
- (However, this field is used to build or mutate values.)
- 
- File "src/core/QCheck2.ml", line 1570, characters 4-33:
- 1570 |     mutable res: 'a TestResult.t;
-            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 69 [unused-field]: mutable record field res is never mutated.
-> compiled  qcheck-core.0.21.2
Processing 77/105: [cpu: ./configure] [dune-configurator: rm] [sexplib0: dune build] [stdlib-shims: dune build] [vpt: dune build] [camlzip: make install]
-> compiled  sexplib0.v0.16.0
Processing 77/105: [cpu: ./configure] [dune-configurator: rm] [stdlib-shims: dune build] [vpt: dune build] [camlzip: make install]
-> compiled  stdlib-shims.0.3.0
Processing 77/105: [cpu: ./configure] [dune-configurator: rm] [vpt: dune build] [camlzip: make install]
-> compiled  vpt.5.0.0
Processing 77/105: [cpu: ./configure] [dune-configurator: rm] [camlzip: make install]
- checking for ocamlc... ocamlc
- OCaml version is 5.1.0
- OCaml library path is /home/opam/.opam/5.1/lib/ocaml
- checking for ocamlopt... ocamlopt
- checking for ocamlc.opt... ocamlc.opt
- checking for ocamlopt.opt... ocamlopt.opt
- checking for dynlink.cmxa... no
- checking for ocaml... ocaml
- checking for ocamldep... ocamldep
- checking for ocamlmktop... ocamlmktop
- checking for ocamlmklib... ocamlmklib
- checking for ocamldoc... ocamldoc
- checking for ocamlbuild... no
- checking for gcc... gcc
- checking whether the C compiler works... yes
- checking for C compiler default output file name... a.out
- checking for suffix of executables... 
- checking whether we are cross compiling... no
- checking for suffix of object files... o
- checking whether the compiler supports GNU C... yes
- checking whether gcc accepts -g... yes
- checking for gcc option to enable C11 features... none needed
- checking for stdio.h... yes
- checking for stdlib.h... yes
- checking for string.h... yes
- checking for inttypes.h... yes
- checking for stdint.h... yes
- checking for strings.h... yes
- checking for sys/stat.h... yes
- checking for sys/types.h... yes
- checking for unistd.h... yes
- checking for grep that handles long lines and -e... /usr/bin/grep
- checking for egrep... /usr/bin/grep -E
- checking for sched.h... yes
- checking for gcc options needed to detect all undeclared functions... none needed
- checking whether sched_setaffinity is declared... yes
- checking for mach/thread_policy.h... no
- checking whether thread_policy_set is declared... no
- configure: creating ./config.status
- config.status: creating src/config.h
Processing 77/105: [cpu: dune build] [dune-configurator: rm] [camlzip: make install]
Processing 77/105: [cpu: dune build] [dune-configurator: dune build] [camlzip: make install]
- cp META-zip META && \
-         ocamlfind install zip META *.cma *.a *.mli *.cmi *.cmti *.cmt gzip.cmx zip.cmx zlib.cmx zip.cmxa zip.cmxs dllcamlzip.so && \
-         rm META
- Installed /home/opam/.opam/5.1/lib/zip/zip.cmxs
- Installed /home/opam/.opam/5.1/lib/zip/zip.cmxa
- Installed /home/opam/.opam/5.1/lib/zip/zlib.cmx
- Installed /home/opam/.opam/5.1/lib/zip/zip.cmx
- Installed /home/opam/.opam/5.1/lib/zip/gzip.cmx
- Installed /home/opam/.opam/5.1/lib/zip/zlib.cmt
- Installed /home/opam/.opam/5.1/lib/zip/zip.cmt
- Installed /home/opam/.opam/5.1/lib/zip/gzip.cmt
- Installed /home/opam/.opam/5.1/lib/zip/zlib.cmti
- Installed /home/opam/.opam/5.1/lib/zip/zip.cmti
- Installed /home/opam/.opam/5.1/lib/zip/gzip.cmti
- Installed /home/opam/.opam/5.1/lib/zip/zlib.cmi
- Installed /home/opam/.opam/5.1/lib/zip/zip.cmi
- Installed /home/opam/.opam/5.1/lib/zip/gzip.cmi
- Installed /home/opam/.opam/5.1/lib/zip/zlib.mli
- Installed /home/opam/.opam/5.1/lib/zip/zip.mli
- Installed /home/opam/.opam/5.1/lib/zip/gzip.mli
- Installed /home/opam/.opam/5.1/lib/zip/zip.a
- Installed /home/opam/.opam/5.1/lib/zip/libcamlzip.a
- Installed /home/opam/.opam/5.1/lib/zip/zip.cma
- Installed /home/opam/.opam/5.1/lib/stublibs/dllcamlzip.so
- Installed /home/opam/.opam/5.1/lib/stublibs/dllcamlzip.so.owner
- ocamlfind: [WARNING] You have installed DLLs but the directory /home/opam/.opam/5.1/lib/stublibs is not mentioned in ld.conf
- Installed /home/opam/.opam/5.1/lib/zip/META
- cp META-camlzip META && \
-         ocamlfind install camlzip META && \
-         rm META
- Installed /home/opam/.opam/5.1/lib/camlzip/META
-> installed camlzip.1.11
Processing 77/105: [cpu: dune build] [dune-configurator: dune build]
Processing 78/105: [cpu: dune build] [dune-configurator: dune build] [num: ocamlfind remove]
- ocamlfind: [WARNING] No such file: /home/opam/.opam/5.1/lib/num/META
- ocamlfind: [WARNING] No such file: /home/opam/.opam/5.1/lib/num-top/META
Processing 78/105: [cpu: dune build] [dune-configurator: dune build] [num: make install]
- /usr/bin/make -C src install
- make[1]: Entering directory '/home/opam/.opam/5.1/.opam-switch/build/num.1.4/src'
- install -d /home/opam/.opam/5.1/lib/ocaml
- sed -e 's/%%VERSION%%/1.4/g' META.in > META
- ocamlfind install num META
- Installed /home/opam/.opam/5.1/lib/num/META
- rm -f META
- install -m 644 nums.cma libnums.a big_int.cmi nat.cmi num.cmi ratio.cmi arith_status.cmi big_int.mli nat.mli num.mli ratio.mli arith_status.mli big_int.cmti nat.cmti num.cmti ratio.cmti arith_status.cmti nums.cmxa nums.a int_misc.cmx nat.cmx big_int.cmx arith_flags.cmx ratio.cmx num.cmx arith_status.cmx nums.cmxs /home/opam/.opam/5.1/lib/ocaml
- install -d /home/opam/.opam/5.1/lib/ocaml/stublibs
- install dllnums.so /home/opam/.opam/5.1/lib/ocaml/stublibs
- make[1]: Leaving directory '/home/opam/.opam/5.1/.opam-switch/build/num.1.4/src'
- /usr/bin/make -C toplevel install
- make[1]: Entering directory '/home/opam/.opam/5.1/.opam-switch/build/num.1.4/toplevel'
- sed -e 's/%%VERSION%%/1.4/g' META.in > META
- ocamlfind install num-top META num_top.cma num_top.cmi num_top_printers.cmi
- Installed /home/opam/.opam/5.1/lib/num-top/num_top_printers.cmi
- Installed /home/opam/.opam/5.1/lib/num-top/num_top.cmi
- Installed /home/opam/.opam/5.1/lib/num-top/num_top.cma
- Installed /home/opam/.opam/5.1/lib/num-top/META
- rm -f META
- make[1]: Leaving directory '/home/opam/.opam/5.1/.opam-switch/build/num.1.4/toplevel'
-> installed num.1.4
Processing 78/105: [cpu: dune build] [dune-configurator: dune build]
Processing 79/105: [batteries: dune build] [cpu: dune build] [dune-configurator: dune build]
-> installed ocaml-compiler-libs.v0.12.4
Processing 80/105: [batteries: dune build] [cpu: dune build] [dune-configurator: dune build]
-> installed qcheck-core.0.21.2
Processing 81/105: [batteries: dune build] [cpu: dune build] [dune-configurator: dune build]
-> installed sexplib0.v0.16.0
Processing 82/105: [batteries: dune build] [cpu: dune build] [dune-configurator: dune build]
-> installed stdlib-shims.0.3.0
Processing 83/105: [batteries: dune build] [cpu: dune build] [dune-configurator: dune build]
Processing 84/105: [batteries: dune build] [cpu: dune build] [dune-configurator: dune build] [ounit2: dune build]
Processing 85/105: [batteries: dune build] [cpu: dune build] [dune-configurator: dune build] [ounit2: dune build] [ppxlib: dune build]
-> installed vpt.5.0.0
Processing 86/105: [batteries: dune build] [cpu: dune build] [dune-configurator: dune build] [ounit2: dune build] [ppxlib: dune build]
-> compiled  cpu.2.0.0
Processing 86/105: [batteries: dune build] [dune-configurator: dune build] [ounit2: dune build] [ppxlib: dune build]
-> installed cpu.2.0.0
Processing 87/105: [batteries: dune build] [dune-configurator: dune build] [ounit2: dune build] [ppxlib: dune build]
Processing 88/105: [batteries: dune build] [dune-configurator: dune build] [ounit2: dune build] [parany: dune build] [ppxlib: dune build]
-> compiled  parany.14.0.0
Processing 88/105: [batteries: dune build] [dune-configurator: dune build] [ounit2: dune build] [ppxlib: dune build]
-> installed parany.14.0.0
Processing 89/105: [batteries: dune build] [dune-configurator: dune build] [ounit2: dune build] [ppxlib: dune build]
-> compiled  dune-configurator.3.10.0
Processing 89/105: [batteries: dune build] [ounit2: dune build] [ppxlib: dune build]
-> installed dune-configurator.3.10.0
Processing 90/105: [batteries: dune build] [ounit2: dune build] [ppxlib: dune build]
-> compiled  ounit2.2.2.7
Processing 90/105: [batteries: dune build] [ppxlib: dune build]
-> installed ounit2.2.2.7
Processing 91/105: [batteries: dune build] [ppxlib: dune build]
Processing 92/105: [batteries: dune build] [ppxlib: dune build] [qcheck-ounit: dune build]
-> compiled  qcheck-ounit.0.21.2
Processing 92/105: [batteries: dune build] [ppxlib: dune build]
-> installed qcheck-ounit.0.21.2
Processing 93/105: [batteries: dune build] [ppxlib: dune build]
Processing 94/105: [batteries: dune build] [ppxlib: dune build] [qcheck: dune build]
-> compiled  qcheck.0.21.2
Processing 94/105: [batteries: dune build] [ppxlib: dune build]
-> installed qcheck.0.21.2
Processing 95/105: [batteries: dune build] [ppxlib: dune build]
-> compiled  batteries.3.7.1
Processing 95/105: [ppxlib: dune build]
-> installed batteries.3.7.1
Processing 96/105: [ppxlib: dune build]
Processing 97/105: [cpm: dune build] [ppxlib: dune build]
-> compiled  cpm.12.2.0
Processing 97/105: [ppxlib: dune build]
-> installed cpm.12.2.0
Processing 98/105: [ppxlib: dune build]
+ /home/opam/.opam/5.1/bin/dune "build" "-p" "ppxlib" "-j" "71" "@install" (CWD=/home/opam/.opam/5.1/.opam-switch/build/ppxlib.0.30.0)
-> compiled  ppxlib.0.30.0
-> installed ppxlib.0.30.0
Processing 100/105: [extunix: dune build]
+ /home/opam/.opam/5.1/bin/dune "build" "-p" "extunix" "-j" "71" "@install" (CWD=/home/opam/.opam/5.1/.opam-switch/build/extunix.0.4.1)
- (cd _build/default/src && ../discover/discover.exe)
- checking EVENTFD.............ok
- checking ATFILE..............ok
- checking DIRFD...............ok
- checking STATVFS.............ok
- checking FSTATVFS............ok
- checking SIOCGIFCONF.........ok
- checking IFADDRS.............ok
- checking INET_NTOA...........ok
- checking INET_NTOP...........ok
- checking UNAME...............ok
- checking FADVISE.............ok
- checking FALLOCATE...........ok
- checking TTY_IOCTL...........ok
- checking TTYNAME.............ok
- checking CTERMID.............ok
- checking GETTID..............ok
- checking PGID................ok
- checking SETREUID............ok
- checking FSYNC...............ok
- checking FDATASYNC...........ok
- checking SYNC................ok
- checking SYNCFS..............ok
- checking REALPATH............ok
- checking SIGNALFD............ok
- checking PTRACE..............ok
- checking RESOURCE............ok
- checking MLOCKALL............ok
- checking STRPTIME............ok
- checking STRTIME.............ok
- checking TIMEZONE............ok
- checking TIMEGM..............ok
- checking PTS.................ok
- checking FCNTL...............ok
- checking TCPGRP..............ok
- checking EXECINFO............ok
- checking SETENV..............ok
- checking CLEARENV............ok
- checking MKDTEMP.............ok
- checking MALLOC_INFO.........ok
- checking MALLOC_STATS........ok
- checking MEMALIGN............ok
- checking ENDIAN..............ok
- checking READ_CREDENTIALS....ok
- checking FEXECVE.............ok
- checking SENDMSG.............ok
- checking PREAD...............ok
- checking PWRITE..............ok
- checking READ................ok
- checking WRITE...............ok
- checking MKSTEMPS............ok
- checking MKOSTEMPS...........ok
- checking SETRESUID...........ok
- checking SYSCONF.............ok
- checking SPLICE..............ok
- checking TEE.................ok
- checking VMSPLICE............ok
- checking SOCKOPT.............ok
- checking TCP_KEEPIDLE........ok
- checking TCP_KEEPCNT.........ok
- checking TCP_KEEPINTVL.......ok
- checking SO_REUSEPORT........ok
- checking POLL................ok
- checking SYSINFO.............ok
- checking MCHECK..............ok
- checking MOUNT...............ok
- checking UNSHARE.............ok
- checking CHROOT..............ok
- checking SYSLOG..............ok
- (cd _build/default/src && /usr/bin/gcc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC -D_FILE_OFFSET_BITS=64 -g -I /home/opam/.opam/5.1/lib/ocaml -I /home/opam/.opam/5.1/lib/bytes -I /home/opam/.opam/5.1/lib/ocaml/unix -o splice.o -c splice.c)
- splice.c: In function 'get_offset':
- splice.c:20:33: warning: return discards 'volatile' qualifier from pointer target type [-Wdiscarded-qualifiers]
-    20 |   return (Is_long(v_off) ? NULL : &(Field(v_off, 0)));
-       |          ~~~~~~~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~
-> compiled  extunix.0.4.1
-> installed extunix.0.4.1
Processing 102/105: [dokeysto: dune build]
+ /home/opam/.opam/5.1/bin/dune "build" "-p" "dokeysto" "-j" "71" (CWD=/home/opam/.opam/5.1/.opam-switch/build/dokeysto.4.0.1)
-> compiled  dokeysto.4.0.1
-> installed dokeysto.4.0.1

#=== ERROR while compiling conf-openbabel.0.1 =================================#
# context              2.1.5 | linux/x86_64 | ocaml-base-compiler.5.1.0 | file:///src
# path                 ~/.opam/5.1/.opam-switch/build/conf-openbabel.0.1
# command              /usr/bin/c++ -I/usr/include/openbabel-2.0 test.cpp -lopenbabel
# exit-code            1
# env-file             ~/.opam/log/conf-openbabel-113-927340.env
# output-file          ~/.opam/log/conf-openbabel-113-927340.out
### output ###
# test.cpp:1:10: fatal error: openbabel/mol.h: No such file or directory
#     1 | #include <openbabel/mol.h>
#       |          ^~~~~~~~~~~~~~~~~
# compilation terminated.



<><> Error report <><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><>
+- The following actions were aborted
| - install lbvs_consent 2.2.0
+- 
+- The following actions failed
| - build conf-openbabel 0.1
+- 
+- The following changes have been performed (the rest was aborted)
| - install base-bytes          base
| - install batteries           3.7.1
| - install bitv                1.6
| - install camlp-streams       5.0.1
| - install camlzip             1.11
| - install conf-autoconf       0.1
| - install conf-boost          1
| - install conf-pkg-config     3
| - install conf-python-3       9.0.0
| - install conf-rdkit          1
| - install conf-which          1
| - install conf-zlib           1
| - install cpm                 12.2.0
| - install cpu                 2.0.0
| - install csexp               1.5.2
| - install dokeysto            4.0.1
| - install dolog               6.0.0
| - install dune-configurator   3.10.0
| - install extunix             0.4.1
| - install minicli             5.0.2
| - install num                 1.4
| - install ocaml-compiler-libs v0.12.4
| - install ounit2              2.2.7
| - install parany              14.0.0
| - install ppx_derivers        1.2.1
| - install ppxlib              0.30.0
| - install qcheck              0.21.2
| - install qcheck-core         0.21.2
| - install qcheck-ounit        0.21.2
| - install seq                 base
| - install sexplib0            v0.16.0
| - install stdlib-shims        0.3.0
| - install vpt                 5.0.0
+- 
# Run eval $(opam env) to update the current shell environment

The former state can be restored with:
    /usr/bin/opam switch import "/home/opam/.opam/5.1/.opam-switch/backup/state-20231009053650.export"
'opam --cli=2.1 install lbvs_consent.2.2.0 vpt.5.0.0 stdlib-shims.0.3.0 sexplib0.v0.16.0 seq.base qcheck-ounit.0.21.2 qcheck-core.0.21.2 qcheck.0.21.2 ppxlib.0.30.0 ppx_derivers.1.2.1 parany.14.0.0 ounit2.2.2.7 ocamlfind.1.9.6 ocaml-compiler-libs.v0.12.4 num.1.4 minicli.5.0.2 extunix.0.4.1 dune-configurator.3.10.0 dune.3.10.0 dolog.6.0.0 dokeysto.4.0.1 csexp.1.5.2 cpu.2.0.0 cpm.12.2.0 conf-zlib.1 conf-which.1 conf-rdkit.1 conf-python-3.9.0.0 conf-pkg-config.3 conf-openbabel.0.1 conf-boost.1 conf-autoconf.0.1 camlzip.1.11 camlp-streams.5.0.1 bitv.1.6 batteries.3.7.1 base-bytes.base --verbose --yes --confirm-level=unsafe-yes' failed.