package llvm

  1. Overview
  2. Docs
On This Page
  1. Error log

llvm 10.0.0

Error log

The package failed to build. The error log from opam follows.

Opam plugin "depext" may require upgrading/reinstalling. Reinstall the plugin on the current switch? [Y/n] y
The following actions will be performed:
  - recompile opam-depext 1.2.1-1

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved opam-depext.1.2.1-1  (cached)
-> removed   opam-depext.1.2.1-1
-> installed opam-depext.1.2.1-1
Done.

<><> opam-depext.1.2.1-1 installed successfully <><><><><><><><><><><><><><><><>
=> opam-depext is unnecessary when used with opam >= 2.1. Please use opam install directly instead
# Run eval $(opam env) to update the current shell environment

<><> Carrying on to "opam depext -viy llvm.10.0.0 stdlib-shims.0.3.0 ocamlfind.1.9.6 integers.0.7.0 dune-configurator.3.13.0 dune.3.13.0 ctypes.0.21.1 csexp.1.5.2 conf-python-2-7.1.2 conf-llvm.10.0.0 conf-cmake.1 conf-bash.1 bigarray-compat.1.1.0" 

You are using opam 2.1+, where external dependency handling has been integrated: consider calling opam directly, the 'depext' plugin interface is provided for backwards compatibility only
# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
[ERROR] No solution for llvm.10.0.0 & stdlib-shims.0.3.0 & ocamlfind.1.9.6 & integers.0.7.0 & dune-configurator.3.13.0 & dune.3.13.0 & ctypes.0.21.1 & csexp.1.5.2 & conf-python-2-7.1.2 & conf-llvm.10.0.0 & conf-cmake.1 & conf-bash.1 & bigarray-compat.1.1.0:   * Missing dependency:
            - conf-llvm = 10.0.0
            depends on the unavailable system package 'llvm-10-dev'. Use `--no-depexts' to attempt installation anyway, or it is possible that a depext package name in the opam file is incorrect.


Command failed: opam --cli=2.1 list --readonly --external '--resolve=llvm.10.0.0,stdlib-shims.0.3.0,ocamlfind.1.9.6,integers.0.7.0,dune-configurator.3.13.0,dune.3.13.0,ctypes.0.21.1,csexp.1.5.2,conf-python-2-7.1.2,conf-llvm.10.0.0,conf-cmake.1,conf-bash.1,bigarray-compat.1.1.0' returned 20