package metapp

  1. Overview
  2. Docs
Meta-preprocessor for OCaml

Install

Authors

Maintainers

Sources

metapp.0.4.4.tar.gz
sha512=817b33d9006a6849845e29a2b12ad7b7d13e34e38216bd2724df45e8f24356f9d281e2731ecc37a8ab2b5faef844252a04f976adf61d024b7653235e38dfdc46

Description

Meta-preprocessor for OCaml: extends the language with [%meta ... ] construction where ... stands for OCaml code evaluated at compile-time.

Published: 04 Aug 2022

Dependencies (5)

  1. ocamlfind >= "1.8.1"
  2. ppxlib >= "0.22.0"
  3. stdcompat >= "12"
  4. ocaml >= "4.08.0"
  5. dune >= "2.7"

Dev Dependencies (1)

  1. odoc with-doc & >= "1.5.1"

Used by (7)

  1. clangml >= "4.3.0"
  2. metaquot >= "0.5.2"
  3. ocaml-in-python
  4. override >= "0.4.0"
  5. pattern >= "0.3.0"
  6. refl >= "0.4.0"
  7. traverse >= "0.3.0"

Conflicts

None