package mirage-kv

  1. Overview
  2. Docs
MirageOS signatures for key/value devices

Install

Dune Dependency

Authors

Maintainers

Sources

mirage-kv-v3.0.1.tbz
sha256=71b23237117b000a3212a3a8cabc841b1a0eac4e559625d89a19b5b6a536e3d8
sha512=b41da634d5ada6bdd14d23bc63759b3d3bc81243385e86153749b71a6002544e4a302c6c4928343a6a13bff4507a03dd30b6a70236153d073b5177f9d07e43ae

Description

mirage-kv provides the Mirage_kv.RO and Mirage_kv.RW signatures the MirageOS key/value devices should implement.

Tags

org:mirage

Published: 05 Nov 2019

README

mirage-kv — MirageOS signatures for key/value devices

mirage-kv provides the Mirage_kv.RO and Mirage_kv.RW signatures the MirageOS key/value devices should implement.

mirage-kv is distributed under the ISC license.

Installation

mirage-kv can be installed with opam:

opam install mirage-kv

If you don't use opam consult the opam file for build instructions.

Documentation

The documentation and API reference is generated from the source interfaces. API docs for both mirage-kv can be consulted online or via odig doc mirage-kv.

Dependencies (5)

  1. lwt >= "4.0.0"
  2. fmt >= "0.8.4"
  3. mirage-device >= "2.0.0"
  4. dune
  5. ocaml >= "4.06.0"

Dev Dependencies (1)

  1. alcotest with-test

Used by (17)

  1. caldav < "0.2.1"
  2. cohttp-mirage >= "2.4.0"
  3. conduit-mirage = "2.0.2"
  4. crunch >= "3.1.0"
  5. docteur < "0.0.2"
  6. docteur-solo5 < "0.0.6"
  7. docteur-unix < "0.0.6"
  8. fat-filesystem = "0.15.0"
  9. irmin-mirage-git < "3.8.0"
  10. mirage-fs >= "3.0.0"
  11. mirage-fs-lwt = "1.2.0"
  12. mirage-fs-unix >= "1.7.0"
  13. mirage-kv-mem = "3.0.0"
  14. mirage-kv-unix >= "2.1.0"
  15. mirage-types >= "3.7.1"
  16. tar-mirage >= "2.0.0" & < "2.2.0"
  17. tls-mirage

Conflicts

None