package octez-libs

  1. Overview
  2. No Docs
A package that contains multiple base libraries used by the Octez suite

Install

Dune Dependency

Authors

Maintainers

Sources

tezos-18.0.tar.gz
sha256=dbc3b675aee59c2c574e5d0a771193a2ecfca31e7a5bc5aed66598080596ce1c
sha512=b97ed762b9d24744305c358af0d20f394376b64bfdd758dd4a81775326caf445caa57c4f6445da3dd6468ff492de18e4c14af6f374dfcbb7e4d64b7b720e5e2a

Description

Published: 13 Oct 2023

Dependencies (58)

  1. resto-acl >= "1.2"
  2. resto-cohttp-server >= "1.2"
  3. cohttp-lwt-unix >= "5.2.0"
  4. resto-cohttp-client >= "1.2"
  5. resto-cohttp >= "1.2"
  6. lwt-watcher = "0.2"
  7. tezos-sapling-parameters >= "1.1.0"
  8. tezos-rust-libs = "1.6"
  9. integers_stubs_js
  10. integers
  11. conf-rust
  12. irmin-pack >= "3.7.2" & < "3.8.0"
  13. irmin >= "3.7.2" & < "3.8.0"
  14. ringo >= "1.0.0"
  15. uutf
  16. conf-libev
  17. mtime >= "1.4.0" & < "2.0.0"
  18. ptime >= "1.1.0"
  19. ipaddr >= "5.3.0" & < "6.0.0"
  20. aches-lwt >= "1.0.0"
  21. octez-alcotezt = version
  22. octez-distributed-lwt-internal = version
  23. logs
  24. stdint
  25. repr
  26. ppx_deriving
  27. base-unix
  28. cmdliner >= "1.1.0"
  29. bigstringaf >= "0.5.0"
  30. ppx_repr >= "0.6.0"
  31. eqaf
  32. bigarray-compat
  33. alcotest >= "1.5.0"
  34. secp256k1-internal >= "0.4.0"
  35. re >= "1.9.0"
  36. bls12-381 = version
  37. resto-directory >= "1.2"
  38. resto >= "1.2"
  39. ezjsonm >= "1.3.0"
  40. ctypes >= "0.18.0"
  41. ctypes_stubs_js
  42. hacl-star-raw
  43. hacl-star >= "0.7.1" & < "0.8"
  44. lwt-canceler >= "0.3" & < "0.4"
  45. seqes >= "0.2"
  46. aches >= "1.0.0"
  47. zarith_stubs_js
  48. zarith >= "1.12" & < "1.13"
  49. hex >= "1.3.0"
  50. ppx_expect
  51. data-encoding >= "0.7.1" & < "1.0.0"
  52. pure-splitmix = "0.3"
  53. lwt >= "5.6.0"
  54. qcheck-alcotest >= "0.20"
  55. fmt >= "0.8.7"
  56. uri >= "3.1.0"
  57. ocaml >= "4.14.1" & < "4.15"
  58. dune >= "3.0" & < "3.11"

Dev Dependencies (3)

  1. bigstring with-test
  2. qcheck-core with-test
  3. tezt with-test & >= "3.1.1"

Used by (65)

  1. octez = "18.0"
  2. octez-accuser-Proxford < "18.1"
  3. octez-accuser-PtNairob = "18.0"
  4. octez-baker-Proxford < "18.1"
  5. octez-baker-PtNairob = "18.0"
  6. octez-client = "18.0"
  7. octez-codec = "18.0"
  8. octez-crawler = "18.0"
  9. octez-dac-client < "18.1"
  10. octez-dac-node < "18.1"
  11. octez-injector = "18.0"
  12. octez-l2-libs < "18.1"
  13. octez-node = "18.0"
  14. octez-node-config = "18.0"
  15. octez-proto-libs < "18.1"
  16. octez-protocol-000-Ps9mPmXa-libs < "18.1"
  17. octez-protocol-001-PtCJ7pwo-libs < "18.1"
  18. octez-protocol-002-PsYLVpVv-libs < "18.1"
  19. octez-protocol-003-PsddFKi3-libs < "18.1"
  20. octez-protocol-004-Pt24m4xi-libs < "18.1"
  21. octez-protocol-005-PsBabyM1-libs < "18.1"
  22. octez-protocol-006-PsCARTHA-libs < "18.1"
  23. octez-protocol-007-PsDELPH1-libs < "18.1"
  24. octez-protocol-008-PtEdo2Zk-libs < "18.1"
  25. octez-protocol-009-PsFLoren-libs < "18.1"
  26. octez-protocol-010-PtGRANAD-libs < "18.1"
  27. octez-protocol-011-PtHangz2-libs < "18.1"
  28. octez-protocol-012-Psithaca-libs < "18.1"
  29. octez-protocol-013-PtJakart-libs < "18.1"
  30. octez-protocol-014-PtKathma-libs < "18.1"
  31. octez-protocol-015-PtLimaPt-libs < "18.1"
  32. octez-protocol-016-PtMumbai-libs < "18.1"
  33. octez-protocol-017-PtNairob-libs < "18.1"
  34. octez-protocol-018-Proxford-libs < "18.1"
  35. octez-protocol-alpha-libs < "18.1"
  36. octez-protocol-compiler = "18.0"
  37. octez-proxy-server = "18.0"
  38. octez-shell-libs < "18.1"
  39. octez-signer = "18.0"
  40. octez-smart-rollup-client-Proxford < "18.1"
  41. octez-smart-rollup-client-PtNairob = "18.0"
  42. octez-smart-rollup-node-lib < "18.1"
  43. octez-smart-rollup-node-Proxford < "18.1"
  44. octez-smart-rollup-node-PtNairob = "18.0"
  45. octez-smart-rollup-wasm-debugger = "18.0"
  46. octez-version < "18.1"
  47. tezos-benchmark < "18.1"
  48. tezos-client-demo-counter = "18.0"
  49. tezos-client-genesis = "18.0"
  50. tezos-dac-client-lib < "18.1"
  51. tezos-dac-lib < "18.1"
  52. tezos-dac-node-lib < "18.1"
  53. tezos-dal-node-lib = "18.0"
  54. tezos-dal-node-services = "18.0"
  55. tezos-protocol-011-PtHangz2 = "18.0"
  56. tezos-protocol-012-Psithaca = "18.0"
  57. tezos-protocol-013-PtJakart = "18.0"
  58. tezos-protocol-014-PtKathma = "18.0"
  59. tezos-protocol-015-PtLimaPt = "18.0"
  60. tezos-protocol-016-PtMumbai = "18.0"
  61. tezos-protocol-017-PtNairob = "18.0"
  62. tezos-protocol-018-Proxford < "18.1"
  63. tezos-protocol-alpha = "18.0"
  64. tezos-proxy-server-config = "18.0"
  65. tezt-tezos = "18.0"

Conflicts (4)

  1. stdcompat < "19"
  2. result < "1.5"
  3. hacl_x25519
  4. checkseum = "0.5.0"