sexplib
  1. Overview
  2. No Docs
Library for serializing OCaml values to and from S-expressions

Install

Authors

Maintainers

Sources

sexplib-v0.16.0.tar.gz
sha256=e564d5d1ca157314ba5fd64b4e89fa12c6cba8efee3becf6d09d7d9dda21ac5b

Description

Part of Jane Street's Core library The Core suite of libraries is an industrial strength alternative to OCaml's standard library that was developed by Jane Street, the largest industrial user of OCaml.

Published: 02 Jun 2023

Dependencies (5)

  1. num
  2. dune >= "2.0.0"
  3. sexplib0 >= "v0.16" & < "v0.17"
  4. parsexp >= "v0.16" & < "v0.17"
  5. ocaml >= "4.14.0"

Dev Dependencies

None

  1. amf < "0.1.2"
  2. arakoon = "1.9.0"
  3. async-zmq >= "0.3.0"
  4. async_core < "108.00.02"
  5. awa < "0.2.0"
  6. biocaml >= "0.11.0"
  7. bistro >= "0.2.0" & < "0.4.0" | >= "0.6.0"
  8. bookaml >= "3.1"
  9. caldav
  10. cconv-ppx
  11. charrua
  12. charrua-core >= "0.3"
  13. charrua-server
  14. cohttp >= "0.20.0" & < "1.2.0"
  15. cohttp-mirage < "2.0.0"
  16. conduit >= "0.12.0" & != "3.0.0"
  17. conduit-async >= "1.2.0" & != "3.0.0"
  18. conduit-lwt >= "1.3.0" & != "3.0.0"
  19. conduit-mirage != "3.0.0"
  20. conformist >= "0.2.1"
  21. coq-serapi < "8.7.2+0.4.13" | >= "8.10.0+0.7.1"
  22. core >= "v0.16.0"
  23. cppffigen
  24. cstruct >= "1.8.0" & != "3.6.0" & < "4.0.0"
  25. cstruct-sexp
  26. current_web >= "0.4"
  27. datakit-server >= "0.10.0" & < "0.11.0"
  28. datakit-server-9p
  29. decoders-sexplib
  30. diet < "0.4"
  31. dns-forward
  32. dockerfile >= "1.3.0"
  33. dockerfile-cmd >= "8.1.0"
  34. dockerfile-opam = "4.0.0" | >= "7.1.0"
  35. dune-deps
  36. earlybird >= "1.0.1"
  37. ego
  38. erlang
  39. ezjsonm >= "0.4.0" & < "1.2.0"
  40. ezjsonm-lwt
  41. frenetic >= "5.0.0" & < "5.0.5"
  42. git < "1.1.0"
  43. git-http >= "1.11.4" & < "2.1.0"
  44. graphql < "0.4.0"
  45. graphql_parser < "0.9.0"
  46. guile
  47. hack_parallel
  48. ipaddr >= "2.8.0" & < "3.0.0"
  49. jekyll-format >= "0.3.0"
  50. ketrew = "3.0.0"
  51. lazy-trie >= "1.2.0"
  52. lua_parser
  53. mecab
  54. message-switch >= "1.4.0"
  55. mirage-conduit = "1.3.0" | >= "3.1.0"
  56. mirage-crypto-pk < "0.10.4"
  57. mirage-http >= "2.5.0" & < "2.5.3"
  58. mirage-net-macosx
  59. mirage-net-xen >= "1.6.0" & < "1.7.1"
  60. mirage-tc >= "0.2.0" & < "0.3.0"
  61. msgpck < "1.1"
  62. nbd >= "2.1.0" & < "2.1.3" | >= "3.0.0"
  63. netchannel
  64. nocrypto >= "0.5.4-1"
  65. not-ocamlfind < "0.07.02"
  66. obuilder
  67. obuilder-spec
  68. ocaml-basics
  69. ocaml-indent
  70. ocaml-topexpect >= "0.3"
  71. odep
  72. odoc >= "1.4.0" & < "2.0.0"
  73. opam-dune-lint
  74. opass >= "1.0.6"
  75. open_packaging
  76. opine
  77. opium >= "0.14.0" & < "0.16.0"
  78. opium_kernel
  79. otr >= "0.3.1" & < "0.3.6"
  80. pa_ppx = "0.03" | >= "0.10"
  81. pgocaml >= "4.2"
  82. pgocaml_ppx >= "4.2" & < "4.3.0"
  83. planck >= "2.2.0"
  84. ppx_cstruct >= "4.0.0"
  85. ppx_log >= "v0.16.0"
  86. ppx_meta_conv = "2.0.2" | = "2.5.0"
  87. ppx_protocol_conv >= "5.1.2"
  88. ppx_protocol_conv_json >= "3.1.0" & != "4.0.0"
  89. ppx_protocol_conv_jsonm != "4.0.0"
  90. ppx_protocol_conv_msgpack >= "3.1.0" & != "4.0.0"
  91. ppx_protocol_conv_xml_light >= "3.1.0" & != "4.0.0"
  92. ppx_protocol_conv_xmlm
  93. ppx_protocol_conv_yaml >= "3.1.0" & != "4.0.0"
  94. protocol-9p >= "0.6.0" & < "2.0.2"
  95. protocol-9p-unix != "2.0.0"
  96. pyre-ast
  97. qcow
  98. qcow-format >= "0.3"
  99. qcow-tool
  100. sentry >= "v0.11.0"
  101. shared-block-ring >= "2.3.0"
  102. sihl < "0.2.0" | >= "0.3.0~rc2"
  103. sihl-core
  104. spin
  105. ssh-agent < "0.4.0"
  106. sslconf
  107. timedesc = "0.8.0"
  108. timedesc-sexp
  109. timmy
  110. tls >= "0.7.1" & < "0.17.0"
  111. tlstunnel >= "0.1.2"
  112. torch
  113. um-abt >= "0.1.7"
  114. uri >= "1.9.2" & < "2.0.0"
  115. vchan >= "2.1.0"
  116. vchan-unix
  117. vchan-xen
  118. vendredi
  119. vmnet >= "1.1.0"
  120. wamp = "1.0"
  121. x509 >= "0.5.1" & < "0.7.0"
  122. xapi-backtrace < "0.7"
  123. yaml >= "0.2.0" & < "3.0.0"
  124. yaml-sexp
  125. yices2_bindings
  126. zanuda

Conflicts

None