package uucp

  1. Overview
  2. Docs
Unicode character properties for OCaml

Install

Dune Dependency

Authors

Maintainers

Sources

uucp-15.0.0.tbz
sha512=ee4acff5666961766321e85e287fb9d5b8d50533319f22bf6f4eceb943242df2d0e0f4e775c4a140f68ca142837938eaa5926e22362215a3365ffe7f8768923b

Description

Uucp is an OCaml library providing efficient access to a selection of character properties of the Unicode character database.

Uucp is independent from any Unicode text data structure and has no dependencies. It is distributed under the ISC license.

Home page: http://erratique.ch/software/uucp

README

Uucp — Unicode character properties for OCaml

v15.0.0

Uucp is an OCaml library providing efficient access to a selection of character properties of the Unicode character database.

Uucp is independent from any Unicode text data structure and has no dependencies. It is distributed under the ISC license.

Home page: http://erratique.ch/software/uucp

Installation

Uucp can be installed with opam:

opam install uucp
opam install cmdliner uutf uunf uucp # for ucharinfo cli tool

If you don't use opam consult the opam file for build instructions and a complete specification of the dependencies.

Documentation

The documentation can be consulted online or via odig doc uucp.

Uucp's documentation also has a minimal Unicode introduction and some Unicode OCaml tips.

Questions are welcome but better asked on the OCaml forum than on the issue tracker.

Sample programs

The ucharinfo tool allows to report character information on the command line.

Sample programs are located in the test directory of the distribution. They can be built with:

topkg build --tests true

The resulting binaries are in _build/test :

  • test.native tests the library. Nothing should fail.

  • perf.native tests the performance of the library.

Dependencies (4)

  1. topkg build & >= "1.0.3"
  2. ocamlbuild build
  3. ocamlfind build
  4. ocaml >= "4.03.0"

Dev Dependencies (3)

  1. uutf with-test
  2. uunf with-test
  3. uucd with-test

Used by (17)

  1. archsat
  2. cmarkit
  3. confero
  4. crowbar
  5. down >= "0.0.4"
  6. inquire = "0.2.1"
  7. irmin-bench >= "2.7.0"
  8. jingoo >= "1.2.19"
  9. notty >= "0.2.0" & < "0.2.3"
  10. omd >= "2.0.0~alpha3"
  11. printbox >= "0.3" & < "0.6"
  12. printbox-text
  13. progress >= "0.2.0"
  14. rdf >= "0.13.0"
  15. terminal
  16. uuseg = "15.0.0"
  17. zed >= "3.2.0"

Conflicts (2)

  1. cmdliner < "1.1.0"
  2. uutf < "1.0.1"