package conduit-mirage

  1. Overview
  2. Docs
A network connection establishment library for MirageOS

Install

Dune Dependency

Authors

Maintainers

Sources

conduit-5.0.0.tbz
sha256=b7fa72d31c7bc077c647243904670df78e36cc693a839d6852b202b1b43ddff0
sha512=827b3f40bc0b7f84cf47b4acca015bdec403e63a595dda4e4532629a3c577523e7953e78545055e73d3075eae6aa501701de7b8ec24070818a6f5da17f9b0e5e

Description

Tags

org:mirage

Published: 21 Oct 2021

README

conduit -- an OCaml network connection establishment library

The conduit library takes care of establishing and listening for TCP and SSL/TLS connections for the Lwt and Async libraries.

The reason this library exists is to provide a degree of abstraction from the precise SSL library used, since there are a variety of ways to bind to a library (e.g. the C FFI, or the Ctypes library), as well as well as which library is used (just OpenSSL for now).

By default, OpenSSL is used as the preferred connection library, but you can force the use of the pure OCaml TLS stack by setting the environment variable CONDUIT_TLS=native when starting your program.

The opam packages available are:

  • conduit: the main Conduit module

  • conduit-lwt: the portable Lwt implementation

  • conduit-lwt-unix: the Lwt/Unix implementation

  • conduit-async the Jane Street Async implementation

  • conduit-mirage: the MirageOS compatible implementation

Debugging

Some of the Lwt_unix-based modules use a non-empty CONDUIT_DEBUG environment variable to output debugging information to standard error. Just set this variable when running the program to see what URIs are being resolved to.

Further Informartion

  • API Docs: https://mirage.github.io/ocaml-conduit/

  • WWW: https://github.com/mirage/ocaml-conduit

  • E-mail: mirageos-devel@lists.xenproject.org

  • Bugs: https://github.com/mirage/ocaml-conduit/issues

Dependencies (22)

  1. fmt >= "0.8.7"
  2. ipaddr-sexp
  3. ipaddr >= "3.0.0"
  4. ca-certs-nss
  5. tls-mirage >= "0.11.0"
  6. tls >= "0.11.0"
  7. xenstore
  8. vchan >= "5.0.0"
  9. conduit-lwt = version
  10. dns-client >= "6.0.0" & < "6.4.0"
  11. mirage-time >= "2.0.0"
  12. mirage-random >= "2.0.0"
  13. mirage-flow-combinators >= "2.0.0"
  14. mirage-flow >= "2.0.0"
  15. mirage-clock >= "3.0.0"
  16. mirage-stack >= "2.2.0"
  17. cstruct >= "3.0.0"
  18. uri >= "4.0.0"
  19. sexplib
  20. ppx_sexp_conv >= "v0.13.0"
  21. dune >= "2.0"
  22. ocaml >= "4.07.0"

Dev Dependencies (1)

  1. tcpip with-test & >= "6.0.0"

Used by (7)

  1. caqti-mirage < "2.1.1"
  2. cohttp-mirage = "2.3.0" | >= "3.0.0"
  3. gluten-mirage >= "0.3.0"
  4. h2-mirage = "0.5.0" | >= "0.8.0" & < "0.10.0"
  5. irmin-mirage-git = "2.3.0" | >= "2.5.0" & < "2.8.0"
  6. pgx_lwt_mirage >= "2.1"
  7. resp-mirage >= "0.10.0"

Conflicts (1)

  1. mirage-conduit