Access C-like structures directly from OCaml
Description

Access C-like structures directly from OCaml

Install

Published

19 Jul 2020

Authors

Maintainers

Sources

cstruct-v5.2.0.tbz
sha256=6bfef3753fab08cc638c07ca39f68d629087768f6a5cfeffc519d42018956a75 sha512=4e8cb53801980dacb9c9153bada89557ffcd9afaac262592fe6243bec3e76d5d1cfe3babe133a9a32e35ed00d98a4b54d55403e8505cca6a1328be50fadb5f37

Dependencies

alcotest with-test
dune >= "2.0.0"
ocaml >= "4.03.0"

Reverse Dependencies

albatross < "1.3.0"
angstrom >= "0.2.0" & < "0.7.0"
arakoon >= "1.8.6" & < "1.8.12"
arp >= "0.2.1" & < "3.0.0"
asn1-combinators >= "0.2.0-1" & < "0.2.6"
awa < "0.0.4"
awa-lwt < "0.0.4"
awa-mirage < "0.0.4"
capnp-rpc-net >= "1.1" & < "1.2.1"
carton < "0.4.3"
certify >= "0.2"
chacha < "1.1.0"
charrua < "1.4.1"
cohttp >= "0.9.7" & < "0.10.0"
colombe < "0.2.0"
conduit >= "0.6.0" & < "0.15.2"
conduit-async = "3.0.0"
conduit-lwt = "3.0.0"
conduit-mirage != "3.0.0"
conex < "0.10.0"
conex-nocrypto >= "0.11.0"
cowabloga >= "0.0.5"
crunch >= "2.0.0" & < "3.0.0"
cstruct-async >= "3.4.0" & < "4.0.0" | = "5.2.0"
cstruct-lwt >= "3.4.0" & < "4.0.0" | = "5.2.0"
cstruct-sexp = "5.0.0" | = "5.2.0"
cstruct-unix >= "3.1.0" & < "3.2.0" | >= "3.4.0" & < "4.0.0" | = "5.2.0"
current_web >= "0.4"
datakit-ci >= "0.12.4"
depyt >= "0.2.0"
dns >= "1.0.0" & < "6.0.0"
dns-client < "6.0.0"
dns-forward >= "0.9.0"
dream < "1.0.0~alpha2"
duff < "0.3"
eqaf >= "0.8"
ethernet < "2.2.1"
fat-filesystem >= "0.13.0" & < "0.15.1"
frenetic < "2.0.0" | >= "3.2.0" & < "5.0.0"
git >= "2.0.0" & < "3.5.0"
github-hooks >= "0.2.0"
gluten-mirage < "0.3.0"
hex >= "1.4.0"
hvsock < "3.0.0"
irmin >= "0.9.0" & < "1.0.0" | >= "1.1.0" & < "2.0.0"
irmin-git >= "2.3.0"
jose < "0.7.0"
key-parsers >= "0.5.0" & < "1.2.1"
ledgerwallet < "0.2.0"
letsencrypt = "0.2.5"
memtrace_viewer < "v0.15.0"
mirage >= "0.7.2" & < "0.9.0" | >= "0.10.0" & < "2.4.0"
mirage-block >= "2.0.0"
mirage-block-unix = "2.0.0" | = "2.7.0" | >= "2.11.1" & < "2.13.0"
mirage-block-xen >= "1.4.0" & < "1.5.2" | >= "1.6.0" & < "2.1.1"
mirage-channel >= "4.0.0" & < "4.1.0"
mirage-conduit < "2.0.0" | >= "2.3.1"
mirage-console >= "3.0.0" & < "4.0.0"
mirage-console-unix >= "2.2.1" & < "5.0.0"
mirage-console-xen-backend >= "2.3.2" & < "2.3.4" | = "4.0.0"
mirage-crypto < "0.10.4"
mirage-dns != "2.6.0" & < "2.7.0"
mirage-flow < "1.2.0" | >= "2.0.0"
mirage-fs >= "0.4.0" & < "1.0.0" | >= "3.0.0"
mirage-fs-unix < "1.1.0" | >= "1.4.0" & != "1.5.0"
mirage-nat < "2.2.4"
mirage-net = "0.5.2" | >= "3.0.0"
mirage-net-unix < "2.1.0" | >= "2.2.1"
mirage-net-xen != "1.4.2" & != "1.7.0" & < "2.1.0"
mirage-profile >= "0.8.2"
mirage-qubes != "0.2" & < "0.5" | >= "0.7.0" & < "0.9.2"
mirage-unix < "0.9.4" | >= "2.5.0" & < "3.0.8"
mirage-vnetif < "0.6.0"
mirage-www < "0.4.0" | >= "1.1.0"
mirage-xen < "2.0.0" | >= "2.6.0"
mrt-format >= "0.3.1"
nbd = "4.0.3"
netchannel < "2.1.0"
nocrypto < "0.4.0" | >= "0.5.4-1"
openflow < "0.2.0"
otr = "0.3.1" | >= "0.3.5" & < "0.3.9"
ox < "1.1.1"
pbkdf < "0.3.0" | = "1.1.0"
pcap-format >= "0.5.2"
plebeia < "2.0.0"
ppx_cstruct = "5.2.0"
protocol-9p = "2.0.1"
protocol-9p-tool = "0.12.0" | >= "2.0.0" & < "2.0.2"
qcow >= "0.11.0"
rawlink >= "0.6" & < "1.2"
resp-mirage = "0.10.0"
rfc6287 >= "1.0.2"
salsa20 < "1.2.0"
salsa20-core >= "0.3.0" & < "1.1.0"
scrypt-kdf >= "0.2.0" & < "1.2.0"
sendmail >= "0.4.1" & < "0.5.0"
shared-memory-ring >= "3.0.1" & < "3.1.1"
tar >= "1.0.0" & < "2.0.0"
tar-unix != "1.0.0" & < "2.0.0"
tcpip >= "3.3.0" & < "6.3.0"
tls >= "0.10.2" & < "0.14.0"
u2f = "0.1.1"
vchan >= "3.0.0" & < "6.0.1"
vhd-format >= "0.12.0"
vhd-tool < "0.12.0"
vmnet >= "1.1.0"
x509 >= "0.6.3" & < "0.14.1"
xen-api-client >= "0.9.6" & < "0.9.14"
xenstore >= "2.1.0"

Conflicts

js_of_ocaml < "3.5.0"