toplevel_expect_test

Expectation tests for the OCaml toplevel
Overview Documentation
Description

Allows one to write both toplevel phrases and the expected output from the toplevel in the same file. This provides an easy way to test compilations errors as well as provide a nice alternative to using the toplevel in a terminal.

Install
Published
28 Apr 2016
Sources
toplevel_expect_test-113.33.03.tar.gz
md5=9eb6aa7f6eecf22a088303c3db48ddcc
Dependencies
variantslib
>= "113.33.03" & < "113.34.00"
typerep
>= "113.33.03" & < "113.34.00"
sexplib
>= "113.33.03" & < "113.34.00"
ppx_jane
>= "113.33.03" & < "113.34.00"
ppx_inline_test
>= "113.33.03" & < "113.34.00"
ppx_here
>= "113.33.03" & < "113.34.00"
ppx_expect
>= "113.33.03" & < "113.34.00"
ppx_driver
>= "113.33.03" & < "113.34.00"
ppx_core
>= "113.33.03" & < "113.34.00"
ppx_bench
>= "113.33.03" & < "113.34.00"
ppx_assert
>= "113.33.03" & < "113.34.00"
ocamlfind
>= "1.3.2"
js-build-tools
build & >= "113.33.04" & < "113.34.00"
fieldslib
>= "113.33.03" & < "113.34.00"
core_kernel
>= "113.33.03" & < "113.34.00"
bin_prot
>= "113.33.03" & < "113.34.00"
ocamlfind
build & >= "1.3.2"
ocaml
= "4.02.3"
Reverse Dependencies