ppx_expect

Cram like framework for OCaml
Description

Part of the Jane Street's PPX rewriters collection.

Install
Published
21 Mar 2022
Sources
ppx_expect-v0.15.0.tar.gz
sha256=06315a45b43da72f96719bcb183c0177b5198beae8c3ddce357e180a32f9ca7b
Dependencies
re
>= "1.8.0"
ppxlib
>= "0.23.0"
dune
>= "2.0.0"
stdio
>= "v0.15" & < "v0.16"
ppx_inline_test
>= "v0.15" & < "v0.16"
ppx_here
>= "v0.15" & < "v0.16"
base
>= "v0.15" & < "v0.16"
ocaml
>= "4.08.0" & < "5.0"
Reverse Dependencies
ansi-parse
>= "0.4.0"
bio_io
>= "0.2.1"
camelot
>= "1.3.0"
combinat
< "3.0"
electrod
>= "0.1.6" & < "0.2.1"
ez_cmdliner
>= "0.2.0"
ez_config
>= "0.2.0"
ez_file
>= "0.2.0"
feather
>= "0.2.0"
fiat-p256
< "0.2.0"
GT
>= "0.4.0" & < "0.5.0"
http-cookie
>= "4.0.0"
influxdb
>= "0.2.0"
js_of_ocaml
>= "3.10.0"
js_of_ocaml-lwt
>= "3.10.0"
js_of_ocaml-ppx
>= "3.10.0"
kqueue
>= "0.2.0"
loga
>= "0.0.5"
lsp
< "1.8.0" | >= "1.11.3"
mlt_parser
>= "v0.15.0"
nsq
>= "0.4.0" & < "0.5.2"
OCanren-ppx
>= "0.3.0~alpha1"
ocplib_stuff
>= "0.3.0"
odate
>= "0.6"
odoc
>= "2.0.0"
opam-bin
>= "0.9.5"
opam_bin_lib
>= "0.9.5"
ppx_jane
>= "v0.15.0"
ppx_relit
>= "0.2.0"
psmt2-frontend
>= "0.3.0"
pythonlib
>= "v0.15.0"
spawn
< "v0.9.0" | >= "v0.14.0"
tezos-stdlib
>= "14.0"
travesty
>= "0.3.0" & < "0.6.0" | >= "0.7.0"
wtr
>= "2.0.0"