package odoc

  1. Overview
  2. No Docs

Description

odoc is a powerful and flexible documentation generator for OCaml. It reads doc comments, demarcated by (** ... *), and transforms them into a variety of output formats, including HTML, LaTeX, and man pages.

  • Output Formats: Odoc generates HTML for web browsing, LaTeX for PDF generation, and man pages for use on Unix-like systems.
  • Cross-References: odoc uses the ocamldoc markup, which allows to create links for functions, types, modules, and documentation pages.
  • Link to Source Code: Documentation generated includes links to the source code of functions, providing an easy way to navigate from the docs to the actual implementation.
  • Code Highlighting: odoc automatically highlights syntax in code snippets for different languages.

odoc is part of the OCaml Platform, the recommended set of tools for OCaml.

Published: 24 Jan 2024

Dependencies (11)

  1. crunch > "1.1.0"
  2. fmt
  3. tyxml >= "4.4.0"
  4. result
  5. ocaml >= "4.02.0" & < "5.2"
  6. fpath
  7. dune >= "3.7.0"
  8. cppo build & >= "1.1.0"
  9. cmdliner >= "1.0.0"
  10. astring
  11. odoc-parser = version

Dev Dependencies (9)

  1. bisect_ppx with-test & > "2.5.0"
  2. ocaml < "4.07.0" & with-test
  3. bos with-test
  4. ppx_expect with-test
  5. conf-jq with-test
  6. sexplib0 with-test
  7. ocaml < "4.04.1" & with-test
  8. yojson >= "1.6.0" & with-test
  9. ocamlfind with-test

  1. absolute >= "0.2"
  2. acgtk >= "2.0.0"
  3. adobe_font_metrics
  4. agrid
  5. aifad >= "2.3.0"
  6. alba >= "0.4.1"
  7. alcotest = "1.1.0" | = "1.2.3" | >= "1.5.0"
  8. alcotest-async >= "1.5.0"
  9. alcotest-js
  10. alcotest-lwt >= "1.5.0"
  11. alcotest-mirage >= "1.5.0"
  12. algaeff
  13. alt-ergo >= "2.4.1"
  14. alt-ergo-lib >= "2.4.1"
  15. alt-ergo-parsers >= "2.4.1"
  16. alt-ergo-plugin-ab-why3
  17. altgr-ergo >= "2.4.1"
  18. ambient-context
  19. ambient-context-eio
  20. ambient-context-lwt
  21. anders < "0.7.1"
  22. ansi >= "0.6.0"
  23. ansi-parse >= "0.4.0"
  24. antic
  25. ao >= "0.2.4"
  26. arb
  27. archetype >= "1.2.3"
  28. arg-complete
  29. argon2 >= "1.0.0"
  30. argsh
  31. arrakis
  32. asai
  33. asak
  34. ask
  35. ask-integrator
  36. async-uri >= "0.4.0"
  37. atable
  38. atacama
  39. atd >= "2.3.3"
  40. atdd
  41. atdgen >= "2.3.3"
  42. atdgen-codec-runtime >= "2.3.3"
  43. atdgen-runtime >= "2.3.3"
  44. atdj >= "2.3.3" & < "20151001.01"
  45. atdpy
  46. atds >= "2.3.3"
  47. atdts
  48. autofonce
  49. autofonce_config
  50. autofonce_core
  51. autofonce_lib
  52. autofonce_m4
  53. autofonce_misc
  54. autofonce_patch
  55. autofonce_share
  56. avro
  57. avro-compiler
  58. awsm
  59. awsm-async
  60. awsm-codegen
  61. awsm-lwt
  62. backoff
  63. baguette_sharp
  64. bam
  65. bare_encoding
  66. base32
  67. bastet
  68. bastet_async
  69. bastet_lwt
  70. batsat
  71. batteries >= "3.7.1"
  72. beluga >= "1.1"
  73. bencode >= "2.0"
  74. bestline
  75. bin_tree
  76. bindlib >= "6.0.0"
  77. binsec >= "0.4.0"
  78. bio_io
  79. biotk
  80. bitcoin >= "3.0"
  81. bitcoin-cohttp-async
  82. bitcoin-cohttp-lwt
  83. bitcoin-ocurl
  84. bitcoinml
  85. bitmasks >= "1.1.0"
  86. bitpack_serializer
  87. bitwuzla
  88. bitwuzla-c
  89. bitwuzla-cxx
  90. bls12-381 >= "6.0.1" & < "18.0"
  91. blurhash
  92. bogue >= "20210917"
  93. bogue-tutorials
  94. boltzgen >= "0.9.2"
  95. boulangerie
  96. box
  97. brotli >= "2.0.3"
  98. brr-lwd
  99. bwd
  100. bytebuffer
  101. ca-certs-nss >= "3.64.0.1"
  102. cairn
  103. caisar
  104. caisar-ir
  105. caisar-nnet
  106. caisar-onnx
  107. caisar-ovo
  108. caisar-xgboost
  109. calcium
  110. calculon >= "0.3"
  111. calculon-web >= "0.3"
  112. calendar >= "3.0.0"
  113. calipso
  114. camelot >= "1.3.0"
  115. camlimages >= "5.0.5"
  116. camlp-streams >= "5.0.1"
  117. camlrack
  118. camomile >= "2.0.0"
  119. camyll
  120. canary
  121. caqti >= "1.7.0"
  122. caqti-async >= "1.7.0"
  123. caqti-driver-mariadb >= "1.7.0"
  124. caqti-driver-postgresql >= "1.7.0"
  125. caqti-driver-sqlite3 >= "1.7.0"
  126. caqti-eio
  127. caqti-lwt >= "1.7.0"
  128. caqti-mirage
  129. caqti-tls
  130. caqti-type-calendar >= "1.9.0"
  131. carbon
  132. castore
  133. catala >= "0.5.0"
  134. catapult
  135. catapult-client
  136. catapult-daemon
  137. catapult-file
  138. catapult-sqlite
  139. cborl
  140. ccbg
  141. cf
  142. cf-lwt
  143. cfg >= "2.3.0"
  144. chamo >= "4.0"
  145. choice >= "0.4"
  146. chrome-trace
  147. cid
  148. clangml >= "4.2.0"
  149. clangml-transforms >= "0.26"
  150. clap >= "0.2.0"
  151. clarity-lang
  152. clim
  153. clim-ppx
  154. cll
  155. clp_operations
  156. cmon
  157. cohttp >= "6.0.0~alpha0"
  158. cohttp-async >= "6.0.0~alpha0"
  159. cohttp-curl
  160. cohttp-curl-async
  161. cohttp-curl-lwt
  162. cohttp-eio
  163. cohttp-lwt >= "6.0.0~alpha0"
  164. cohttp-lwt-jsoo >= "6.0.0~alpha0"
  165. cohttp-lwt-unix >= "6.0.0~alpha0"
  166. cohttp-mirage >= "6.0.0~alpha0"
  167. cohttp-server-lwt-unix
  168. cohttp-top >= "6.0.0~alpha0"
  169. colibri2
  170. colibrics
  171. colibrilib
  172. colors
  173. combinaml
  174. combinat >= "3.0"
  175. config
  176. config-file >= "1.2.1"
  177. conformist >= "0.8.1"
  178. containers >= "2.0"
  179. containers-data
  180. containers-thread
  181. coq >= "8.19.0"
  182. coq-core >= "8.19.0"
  183. coq-stdlib >= "8.19.0"
  184. coqide >= "8.19.0"
  185. coqide-server >= "8.19.0"
  186. crc >= "2.0.0"
  187. crontab
  188. crowbar >= "0.2.1"
  189. cry >= "0.6.6"
  190. csexp >= "1.5.1"
  191. css
  192. ctoxml
  193. ctypes >= "0.21.1"
  194. ctypes-foreign >= "0.21.1"
  195. cucumber
  196. cudf >= "0.10"
  197. cue_sheet_maker
  198. curly >= "0.2.0"
  199. current >= "0.6.4"
  200. current-albatross-deployer
  201. current-web-pipelines
  202. current_docker >= "0.6.4"
  203. current_examples >= "0.6.4"
  204. current_git >= "0.6.4"
  205. current_github >= "0.6.4"
  206. current_gitlab >= "0.6.4"
  207. current_ocluster >= "0.2"
  208. current_rpc >= "0.6.4"
  209. current_slack >= "0.6.4"
  210. current_ssh
  211. current_web >= "0.6.4"
  212. curses >= "1.0.10"
  213. cwe_checker >= "0.3"
  214. DkSDKFFIOCaml_Std
  215. data-encoding >= "0.5"
  216. datalog >= "0.6"
  217. dates_calc
  218. dbf >= "0.2.0"
  219. decimal
  220. decoders >= "0.5.0"
  221. decoders-bencode
  222. decoders-cbor
  223. decoders-ezjsonm >= "0.3.0"
  224. decoders-ezxmlm
  225. decoders-jsonaf
  226. decoders-jsonm
  227. decoders-msgpck
  228. decoders-sexplib
  229. decoders-yojson >= "0.3.0"
  230. delimcc_of_fxhandler
  231. devkit >= "1.20210120"
  232. diff
  233. diskuvbox
  234. disml
  235. dkml-c-probe
  236. dkml-component-offline-ocamlrun
  237. dkml-component-offline-opam
  238. dkml-component-staging-ocamlrun >= "4.12.1~v1.0.2"
  239. dkml-component-staging-opam32 < "2.2.0~dkml20220801"
  240. dkml-component-staging-opam64 < "2.2.0~dkml20220801"
  241. dkml-dune-dsl
  242. dkml-dune-dsl-show
  243. dkml-install
  244. dkml-install-installer
  245. dkml-install-runner
  246. dkml-option-vcpkg
  247. dkml-package-console
  248. dkml-runtime-distribution
  249. dkml-workflows
  250. dlm >= "0.3.3"
  251. dmap
  252. docfd
  253. docker-api >= "0.2.2"
  254. dockerfile >= "8.1.0"
  255. dockerfile-cmd >= "8.1.0"
  256. dockerfile-opam >= "8.1.0"
  257. doculib
  258. doi2bib >= "0.3.0"
  259. dolmen >= "0.5"
  260. dolmen_bin
  261. dolmen_loop
  262. dolmen_lsp
  263. dolmen_model
  264. dolmen_type
  265. domain-local-await
  266. domain-local-timeout
  267. domainslib >= "0.5.1"
  268. dose3 >= "6.1"
  269. dose3-extra
  270. dream-accept
  271. dream-cli
  272. dream-encoding
  273. dream-html
  274. dream-htmx
  275. dream-livereload
  276. drom
  277. drom_lib
  278. drom_toml
  279. dscheck
  280. dssi >= "0.1.4"
  281. dtools >= "0.4.3"
  282. dual
  283. dump_ocamlformat
  284. dune-action-plugin >= "2.7.0"
  285. dune-build-info >= "2.7.0"
  286. dune-compiledb
  287. dune-configurator >= "2.7.0"
  288. dune-expand
  289. dune-glob >= "2.7.0"
  290. dune-private-libs >= "2.7.0"
  291. dune-release
  292. dune-rpc
  293. dune-rpc-lwt
  294. dune-site
  295. duppy >= "0.9.1"
  296. dyn
  297. earley >= "3.0.0"
  298. earlybird >= "1.0.0"
  299. easy-format >= "1.3.3"
  300. ego
  301. eio
  302. eio-ssl >= "0.1.1"
  303. eio-trace
  304. eio_linux
  305. eio_luv
  306. eio_main
  307. eio_posix
  308. eio_windows
  309. electrod >= "1.0.0"
  310. eliom >= "10.1.2"
  311. elpi >= "1.16.7"
  312. embedded_ocaml_templates >= "0.8"
  313. encoding
  314. equinoxe
  315. equinoxe-cohttp
  316. equinoxe-hlc
  317. eris
  318. eris-lwt
  319. erlang
  320. errpy
  321. extism
  322. extism-manifest
  323. extunix >= "0.4.0"
  324. ez_cmdliner >= "0.2.0"
  325. ez_config >= "0.2.0"
  326. ez_file >= "0.2.0"
  327. ez_hash
  328. ez_opam_file
  329. ez_search
  330. ez_subst
  331. ezcurl
  332. ezcurl-lwt
  333. ezgzip
  334. ezjs_fetch >= "0.3"
  335. ezjs_idb >= "0.1.1"
  336. ezjs_min >= "0.2.2"
  337. ezjsonm-encoding
  338. FPauth
  339. FPauth-core
  340. FPauth-responses
  341. FPauth-strategies
  342. FrontC >= "4.0.0"
  343. faad >= "0.5.1"
  344. fadbadml >= "0.1.2"
  345. farith
  346. fd-send-recv >= "2.0.1"
  347. fdkaac >= "0.3.3"
  348. feather >= "0.2.0"
  349. feather_async >= "0.2.0"
  350. ffmpeg >= "1.0.0~beta2"
  351. ffmpeg-av >= "1.0.0~beta2"
  352. ffmpeg-avcodec >= "1.0.0~beta2"
  353. ffmpeg-avdevice >= "1.0.0~beta2"
  354. ffmpeg-avfilter >= "1.0.0~beta2"
  355. ffmpeg-avutil >= "1.0.0~beta2"
  356. ffmpeg-swresample >= "1.0.0~beta2"
  357. ffmpeg-swscale >= "1.0.0~beta2"
  358. fiat-p256 = "0.2.2"
  359. fiber
  360. fiber-lwt
  361. flac >= "0.3.1"
  362. flint
  363. fmlib
  364. fmlib_browser
  365. fmlib_js
  366. fmlib_parse
  367. fmlib_pretty
  368. fmlib_std
  369. fontforge-of-ocaml
  370. forester
  371. frama-c >= "27.0"
  372. frama-c-metacsl >= "0.4"
  373. frama-clang
  374. frenetic >= "5.0.0"
  375. fsevents
  376. fsevents-lwt
  377. GT >= "0.5.0"
  378. gccjit
  379. gen >= "0.5.1"
  380. gen_js_api >= "1.0.8"
  381. geojson
  382. geojsone
  383. geoml
  384. getopt >= "20230213"
  385. github >= "4.4.0"
  386. github-data
  387. github-jsoo >= "4.4.0"
  388. github-unix >= "4.4.0"
  389. gitlab
  390. gitlab-jsoo
  391. gitlab-unix
  392. gitlab_pipeline_notifier
  393. globlon
  394. gluten >= "0.5.0"
  395. gluten-async >= "0.5.0"
  396. gluten-eio >= "0.5.0"
  397. gluten-lwt >= "0.5.0"
  398. gluten-lwt-unix >= "0.5.0"
  399. gluten-mirage >= "0.5.0"
  400. gnuplot >= "0.6"
  401. goblint >= "1.1.1"
  402. goblint-cil >= "1.8.0"
  403. gospel >= "0.2.0"
  404. gotd
  405. gperftools >= "0.4"
  406. gpiod
  407. gpt
  408. grace
  409. gradescope_submit
  410. graphv
  411. graphv_core
  412. graphv_core_lib
  413. graphv_font
  414. graphv_font_js
  415. graphv_font_stb_truetype
  416. graphv_gles2
  417. graphv_gles2_native
  418. graphv_gles2_native_impl
  419. graphv_webgl
  420. graphv_webgl_impl
  421. grpc
  422. grpc-async
  423. grpc-bench
  424. grpc-eio
  425. grpc-examples
  426. grpc-lwt
  427. gsl >= "1.25.0"
  428. guardian
  429. guile
  430. h1_parser
  431. h2 >= "0.10.0"
  432. h2-async >= "0.10.0"
  433. h2-eio
  434. h2-lwt >= "0.10.0"
  435. h2-lwt-unix >= "0.10.0"
  436. h2-mirage >= "0.10.0"
  437. hacl-star >= "0.4.0"
  438. hacl_func
  439. hacl_x25519 = "0.2.1"
  440. hashcons >= "1.4.0"
  441. hc >= "0.2"
  442. hdr_histogram
  443. headache = "1.06"
  444. header-check
  445. highlexer
  446. higlo >= "0.8"
  447. hilite
  448. hockmd
  449. hol2dk
  450. hooke
  451. hpack >= "0.10.0"
  452. hsluv
  453. html_of_jsx
  454. htmlfromtexbooks
  455. http
  456. http-cookie
  457. http-date
  458. http-multipart-formdata
  459. http_async
  460. httpaf_caged >= "1.0.1"
  461. ISO3166
  462. ISO8601 >= "0.2.6"
  463. idds
  464. inotify >= "2.4"
  465. inquire >= "0.3.0"
  466. inquirer_oc
  467. interval-map
  468. iomux
  469. ip2location
  470. ip2locationio
  471. irc-client >= "0.6.2"
  472. irc-client-lwt >= "0.6.2"
  473. irc-client-lwt-ssl
  474. irc-client-tls >= "0.6.2"
  475. irc-client-unix >= "0.6.2"
  476. iri >= "0.6.0"
  477. irmin >= "3.0.0"
  478. irmin-watcher >= "0.5.0"
  479. iter
  480. jekyll-format >= "0.2.0"
  481. jerboa
  482. jext
  483. jose >= "0.6.0"
  484. js_of_ocaml >= "3.10.0"
  485. js_of_ocaml-compiler >= "3.10.0"
  486. js_of_ocaml-lwt >= "3.10.0"
  487. js_of_ocaml-ocamlbuild >= "3.10.0"
  488. js_of_ocaml-ppx >= "3.10.0"
  489. js_of_ocaml-ppx_deriving_json >= "3.10.0"
  490. js_of_ocaml-toplevel >= "3.10.0"
  491. js_of_ocaml-tyxml >= "3.10.0"
  492. json-data-encoding >= "0.12"
  493. jsonoo
  494. jsonrpc >= "1.4.0"
  495. jsonschema2atd
  496. jsoo-react
  497. junit >= "1.0"
  498. junit_alcotest
  499. junit_ounit
  500. jupyter-kernel >= "0.4"
  501. jwto >= "0.4.0"
  502. kcas >= "0.1.6"
  503. kcas_data
  504. kdl
  505. kind2
  506. kittyimg
  507. kkmarkdown
  508. knights_tour
  509. kqueue >= "0.2.0"
  510. lab
  511. lablgtk3-extras >= "3.0.1"
  512. lacaml >= "11.0.10"
  513. ladspa >= "0.2.1"
  514. lambda
  515. lambda-term >= "3.3.0"
  516. lambda_streams
  517. lambdapi >= "2.0.0"
  518. lame >= "0.3.6"
  519. landmarks >= "1.4"
  520. landmarks-ppx
  521. ldap >= "2.4.2"
  522. ldp
  523. ldp_curl
  524. ldp_js
  525. ldp_tls
  526. leaflet
  527. learn-ocaml >= "0.12"
  528. leaves
  529. letters != "0.1.1"
  530. leveldb >= "1.3.0"
  531. libc
  532. libsail
  533. lilv
  534. linenoise >= "1.3.1"
  535. linol
  536. linol-lwt
  537. lintcstubs
  538. lintcstubs-arity
  539. lintcstubs-gen
  540. liquidsoap >= "2.2.0"
  541. liquidsoap-core
  542. liquidsoap-js
  543. liquidsoap-lang
  544. liquidsoap-libs
  545. liquidsoap-libs-extra
  546. liquidsoap-mode
  547. little_logger
  548. llama
  549. llama-cpp-ocaml
  550. llama_core
  551. llama_interactive
  552. llama_midi
  553. lmdb >= "1.0"
  554. logical
  555. logs-async >= "1.3"
  556. logs-async-reporter >= "1.3"
  557. loop
  558. lreplay
  559. lru_cache < "v0.16.0"
  560. lsp >= "1.4.0"
  561. lua-ml >= "0.9.3"
  562. lua_parser >= "1.0.2"
  563. lwd >= "0.2"
  564. lwt-parallel >= "1.0.0"
  565. lwt-pipe
  566. lwt_eio
  567. lz4 >= "1.2.0"
  568. m_tree
  569. mad >= "0.5.1"
  570. make-random
  571. matita
  572. mc2
  573. md2mld >= "0.7.0"
  574. mdx = "1.7.0" | >= "1.11.0"
  575. mec
  576. mehari
  577. mehari-eio
  578. mehari-eio-unix
  579. mehari-lwt-unix
  580. mehari-mirage
  581. mel
  582. melange
  583. melange-atdgen-codec-runtime
  584. melange-compiler-libs
  585. melange-fetch
  586. melange-jest
  587. melange-json
  588. melange-moment
  589. melange-numeral
  590. melange-radix-icons
  591. melange-react-dates
  592. melange-react-query
  593. melange-recharts
  594. melange-testing-library
  595. melange-webapi
  596. meldep
  597. mem_usage
  598. memgraph
  599. memgraph_kitty
  600. metadata
  601. metadb
  602. metapp >= "0.3.0"
  603. metaquot >= "0.3.0"
  604. middleware
  605. minisat >= "0.2"
  606. minttea
  607. mjson
  608. mlbdd >= "0.7.2"
  609. mlmpfr >= "4.2.0"
  610. mm >= "0.7.2"
  611. mnd
  612. module-graph
  613. monocypher
  614. monomorphic >= "2.0"
  615. moonpool
  616. morbig >= "0.10.3"
  617. mpg123 >= "0.3"
  618. mpris >= "0.2.0"
  619. mpris-clients
  620. mssql >= "2.0.3"
  621. mugen
  622. mula
  623. multibase
  624. multicodec
  625. multicont >= "1.0.1"
  626. multicore-bench
  627. multicore-magic
  628. multihash
  629. multihash-digestif
  630. mustache >= "3.2.0"
  631. mustache-cli
  632. mysql_protocol >= "3.0.1"
  633. nanoid
  634. nanosvg
  635. nanosvg_text
  636. nbd >= "6.0.0"
  637. nbd-tool
  638. nbd-unix
  639. netkat
  640. nice_parser
  641. ninja_utils
  642. nloge
  643. nlopt
  644. nmea
  645. noCanren >= "0.3.0~alpha1"
  646. node_of_ocaml
  647. nottui >= "0.2"
  648. nottui-lwt >= "0.2"
  649. nottui-pretty >= "0.2"
  650. nunchaku >= "0.5.1"
  651. nuscr >= "1.1.0"
  652. OCADml
  653. OCanren >= "0.3.0~alpha1"
  654. OCanren-ppx >= "0.3.0~alpha1"
  655. OSCADml
  656. obuilder
  657. obuilder-spec
  658. ocaml-canvas
  659. ocaml-compiler-libs = "v0.12.4"
  660. ocaml-in-python
  661. ocaml-logicalform
  662. ocaml-lsp-server >= "1.4.0"
  663. ocaml-lua >= "1.8"
  664. ocaml-protoc >= "2.1"
  665. ocaml-version >= "3.6.0"
  666. ocamlc-loc
  667. ocamldiff >= "1.2"
  668. ocamlformat >= "0.19.0~4.13preview"
  669. ocamlformat-lib
  670. ocamlformat-rpc >= "0.19.0" & < "removed"
  671. ocamlformat-rpc-lib
  672. ocamlfuse >= "2.7.1-cvs8"
  673. ocamlregextkit
  674. ocb
  675. ocf >= "0.8.0"
  676. ocf_ppx
  677. ockt
  678. ocluster >= "0.2"
  679. ocluster-api >= "0.2"
  680. ocluster-worker
  681. ocp-browser >= "1.2.2"
  682. ocp-index >= "1.2.2"
  683. ocp-search
  684. ocplib_stuff >= "0.3.0"
  685. odep >= "0.2.0"
  686. odig >= "0.0.7"
  687. oframl
  688. ogg >= "0.7.1"
  689. ojo
  690. ojs >= "1.0.8"
  691. ojs_base
  692. ojs_base_all
  693. ojs_base_ppx
  694. ojs_ed
  695. ojs_filetree
  696. ojs_list
  697. olinq >= "0.3"
  698. oma
  699. omd = "1.3.2" | >= "2.0.0~alpha3"
  700. omigrate != "0.3.0"
  701. omtl
  702. oniguruma
  703. opam-0install >= "0.4.2"
  704. opam-0install-cudf >= "0.4.2"
  705. opam-bin >= "0.9.5"
  706. opam-check-npm-deps
  707. opam-compiler >= "0.2.0"
  708. opam-dune-lint
  709. opam-monorepo >= "0.3.0"
  710. opam-spin
  711. opam_bin_lib >= "0.9.5"
  712. opasswd >= "1.3.1"
  713. openapi
  714. openapi_router
  715. openstellina
  716. opentelemetry
  717. opentelemetry-client-cohttp-lwt
  718. opentelemetry-client-ocurl
  719. opentelemetry-cohttp-lwt
  720. opentelemetry-lwt
  721. opine
  722. opium >= "0.20.0"
  723. opium-testing >= "0.20.0"
  724. oplot != "0.50"
  725. optiml-transport
  726. opus >= "0.2.1"
  727. oraft >= "0.3.0"
  728. ordering
  729. ordinal
  730. orgeat
  731. oseq
  732. osh
  733. osnap
  734. otoggl
  735. otoml >= "0.9.3"
  736. ounit2 >= "2.2.7"
  737. ounit2-lwt >= "2.2.7"
  738. override >= "0.4.0"
  739. owi
  740. p5scm
  741. packstream
  742. pancake
  743. pandoc >= "0.2.1"
  744. pandoc-abbreviations >= "0.2.1"
  745. pandoc-comment >= "0.2.1"
  746. pandoc-crossref >= "0.2.1"
  747. pandoc-include >= "0.2.1"
  748. pandoc-inspect >= "0.2.1"
  749. pandoc-pdf2png >= "0.2.1"
  750. pandoc-replace >= "0.2.1"
  751. par_incr
  752. pari
  753. pari-bindings
  754. parmap >= "1.2.3"
  755. path_glob
  756. patoline >= "0.2"
  757. pbrt
  758. pbrt_yojson
  759. pcre >= "7.5.0"
  760. pcre2
  761. petrol
  762. pgx >= "1.0"
  763. pgx_async >= "2.2"
  764. pgx_lwt >= "2.2"
  765. pgx_lwt_mirage >= "2.2"
  766. pgx_lwt_unix >= "2.2"
  767. pgx_unix >= "2.2"
  768. pgx_value_core >= "2.2"
  769. pgx_value_ptime >= "2.2"
  770. phylogenetics >= "0.2.0"
  771. piece_rope
  772. plateau
  773. plist-xml
  774. plist-xml-lwt
  775. plotly
  776. plplot >= "5.12.0"
  777. polars
  778. polars_async
  779. poll
  780. popper
  781. portaudio >= "0.2.3"
  782. portmidi
  783. posix-base >= "2.0.1"
  784. posix-bindings >= "2.0.1"
  785. posix-getopt >= "2.0.1"
  786. posix-signal >= "2.0.1"
  787. posix-socket >= "2.0.1"
  788. posix-socket-unix >= "2.0.1"
  789. posix-time2 >= "2.0.1"
  790. posix-types >= "2.0.1"
  791. posix-uname >= "2.0.1"
  792. pp >= "1.2.0"
  793. pp-binary-ints
  794. pp_loc
  795. ppx_camlrack
  796. ppx_catch
  797. ppx_const >= "2.0"
  798. ppx_decimal
  799. ppx_default
  800. ppx_deriving_cad
  801. ppx_deriving_encoding >= "0.3.0"
  802. ppx_deriving_hash
  803. ppx_deriving_madcast >= "0.2"
  804. ppx_deriving_popper
  805. ppx_deriving_qcheck >= "0.2.0"
  806. ppx_deriving_scad
  807. ppx_deriving_yaml >= "0.2.0"
  808. ppx_distr_guards >= "0.3"
  809. ppx_dream_eml
  810. ppx_getenv >= "2.0"
  811. ppx_interact
  812. ppx_make
  813. ppx_map
  814. ppx_minidebug
  815. ppx_monad
  816. ppx_monoid >= "0.3.3"
  817. ppx_open
  818. ppx_optint
  819. ppx_parser
  820. ppx_pyformat
  821. ppx_repr != "0.2.0"
  822. ppx_seq
  823. ppx_subliner
  824. ppx_system
  825. ppx_trace
  826. ppx_ts
  827. ppx_update
  828. ppx_viewpattern
  829. ppx_yojson >= "1.3.0"
  830. ppxlib >= "0.22.0"
  831. pratter
  832. prbnmcn-basic-structures
  833. prbnmcn-cgrph
  834. prbnmcn-clustering
  835. prbnmcn-dagger
  836. prbnmcn-dagger-gsl
  837. prbnmcn-dagger-stats
  838. prbnmcn-dagger-test
  839. prbnmcn-gnuplot
  840. prbnmcn-linalg
  841. prbnmcn-mcts
  842. prbnmcn-proptest
  843. prbnmcn-stats
  844. prbnmcn-ucb1 >= "0.0.2"
  845. preface
  846. pretty_expressive
  847. printbox >= "0.2"
  848. printbox-html
  849. printbox-md
  850. printbox-text
  851. processor
  852. producer
  853. progress
  854. prometheus-liquidsoap >= "2"
  855. promise_jsoo
  856. prr
  857. psmt2-frontend >= "0.3.0"
  858. pulseaudio >= "0.1.5"
  859. pvec
  860. pyast
  861. pyml >= "20210924"
  862. pyml_bindgen
  863. pyre-ast
  864. qbf >= "0.3"
  865. qcheck >= "0.9"
  866. qcheck-alcotest
  867. qcheck-core
  868. qcheck-lin
  869. qcheck-multicoretests-util
  870. qcheck-ounit
  871. qcheck-stm
  872. qiskit >= "0.44.0"
  873. quick_print
  874. randii
  875. random
  876. randoml
  877. raygui
  878. raylib >= "0.3.1"
  879. rdf >= "0.13.0"
  880. rdf_json_ld
  881. rdf_lwt
  882. rdf_mysql
  883. rdf_postgresql
  884. rdf_ppx
  885. rea < "0.2.0"
  886. reactjs-jsx-ppx
  887. readline
  888. reason >= "3.9.0"
  889. reason-react
  890. reason-react-ppx
  891. reddit_api_async
  892. reddit_api_kernel
  893. redis >= "0.4"
  894. redis-lwt >= "0.4"
  895. redis-sync >= "0.4"
  896. refl >= "0.2.0"
  897. reparse >= "2.0.0"
  898. reparse-lwt
  899. reparse-lwt-unix
  900. reparse-unix
  901. repr != "0.2.0"
  902. repr-bench
  903. repr-fuzz
  904. rescript-syntax
  905. reshowcase
  906. resto >= "0.7"
  907. rfsm >= "2.0"
  908. riot
  909. river >= "0.2"
  910. rock >= "0.20.0"
  911. roman
  912. routes >= "1.0.0"
  913. rpc >= "6.1.0"
  914. rsdd
  915. rtop >= "3.9.0"
  916. rtree
  917. runtime_events_tools
  918. SourceCode_ASCII
  919. safemoney
  920. sail >= "0.15"
  921. sail_c_backend
  922. sail_coq_backend
  923. sail_doc_backend
  924. sail_latex_backend
  925. sail_lem_backend
  926. sail_manifest
  927. sail_ocaml_backend
  928. sail_output
  929. sail_smt_backend
  930. sail_sv_backend
  931. samplerate >= "0.1.6"
  932. sanddb >= "0.2"
  933. sarek >= "20210823"
  934. sarif
  935. saturn >= "0.4.1"
  936. saturn_lockfree >= "0.4.1"
  937. scad_ml
  938. scfg
  939. sd_logic
  940. sdl-liquidsoap >= "3"
  941. secp256k1 >= "0.4.1"
  942. sedlex >= "2.4"
  943. sel
  944. semver >= "0.2.1"
  945. semver2
  946. seqes
  947. sequence >= "1.1"
  948. serde
  949. serde_debug
  950. serde_derive
  951. serde_json
  952. serde_sexpr
  953. serde_xml
  954. sexp_decode
  955. sha >= "1.15.1"
  956. shades
  957. sherlodoc
  958. shine >= "0.2.2"
  959. shuttle
  960. shuttle_http
  961. shuttle_ssl
  962. shuttle_websocket
  963. sifun
  964. sihl >= "0.1.5"
  965. sihl-cache
  966. sihl-contract
  967. sihl-core
  968. sihl-email
  969. sihl-facade
  970. sihl-persistence
  971. sihl-queue
  972. sihl-session
  973. sihl-storage
  974. sihl-token
  975. sihl-type
  976. sihl-user
  977. sihl-web
  978. simlog
  979. smart-print >= "0.3.0"
  980. smol
  981. smol-helpers
  982. smtlib-utils
  983. snappy >= "0.1.2"
  984. snoke
  985. sodium-fmt
  986. solid
  987. solid_server
  988. solid_tools
  989. solidity-alcotest
  990. solidity-common
  991. solidity-parser
  992. solidity-test
  993. solidity-typechecker
  994. spatial-shell
  995. spawn >= "v0.15.0"
  996. spdx_licenses < "1.2.0"
  997. spectrum
  998. speex >= "0.4.1"
  999. spelll >= "0.3"
  1000. spices
  1001. spin
  1002. spoc >= "20210823"
  1003. spoc_ppx
  1004. sqids
  1005. sqlgg >= "20200521"
  1006. sqlite3 >= "5.0.3"
  1007. sqlite3_utils
  1008. srt >= "0.2.1"
  1009. ssl >= "0.7.0"
  1010. sslconf
  1011. starpath
  1012. stdint = "0.7.0" | >= "0.7.2"
  1013. stdint-literals
  1014. stdlib-random
  1015. stdune
  1016. stk
  1017. stk_iconv
  1018. stog >= "0.20.0"
  1019. stog_all
  1020. stog_asy
  1021. stog_dot
  1022. stog_extern
  1023. stog_markdown
  1024. stog_multi_doc
  1025. stog_nocaml
  1026. stog_noexec
  1027. stog_plugins
  1028. stog_rdf
  1029. stog_rel_href
  1030. stog_server
  1031. stog_server_multi
  1032. stog_sitemap
  1033. stog_writing
  1034. stramon-lib
  1035. stringCodepointSplitter
  1036. sun
  1037. swhid
  1038. swhid_compute
  1039. swhid_core
  1040. swhid_types
  1041. swipl
  1042. syguslib-utils
  1043. taglib >= "0.3.7"
  1044. talaria-bibtex
  1045. tar >= "2.0.0"
  1046. tar-eio
  1047. tar-mirage >= "2.0.0"
  1048. tar-unix >= "2.0.0"
  1049. teash
  1050. telemetry
  1051. terminal
  1052. terminus
  1053. terminus-cohttp
  1054. terminus-hlc
  1055. testu01
  1056. textmate-language
  1057. textrazor
  1058. tezos-bls12-381-polynomial >= "0.1.3"
  1059. tezos-plompiler >= "0.1.3"
  1060. tezos-plonk >= "0.1.3"
  1061. tezt-bam
  1062. thread-table
  1063. tidy_email
  1064. tidy_email_mailgun
  1065. tidy_email_sendgrid
  1066. tidy_email_smtp
  1067. timed >= "1.1"
  1068. timedesc >= "0.8.0"
  1069. timedesc-json
  1070. timedesc-sexp
  1071. timedesc-tzdb
  1072. timedesc-tzlocal
  1073. timedesc-tzlocal-js
  1074. timere >= "0.8.0"
  1075. timmy
  1076. timmy-jsoo
  1077. timmy-unix
  1078. tiny_httpd
  1079. tiny_httpd_camlzip
  1080. tip-parser >= "0.4"
  1081. tls-liquidsoap
  1082. toc
  1083. togglelog
  1084. toml >= "5.0.0"
  1085. toml_cconv >= "7.0.0"
  1086. topojson
  1087. topojsone
  1088. touist >= "3.5.0"
  1089. trace
  1090. trace-fuchsia
  1091. trace-tef
  1092. tracy-client
  1093. traits
  1094. trampoline
  1095. transept
  1096. traverse >= "0.3.0"
  1097. travesty >= "0.7.2"
  1098. trexio
  1099. tsdl-image >= "0.3.0"
  1100. tsdl-mixer >= "0.3.0"
  1101. tsdl-ttf >= "0.3"
  1102. tty
  1103. tyabt
  1104. type_eq
  1105. type_id
  1106. tyre >= "0.5"
  1107. tyxml >= "4.6.0"
  1108. tyxml-jsx >= "4.6.0"
  1109. tyxml-lwd >= "0.2"
  1110. tyxml-ppx >= "4.6.0"
  1111. tyxml-syntax >= "4.6.0"
  1112. ubase >= "0.20"
  1113. um-abt
  1114. unisim_archisec
  1115. uring
  1116. uritemplate >= "0.1.0"
  1117. urn
  1118. validate
  1119. validator
  1120. varray
  1121. vdom
  1122. vec >= "0.2.0"
  1123. vendredi
  1124. voqc >= "0.2.0"
  1125. vue-jsoo >= "0.3"
  1126. vue-ppx
  1127. wayland
  1128. waylaunch < "0.3.0"
  1129. websocket >= "2.15"
  1130. websocket-async >= "2.15"
  1131. websocket-lwt-unix >= "2.15"
  1132. win-eventlog >= "0.4"
  1133. winsvc >= "1.0.1"
  1134. wtr
  1135. wtr-ppx
  1136. wu-manber-fuzzy-search
  1137. xapi-stdext-date
  1138. xapi-stdext-encodings
  1139. xapi-stdext-pervasives >= "4.19.0"
  1140. xapi-stdext-std >= "4.19.0"
  1141. xapi-stdext-threads >= "4.19.0"
  1142. xapi-stdext-unix >= "4.19.0"
  1143. xapi-stdext-zerocheck
  1144. xcursor
  1145. xdg
  1146. xmelly
  1147. xmldiff >= "0.7.0"
  1148. xmldiff_js
  1149. xoshiro
  1150. xtmpl >= "0.19.0"
  1151. xtmpl_js
  1152. xtmpl_ppx
  1153. yocaml
  1154. yocaml_cmark
  1155. yocaml_git
  1156. yocaml_jingoo
  1157. yocaml_markdown
  1158. yocaml_mustache
  1159. yocaml_syndication
  1160. yocaml_unix
  1161. yocaml_yaml
  1162. yojson >= "2.0.0"
  1163. yuujinchou >= "0.10.0"
  1164. zanuda
  1165. zar
  1166. zed >= "3.2.0"
  1167. zlib >= "0.6"
  1168. zlist >= "0.4.0"
  1169. zmq >= "5.2.1"
  1170. zmq-async >= "5.2.1"
  1171. zmq-lwt >= "5.2.1"

Conflicts

None