package ounit

  1. Overview
  2. Docs
This is a transition package, ounit-lwt is now ounit2-lwt

Install

Dune Dependency

Authors

Maintainers

Sources

ounit-2.2.7.tbz
sha256=90f6e63bd1240a51d8b9b2f722059bd79ce00b5276bdd6238b8f5c613c0e7388
sha512=53463e5b1b5a40f424e19f5f6a86338a544079600d1fd121ffc1a6fcaa239630194018faf91ccf360ba40b1b2a8b01cf491935e014c68d2947f6e027a2f0a0f9

Description

More details for the transition: https://github.com/gildor478/ounit#transition-to-ounit2

Published: 24 Mar 2023

Dependencies (2)

  1. ounit2 = version
  2. ocamlfind build

Dev Dependencies

None

  1. 0install < "2.17"
  2. 0install-gtk < "2.17"
  3. alcotest < "0.4.0"
  4. amf
  5. arakoon < "1.8.6" | >= "1.9.17"
  6. asn1-combinators >= "0.1.3" & < "0.2.2"
  7. aws-s3 < "4.0.0"
  8. baardskeerder >= "0.5.2"
  9. bap-stub-resolver
  10. bap-veri
  11. beluga < "0.8"
  12. bencode >= "2.0"
  13. bimap
  14. binbin
  15. biocaml = "0.4.0"
  16. bisect_ppx >= "1.0.0" & < "2.0.0"
  17. bitcoinml
  18. bitstring >= "3.0.0" & < "4.0.0"
  19. bson2
  20. bulletml
  21. caldav
  22. camelsnakekebab
  23. camlp5 >= "8.00"
  24. camltc
  25. capnp >= "3.0.0" & < "3.6.0"
  26. caradoc
  27. cconv-ppx
  28. cfstream = "1.2.3" | >= "1.3.1"
  29. channel
  30. charrua-client = "0.9"
  31. charrua-client-lwt < "0.10"
  32. charrua-client-mirage < "0.10"
  33. choice >= "0.4"
  34. cohttp < "1.0.0"
  35. cohttp-async
  36. cohttp-curl-async
  37. cohttp-curl-lwt
  38. cohttp-lwt-unix
  39. cohttp-lwt-unix-nossl
  40. cohttp-lwt-unix-ssl
  41. containers >= "2.0" & < "3.8"
  42. containers-data < "3.9"
  43. containers-thread < "3.9"
  44. core < "109.19.00"
  45. cow < "2.0.0"
  46. crc
  47. crdt-ml
  48. cryptohash
  49. cstruct >= "1.1.0" & < "3.0.1" | >= "3.1.0" & < "3.3.0"
  50. ctypes < "0.2.3" | >= "0.7.0" & < "0.21.1"
  51. debian-formats < "0.1.2"
  52. decoders-bencode < "1.0.0"
  53. decoders-cbor < "1.0.0"
  54. decoders-ezjsonm < "1.0.0"
  55. decoders-jsonm < "1.0.0"
  56. decoders-msgpck < "1.0.0"
  57. decoders-sexplib < "1.0.0"
  58. decoders-yojson < "1.0.0"
  59. devkit < "1.20210120"
  60. diet != "0.2"
  61. dispatch < "0.4.1"
  62. distributed < "0.5.0"
  63. dlm
  64. dns >= "0.13.0" & < "1.0.0" | = "1.1.3"
  65. dose3 >= "6.1"
  66. dose3-extra
  67. dtoa < "0.3.3"
  68. easy_xlsx
  69. edn >= "0.1.2-1-g09b142a" & < "0.2.0"
  70. email_message >= "113.24.00" & < "v0.10.0"
  71. enumerators
  72. expect
  73. extprot >= "1.2.0"
  74. extunix < "0.3.1"
  75. fat-filesystem >= "0.10.1" & < "0.12.0"
  76. fileutils < "0.6.4"
  77. flock
  78. fluent-logger >= "1.1.0"
  79. freetds >= "0.5.2"
  80. frenetic < "5.0.0"
  81. functoria < "2.2.0"
  82. gapi-ocaml >= "0.3.4" & < "0.4.3"
  83. gettext < "0.4.1"
  84. gettext-camomile
  85. gettext-stub
  86. git = "1.4.10"
  87. gobject-introspection
  88. google-drive-ocamlfuse < "0.7.29"
  89. hamt < "1.0.0"
  90. http_router
  91. humane-re < "0.1.0"
  92. ISO8601 >= "0.2.6"
  93. inotify >= "2.1" & < "2.3"
  94. io-page < "2.0.0" | >= "2.4.0"
  95. io-page-unix >= "2.0.0"
  96. iocaml-kernel
  97. ipaddr >= "2.6.0" & < "5.3.1"
  98. ipaddr-sexp < "5.3.1"
  99. irc-client
  100. irc-client-lwt < "0.6.2"
  101. irc-client-tls < "0.6.2"
  102. irc-client-unix < "0.6.2"
  103. iso-filesystem
  104. jhupllib
  105. jingoo
  106. junit_ounit
  107. key-parsers >= "0.3.0" & != "0.9.2"
  108. kicadsch
  109. lambda
  110. lambdasoup >= "0.6.2" & < "0.7.2"
  111. lens >= "1.1.0"
  112. letsencrypt
  113. leveldb < "1.3.0"
  114. libevent >= "0.8.1"
  115. libres3
  116. lilac
  117. llvm >= "3.6" & < "15.0.7+nnp-2"
  118. loga < "0.0.5"
  119. lz4 >= "1.1.0" & < "1.2.0"
  120. m17n
  121. macaddr < "5.3.1"
  122. macaddr-sexp < "5.3.1"
  123. markup < "1.0.0"
  124. mbr-format < "1.0.0"
  125. mel
  126. melange
  127. memcad
  128. memcpy
  129. message-switch < "1.4.0"
  130. mirage-block < "1.0.0"
  131. mirage-block-ccm < "1.1.0"
  132. mirage-block-unix < "2.11.1" | >= "2.12.0" & < "2.13.0"
  133. mirage-bootvar-xen = "0.3.2"
  134. mirage-crypto < "0.10.6"
  135. mirage-crypto-pk < "0.10.6"
  136. mirage-crypto-rng < "0.10.6"
  137. mirage-flow < "1.2.0"
  138. mirage-fs-unix >= "1.2.0" & < "1.3.0"
  139. mirage-net-unix < "2.3.0"
  140. mirage-tc
  141. missinglib
  142. mkaudio
  143. ml2mxml
  144. mock-ounit < "1.0.0"
  145. modular-arithmetic
  146. mqtt < "0.2.2"
  147. msgpack >= "1.3.0"
  148. mssql < "2.0.3"
  149. mustache < "1.0.0" | >= "2.0.0" & < "3.0.0" | = "3.1.0"
  150. mvar
  151. nbd >= "2.0.1" & < "4.0.3"
  152. nebula
  153. nmea
  154. nocrypto >= "0.5.0"
  155. noise
  156. nunchaku >= "0.5.1"
  157. oasis < "0.3.0"
  158. oasis2debian >= "0.1.4"
  159. oasis2opam >= "0.6.0"
  160. obeam < "0.1.1"
  161. obigstore
  162. ocaml-markdown < "transition"
  163. ocaml-xdg-basedir < "transition"
  164. ocaml-zmq
  165. ocamlapi
  166. ocamllint
  167. ocamlmod >= "0.0.7"
  168. ocolor = "1.3.0"
  169. odash
  170. ofx
  171. opam-query >= "1.3"
  172. open_packaging
  173. openflow >= "0.8.0"
  174. opium >= "0.12.0" & < "0.15.0"
  175. opti
  176. oraft
  177. orm >= "0.7.1"
  178. orsetto < "1.0.3"
  179. osc
  180. osc-lwt
  181. osc-unix
  182. pa_ounit >= "109.10.00"
  183. pa_ppx >= "0.07"
  184. pa_ppx_ag
  185. pa_ppx_hashcons
  186. pa_ppx_migrate
  187. pa_ppx_parsetree
  188. pa_ppx_q_ast
  189. pa_ppx_quotation2extension
  190. pa_ppx_regexp
  191. pa_ppx_static
  192. pa_ppx_string
  193. pa_ppx_unique
  194. packet >= "0.4.0"
  195. parse-argv
  196. pb
  197. pb-plugin
  198. pcap-format >= "0.5.0"
  199. pci < "1.0.1"
  200. pci-db
  201. pds-reachability
  202. pgocaml >= "2.3" & < "4.0"
  203. pgsolver
  204. pgx < "1.0"
  205. pgx_async < "1.0"
  206. pgx_unix < "1.0"
  207. phonetic
  208. pkcs11 >= "0.7.0"
  209. pkcs11-driver
  210. posix-getopt < "2.0.0"
  211. ppx_bitstring >= "1.2.0" & < "2.0.0" | >= "4.0.0"
  212. ppx_const < "2.0"
  213. ppx_cstruct >= "3.1.0"
  214. ppx_deriving >= "1.0" & < "5.2"
  215. ppx_deriving_argparse
  216. ppx_deriving_hardcaml < "v0.12.0"
  217. ppx_deriving_morphism
  218. ppx_deriving_protobuf < "3.0.0"
  219. ppx_deriving_yojson < "3.7.0"
  220. ppx_enum
  221. ppx_factory
  222. ppx_getenv < "2.0"
  223. ppx_hardcaml
  224. ppx_import
  225. ppx_monoid >= "0.3.2"
  226. ppx_protocol_conv >= "2.0.0" & < "5.0.0"
  227. ppx_protocol_conv_json >= "3.1.0" & < "5.0.0"
  228. ppx_protocol_conv_jsonm < "5.0.0"
  229. ppx_protocol_conv_msgpack >= "3.1.0" & < "5.0.0"
  230. ppx_protocol_conv_xml_light >= "3.1.0" & < "5.0.0"
  231. ppx_protocol_conv_yaml >= "3.1.0" & < "5.0.0"
  232. ppx_sqlexpr
  233. ppx_yojson < "1.1.0"
  234. qbf
  235. qcheck >= "0.5" & < "0.9"
  236. qcheck-ounit < "0.14"
  237. qcow != "0.10.0"
  238. qcow-format
  239. qcow-tool
  240. qiskit >= "0.44.0"
  241. qtest < "2.11.1"
  242. range >= "0.8.3"
  243. rdbg >= "1.65"
  244. re >= "1.7.2"
  245. records
  246. redis-lwt = "0.4"
  247. redis-sync = "0.4"
  248. rfc6287
  249. rfc7748
  250. riak
  251. rlp
  252. rubytt
  253. secp256k1 >= "0.2.5" & < "0.4.1"
  254. semver2
  255. session >= "0.2.0"
  256. sha >= "1.12" & < "1.15.1"
  257. shared-block-ring < "3.0.0"
  258. shared-memory-ring
  259. shared-memory-ring-lwt
  260. shared-secret
  261. sid
  262. slacko >= "0.13.0"
  263. socialpeek
  264. sodium >= "0.6.0"
  265. spotify-web-api
  266. spreadsheetml
  267. sqlexpr >= "0.7.1" & < "0.9.0"
  268. sqlgg >= "0.2.5"
  269. sslconf
  270. stitch
  271. stringext >= "1.2.0"
  272. subtype-refinement
  273. swdogen
  274. tar-format >= "0.2.0"
  275. tar-mirage < "2.0.0"
  276. tcpip >= "3.0.0" & < "3.3.0"
  277. tdk >= "0.2.0"
  278. tls >= "0.6.0" & < "0.13.0"
  279. toml >= "5.0.0" & < "7.0.0"
  280. topology >= "0.4.0"
  281. touist >= "3.4.0" & < "3.5.0"
  282. traildb
  283. tuntap = "1.0.0" | >= "1.4.1"
  284. ucorelib
  285. unix-type-representations
  286. uri < "1.3.0" | >= "1.8.0" & < "4.4.0"
  287. uri-re < "4.4.0"
  288. uri-sexp < "4.4.0"
  289. uritemplate
  290. uwt < "0.3.3"
  291. vchan >= "2.0.0"
  292. vchan-unix
  293. vchan-xen
  294. vhd-format < "0.9.1"
  295. vhd-format-lwt < "0.12.3"
  296. vhd-tool < "0.12.0"
  297. vlq < "0.2.1"
  298. webmachine
  299. wikitext
  300. x509 >= "0.4.0" & < "0.7.0"
  301. xapi-idl
  302. xapi-rrd < "1.8.2"
  303. xapi-rrdd
  304. xen-api-client
  305. xen-evtchn < "2.0.0"
  306. xen-evtchn-unix
  307. xen-gnt < "2.2.0" | = "2.2.3"
  308. xenstore != "1.2.5" & < "2.2.0"
  309. xenstore_transport >= "1.3.0"
  310. zeit
  311. zmq < "4.0-7"
  312. zxcvbn

Conflicts

None