tls

Transport Layer Security (TLS) in OCaml
Description

A clean-slate TLS implementation, with support for protocol versions 1.0-1.2. Includes the core library, as well as Lwt and MirageOS frontends.

Install
Published
05 Dec 2015
Authors
Maintainers
Sources
0.7.0.tar.gz
md5=b040eef1a998ecc18965dc14f7d628e1
Dependencies
ounit with-test
x509 >= "0.5.0" & < "0.6.0"
nocrypto >= "0.5.0" & < "0.5.3"
sexplib < "113.01.00"
cstruct >= "1.6.0" & < "2.0.0"
ocaml >= "4.01.0" & < "4.12.0"
Reverse Dependencies
aws-s3-lwt < "3.0.0"
azure-cosmos-db >= "0.1.5" & < "0.2.0"
calculon < "0.5"
colombe < "0.2.0"
comby < "1.7.0"
datakit-ci < "0.12.1"
dns-resolver >= "6.0.0"
doi2bib < "0.2.1"
dropbox >= "0.2"
git >= "2.0.0" & < "3.0.0"
git-mirage >= "2.0.0" & < "3.0.0" | >= "3.6.0"
git-unix = "2.0.0" | >= "2.1.1" & < "3.0.0"
github >= "2.0.0" & < "3.0.0"
github-unix < "3.1.0"
imaplet-lwt >= "0.1.8" & < "0.1.10" | >= "0.1.14"
links >= "0.9.6"
opam-publish >= "0.3.5" & < "2.1.0"
paf-cohttp = "0.0.5"
sendmail >= "0.2.0" & < "0.4.1"
sendmail-lwt < "0.4.1"
slacko >= "0.13.0"
syndic >= "1.5" & < "1.6.0"
tezos-node < "9.0"
tlstunnel >= "0.1.1" & < "0.2.0"
wcs-api = "2017-05-26.02"
Conflicts
lwt >= "4.0.0"
lwt < "2.4.8"