package odoc

  1. Overview
  2. Docs

Description

odoc is an OCaml API documentation tool

Tags

doc html ocaml org:ocaml-doc

Published: 24 Nov 2017

README

odoc — An OCaml API documentation tool

v1.2.0

odoc is an OCaml API documentation tool

Installation

Odoc can be installed with opam:

opam install odoc

If you don't use opam consult the opam file for build instructions.

Dependencies (12)

  1. cmdliner
  2. xmlm
  3. result
  4. fpath
  5. bos
  6. tyxml >= "4.0.0"
  7. doc-ock-xml >= "1.2.0"
  8. doc-ock-html >= "1.2.0"
  9. doc-ock >= "1.2.0"
  10. jbuilder >= "1.0+beta10"
  11. ocamlfind build
  12. ocaml >= "4.03.0" & < "5.0"

Dev Dependencies

None

  1. absolute >= "0.2"
  2. acgtk >= "2.0.0"
  3. adobe_font_metrics
  4. agrid
  5. aifad >= "2.3.0"
  6. alba >= "0.4.1"
  7. alcotest = "1.1.0" | = "1.2.3" | >= "1.5.0"
  8. alcotest-async >= "1.5.0"
  9. alcotest-js
  10. alcotest-lwt >= "1.5.0"
  11. alcotest-mirage >= "1.5.0"
  12. algaeff
  13. alt-ergo >= "2.4.1"
  14. alt-ergo-lib >= "2.4.1"
  15. alt-ergo-parsers >= "2.4.1"
  16. alt-ergo-plugin-ab-why3
  17. altgr-ergo >= "2.4.1"
  18. ambient-context
  19. ambient-context-eio
  20. ambient-context-lwt
  21. anders < "0.7.1"
  22. ansi >= "0.6.0"
  23. antic
  24. ao >= "0.2.4"
  25. arb
  26. archetype >= "1.2.3"
  27. arg-complete
  28. argon2 >= "1.0.0"
  29. argsh
  30. arrakis
  31. asai
  32. asak
  33. ask
  34. ask-integrator
  35. async-uri >= "0.4.0"
  36. atable
  37. atacama < "0.0.4"
  38. atd >= "2.3.3"
  39. atdd
  40. atdgen >= "2.3.3"
  41. atdgen-codec-runtime >= "2.3.3"
  42. atdgen-runtime >= "2.3.3"
  43. atdj >= "2.3.3" & < "20151001.01"
  44. atdpy
  45. atds >= "2.3.3"
  46. atdts
  47. autofonce
  48. autofonce_config
  49. autofonce_core
  50. autofonce_lib
  51. autofonce_m4
  52. autofonce_misc
  53. autofonce_patch
  54. autofonce_share
  55. avro
  56. avro-compiler
  57. awsm
  58. awsm-async
  59. awsm-codegen
  60. awsm-lwt
  61. backoff
  62. baguette_sharp
  63. bam
  64. bare_encoding
  65. base32
  66. batsat
  67. batteries >= "3.7.1"
  68. bencode >= "2.0"
  69. bestline
  70. bin_tree
  71. bindlib >= "6.0.0"
  72. binsec >= "0.4.0"
  73. bio_io
  74. biotk
  75. bitcoin >= "3.0"
  76. bitcoin-cohttp-async
  77. bitcoin-cohttp-lwt
  78. bitcoin-ocurl
  79. bitcoinml < "0.4.1"
  80. bitmasks >= "1.1.0"
  81. bitpack_serializer
  82. bitwuzla
  83. bitwuzla-c
  84. bitwuzla-cxx
  85. bls12-381 >= "6.0.1" & < "18.0"
  86. blurhash
  87. bogue >= "20210917"
  88. bogue-tutorials
  89. boltzgen >= "0.9.2"
  90. boulangerie
  91. box
  92. brotli >= "2.0.3"
  93. brr-lwd
  94. bwd < "2.0.0"
  95. bytebuffer
  96. ca-certs-nss >= "3.64.0.1"
  97. cairn
  98. caisar
  99. caisar-ir
  100. caisar-nnet
  101. caisar-onnx
  102. caisar-ovo
  103. caisar-xgboost
  104. calcium
  105. calculon >= "0.3"
  106. calculon-web >= "0.3"
  107. calendar >= "3.0.0"
  108. calipso
  109. camlimages >= "5.0.5"
  110. camlp-streams >= "5.0.1"
  111. camlrack
  112. camomile >= "2.0.0"
  113. camyll
  114. canary
  115. caqti >= "1.7.0"
  116. caqti-async >= "1.7.0"
  117. caqti-driver-mariadb >= "1.7.0"
  118. caqti-driver-postgresql >= "1.7.0"
  119. caqti-driver-sqlite3 >= "1.7.0"
  120. caqti-eio
  121. caqti-lwt >= "1.7.0"
  122. caqti-mirage
  123. caqti-tls
  124. caqti-type-calendar >= "1.9.0"
  125. carbon
  126. castore
  127. catala >= "0.5.0"
  128. catapult
  129. catapult-client
  130. catapult-daemon
  131. catapult-file
  132. catapult-sqlite
  133. cborl
  134. ccbg
  135. cf
  136. cf-lwt
  137. cfg >= "2.3.0"
  138. chamo >= "4.0"
  139. choice >= "0.4"
  140. chrome-trace
  141. cid
  142. clap >= "0.2.0"
  143. clarity-lang
  144. clim
  145. clim-ppx
  146. cll
  147. clp_operations
  148. cmon
  149. cohttp >= "6.0.0~alpha0"
  150. cohttp-async >= "6.0.0~alpha0"
  151. cohttp-curl
  152. cohttp-curl-async
  153. cohttp-curl-lwt
  154. cohttp-eio
  155. cohttp-lwt >= "6.0.0~alpha0"
  156. cohttp-lwt-jsoo >= "6.0.0~alpha0"
  157. cohttp-lwt-unix >= "6.0.0~alpha0"
  158. cohttp-mirage >= "6.0.0~alpha0"
  159. cohttp-server-lwt-unix
  160. cohttp-top >= "6.0.0~alpha0"
  161. colibri2
  162. colibrics
  163. colibrilib
  164. colors
  165. combinaml
  166. combinat >= "3.0"
  167. config
  168. config-file >= "1.2.1"
  169. conformist >= "0.8.1"
  170. containers >= "2.0"
  171. containers-data
  172. containers-thread
  173. coq >= "8.19.0"
  174. coq-core >= "8.19.0"
  175. coq-stdlib >= "8.19.0"
  176. coqide >= "8.19.0"
  177. coqide-server >= "8.19.0"
  178. crc >= "2.0.0"
  179. crontab
  180. crowbar >= "0.2.1"
  181. cry >= "0.6.6"
  182. csexp >= "1.5.1"
  183. css
  184. ctoxml
  185. ctypes >= "0.21.1"
  186. ctypes-foreign >= "0.21.1"
  187. cucumber
  188. cudf >= "0.10"
  189. cue_sheet_maker
  190. curly >= "0.2.0"
  191. current >= "0.6.4"
  192. current-albatross-deployer
  193. current-web-pipelines
  194. current_docker >= "0.6.4"
  195. current_examples >= "0.6.4"
  196. current_git >= "0.6.4"
  197. current_github >= "0.6.4"
  198. current_gitlab >= "0.6.4"
  199. current_ocluster >= "0.2"
  200. current_rpc >= "0.6.4"
  201. current_slack >= "0.6.4"
  202. current_ssh
  203. current_web >= "0.6.4"
  204. curses >= "1.0.10"
  205. DkSDKFFIOCaml_Std
  206. data-encoding >= "0.5"
  207. datalog >= "0.6"
  208. dates_calc
  209. dbf >= "0.2.0"
  210. decimal
  211. decoders >= "0.5.0"
  212. decoders-bencode
  213. decoders-cbor
  214. decoders-ezjsonm >= "0.3.0"
  215. decoders-ezxmlm
  216. decoders-jsonaf
  217. decoders-jsonm
  218. decoders-msgpck
  219. decoders-sexplib
  220. decoders-yojson >= "0.3.0"
  221. delimcc_of_fxhandler
  222. devkit >= "1.20210120"
  223. diff
  224. dkml-c-probe
  225. dkml-component-offline-ocamlrun
  226. dkml-component-offline-opam
  227. dkml-component-staging-ocamlrun >= "4.12.1~v1.0.2"
  228. dkml-component-staging-opam32 < "2.2.0~dkml20220801"
  229. dkml-component-staging-opam64 < "2.2.0~dkml20220801"
  230. dkml-dune-dsl
  231. dkml-dune-dsl-show
  232. dkml-install >= "0.5.1"
  233. dkml-install-installer >= "0.5.1"
  234. dkml-install-runner >= "0.5.1"
  235. dkml-option-vcpkg
  236. dkml-package-console >= "0.5.1"
  237. dkml-runtime-distribution
  238. dkml-workflows
  239. dlm >= "0.3.3"
  240. dmap
  241. docfd
  242. docker-api >= "0.2.2"
  243. dockerfile >= "8.1.0"
  244. dockerfile-cmd >= "8.1.0"
  245. dockerfile-opam >= "8.1.0"
  246. doculib
  247. doi2bib >= "0.3.0"
  248. dolmen >= "0.5"
  249. dolmen_bin
  250. dolmen_loop
  251. dolmen_lsp
  252. dolmen_model
  253. dolmen_type
  254. domain-local-await
  255. domain-local-timeout
  256. domainslib >= "0.5.1"
  257. dose3 >= "6.1"
  258. dose3-extra
  259. dream-accept
  260. dream-cli
  261. dream-encoding
  262. dream-html
  263. dream-htmx
  264. dream-livereload
  265. drom
  266. drom_lib
  267. drom_toml
  268. dscheck
  269. dssi >= "0.1.4"
  270. dtools >= "0.4.3"
  271. dual
  272. dune-action-plugin >= "2.7.0"
  273. dune-build-info >= "2.7.0"
  274. dune-compiledb
  275. dune-configurator >= "2.7.0"
  276. dune-expand
  277. dune-glob >= "2.7.0"
  278. dune-private-libs >= "2.7.0"
  279. dune-release
  280. dune-rpc
  281. dune-rpc-lwt
  282. dune-site
  283. duppy >= "0.9.1"
  284. dyn
  285. earley >= "3.0.0"
  286. earlybird >= "1.0.0"
  287. easy-format >= "1.3.3"
  288. ego
  289. eio
  290. eio-ssl >= "0.1.1"
  291. eio-trace
  292. eio_linux
  293. eio_luv
  294. eio_main
  295. eio_posix
  296. eio_windows
  297. electrod >= "1.0.0"
  298. eliom >= "10.1.2"
  299. elpi >= "1.16.7"
  300. embedded_ocaml_templates >= "0.8"
  301. encoding
  302. equinoxe
  303. equinoxe-cohttp
  304. equinoxe-hlc
  305. eris
  306. eris-lwt
  307. erlang
  308. errpy
  309. extism
  310. extism-manifest
  311. extunix >= "0.4.0"
  312. ez_cmdliner >= "0.2.0"
  313. ez_config >= "0.2.0"
  314. ez_file >= "0.2.0"
  315. ez_hash
  316. ez_opam_file
  317. ez_search
  318. ez_subst
  319. ezcurl
  320. ezcurl-lwt
  321. ezgzip
  322. ezjs_fetch >= "0.3"
  323. ezjs_idb >= "0.1.1"
  324. ezjs_min >= "0.2.2"
  325. ezjsonm-encoding
  326. FPauth
  327. FPauth-core
  328. FPauth-responses
  329. FPauth-strategies
  330. FrontC >= "4.0.0"
  331. faad >= "0.5.1"
  332. fadbadml >= "0.1.2"
  333. farith
  334. fd-send-recv >= "2.0.1"
  335. fdkaac >= "0.3.3"
  336. feather >= "0.2.0"
  337. feather_async >= "0.2.0"
  338. ffmpeg >= "1.0.0~beta2"
  339. ffmpeg-av >= "1.0.0~beta2"
  340. ffmpeg-avcodec >= "1.0.0~beta2"
  341. ffmpeg-avdevice >= "1.0.0~beta2"
  342. ffmpeg-avfilter >= "1.0.0~beta2"
  343. ffmpeg-avutil >= "1.0.0~beta2"
  344. ffmpeg-swresample >= "1.0.0~beta2"
  345. ffmpeg-swscale >= "1.0.0~beta2"
  346. fiat-p256 = "0.2.2"
  347. fiber
  348. fiber-lwt
  349. flac >= "0.3.1"
  350. flint
  351. fmlib
  352. fmlib_browser
  353. fmlib_js
  354. fmlib_parse
  355. fmlib_pretty
  356. fmlib_std
  357. fontforge-of-ocaml
  358. forester
  359. frama-c >= "27.0"
  360. frama-c-metacsl >= "0.4"
  361. frama-clang
  362. frenetic >= "5.0.0"
  363. fsevents
  364. fsevents-lwt
  365. fuseau
  366. fuseau-lwt
  367. GT >= "0.5.0"
  368. gccjit
  369. gd >= "1.1"
  370. gen >= "0.5.1"
  371. gen_js_api >= "1.0.8"
  372. geojson
  373. geojsone
  374. geoml
  375. getopt >= "20230213"
  376. github >= "4.4.0"
  377. github-data
  378. github-jsoo >= "4.4.0"
  379. github-unix >= "4.4.0"
  380. gitlab
  381. gitlab-jsoo
  382. gitlab-unix
  383. gitlab_pipeline_notifier
  384. globlon
  385. gluten >= "0.5.0"
  386. gluten-async >= "0.5.0"
  387. gluten-eio >= "0.5.0"
  388. gluten-lwt >= "0.5.0"
  389. gluten-lwt-unix >= "0.5.0"
  390. gluten-mirage >= "0.5.0"
  391. gnuplot >= "0.6"
  392. goblint >= "1.1.1"
  393. goblint-cil >= "1.8.0"
  394. gospel >= "0.2.0"
  395. gotd
  396. gperftools >= "0.4"
  397. gpiod
  398. gpt
  399. grace
  400. gradescope_submit
  401. graphv
  402. graphv_core
  403. graphv_core_lib
  404. graphv_font
  405. graphv_font_js
  406. graphv_font_stb_truetype
  407. graphv_gles2
  408. graphv_gles2_native
  409. graphv_gles2_native_impl
  410. graphv_webgl
  411. graphv_webgl_impl
  412. grpc
  413. grpc-async
  414. grpc-bench
  415. grpc-eio
  416. grpc-examples
  417. grpc-lwt
  418. gsl >= "1.25.0"
  419. guardian
  420. guile
  421. h1_parser
  422. h2 >= "0.10.0"
  423. h2-async >= "0.10.0"
  424. h2-eio
  425. h2-lwt >= "0.10.0"
  426. h2-lwt-unix >= "0.10.0"
  427. h2-mirage >= "0.10.0"
  428. hacl-star >= "0.4.0"
  429. hacl_func
  430. hacl_x25519 = "0.2.1"
  431. hashcons >= "1.4.0"
  432. hc >= "0.2"
  433. hdr_histogram
  434. headache = "1.06"
  435. header-check
  436. highlexer
  437. higlo >= "0.8"
  438. hilite
  439. hockmd
  440. hol2dk
  441. hooke
  442. hpack >= "0.10.0"
  443. hsluv
  444. html_of_jsx
  445. htmlfromtexbooks
  446. http
  447. http-cookie
  448. http-date
  449. http-multipart-formdata
  450. http_async
  451. httpaf_caged >= "1.0.1"
  452. ISO3166
  453. ISO8601 >= "0.2.6"
  454. idds
  455. inotify >= "2.4"
  456. inquire >= "0.3.0"
  457. inquirer_oc
  458. interval-map
  459. iomux
  460. ip2location
  461. ip2locationio
  462. irc-client >= "0.6.2"
  463. irc-client-lwt >= "0.6.2"
  464. irc-client-lwt-ssl
  465. irc-client-tls >= "0.6.2"
  466. irc-client-unix >= "0.6.2"
  467. iri >= "0.6.0"
  468. irmin >= "3.0.0"
  469. irmin-watcher >= "0.5.0"
  470. iter
  471. jekyll-format >= "0.2.0"
  472. jerboa
  473. jext
  474. jose >= "0.6.0"
  475. js_of_ocaml >= "3.10.0"
  476. js_of_ocaml-compiler >= "3.10.0"
  477. js_of_ocaml-lwt >= "3.10.0"
  478. js_of_ocaml-ocamlbuild >= "3.10.0"
  479. js_of_ocaml-ppx >= "3.10.0"
  480. js_of_ocaml-ppx_deriving_json >= "3.10.0"
  481. js_of_ocaml-toplevel >= "3.10.0"
  482. js_of_ocaml-tyxml >= "3.10.0"
  483. json-data-encoding >= "0.12"
  484. jsonoo
  485. jsonrpc >= "1.4.0"
  486. jsonschema2atd
  487. jsoo-react
  488. junit >= "1.0"
  489. junit_alcotest
  490. junit_ounit
  491. jupyter-kernel >= "0.4"
  492. jwto >= "0.4.0"
  493. kcas >= "0.1.6" & < "0.6.0"
  494. kcas_data < "0.6.0"
  495. kdl
  496. kind2
  497. kittyimg
  498. kkmarkdown
  499. knights_tour
  500. kqueue >= "0.2.0"
  501. lab
  502. lablgtk3-extras >= "3.0.1"
  503. lacaml >= "11.0.10"
  504. ladspa >= "0.2.1"
  505. lambda-term >= "3.3.0"
  506. lambdapi >= "2.0.0"
  507. lame >= "0.3.6"
  508. landmarks >= "1.4"
  509. landmarks-ppx
  510. ldap >= "2.4.2"
  511. ldp
  512. ldp_curl
  513. ldp_js
  514. ldp_tls
  515. leaflet
  516. learn-ocaml >= "0.13.0"
  517. leaves
  518. letters != "0.1.1"
  519. leveldb >= "1.3.0"
  520. libc
  521. libsail
  522. lilv
  523. linenoise >= "1.3.1"
  524. linol
  525. linol-lwt
  526. lintcstubs
  527. lintcstubs-arity
  528. lintcstubs-gen
  529. liquidsoap >= "2.2.0"
  530. liquidsoap-core
  531. liquidsoap-js
  532. liquidsoap-lang
  533. liquidsoap-libs
  534. liquidsoap-libs-extra
  535. liquidsoap-mode
  536. little_logger
  537. llama
  538. llama-cpp-ocaml
  539. llama_core
  540. llama_interactive
  541. llama_midi
  542. lmdb >= "1.0"
  543. logical
  544. logs-async >= "1.3"
  545. logs-async-reporter >= "1.3"
  546. loop
  547. lreplay
  548. lru_cache < "v0.16.0"
  549. lsp >= "1.4.0"
  550. lua-ml >= "0.9.3"
  551. lua_parser >= "1.0.2"
  552. lwd >= "0.2"
  553. lwt-parallel >= "1.0.0"
  554. lwt-pipe
  555. lwt_eio
  556. lz4 >= "1.2.0"
  557. m_tree
  558. mad >= "0.5.1"
  559. make-random
  560. matita
  561. mc2
  562. md2mld >= "0.7.0"
  563. mdx = "1.7.0" | >= "1.11.0"
  564. mec
  565. mehari
  566. mehari-eio
  567. mehari-eio-unix
  568. mehari-lwt-unix
  569. mehari-mirage
  570. mel
  571. melange
  572. melange-atdgen-codec-runtime
  573. melange-compiler-libs
  574. melange-fetch
  575. melange-jest
  576. melange-json
  577. melange-moment
  578. melange-numeral
  579. melange-radix-icons
  580. melange-react-dates
  581. melange-react-query
  582. melange-recharts
  583. melange-testing-library
  584. melange-webapi
  585. meldep
  586. mem_usage
  587. memgraph
  588. memgraph_kitty
  589. metadata
  590. metadb
  591. middleware
  592. minisat >= "0.2"
  593. minttea
  594. mjson
  595. mlbdd >= "0.7.2"
  596. mlmpfr >= "4.2.0"
  597. mm >= "0.7.2"
  598. mnd
  599. module-graph
  600. monocypher
  601. monomorphic >= "2.0"
  602. moonpool
  603. morbig >= "0.10.3"
  604. mpg123 >= "0.3"
  605. mpris >= "0.2.0"
  606. mpris-clients
  607. mssql >= "2.0.3"
  608. mugen
  609. mula
  610. multibase
  611. multicodec
  612. multicont >= "1.0.1"
  613. multihash
  614. multihash-digestif
  615. mustache >= "3.2.0"
  616. mustache-cli
  617. mysql_protocol >= "3.0.1"
  618. nanoid
  619. nanosvg
  620. nanosvg_text
  621. nbd >= "6.0.0"
  622. nbd-tool
  623. nbd-unix
  624. netkat
  625. nice_parser
  626. ninja_utils
  627. nloge
  628. nlopt
  629. noCanren >= "0.3.0~alpha1"
  630. node_of_ocaml
  631. nottui >= "0.2"
  632. nottui-lwt >= "0.2"
  633. nottui-pretty >= "0.2"
  634. nunchaku >= "0.5.1"
  635. nuscr >= "1.1.0"
  636. OCADml
  637. OCanren >= "0.3.0~alpha1"
  638. OCanren-ppx >= "0.3.0~alpha1"
  639. OSCADml
  640. obuilder
  641. obuilder-spec
  642. ocaml-compiler-libs = "v0.12.4"
  643. ocaml-in-python
  644. ocaml-logicalform
  645. ocaml-lsp-server >= "1.4.0"
  646. ocaml-lua >= "1.8"
  647. ocaml-protoc >= "2.1"
  648. ocaml-protoc-plugin >= "5.0.0"
  649. ocaml-version >= "3.6.0"
  650. ocamlc-loc
  651. ocamldiff >= "1.2"
  652. ocamlformat >= "0.19.0"
  653. ocamlformat-lib
  654. ocamlformat-rpc >= "0.19.0" & < "removed"
  655. ocamlformat-rpc-lib
  656. ocamlfuse >= "2.7.1-cvs8"
  657. ocamlregextkit
  658. ocb
  659. ocf >= "0.8.0"
  660. ocf_ppx
  661. ockt
  662. ocluster >= "0.2"
  663. ocluster-api >= "0.2"
  664. ocluster-worker
  665. ocp-browser >= "1.2.2"
  666. ocp-index >= "1.2.2"
  667. ocp-search
  668. ocplib_stuff >= "0.3.0"
  669. odep >= "0.2.0"
  670. oframl
  671. ogg >= "0.7.1"
  672. ojo
  673. ojs >= "1.0.8"
  674. ojs_base
  675. ojs_base_all
  676. ojs_base_ppx
  677. ojs_ed
  678. ojs_filetree
  679. ojs_list
  680. olinq >= "0.3"
  681. oma
  682. omd = "1.3.2" | >= "2.0.0~alpha3"
  683. omigrate != "0.3.0"
  684. omtl
  685. oniguruma
  686. opam-0install >= "0.4.2"
  687. opam-0install-cudf >= "0.4.2"
  688. opam-bin >= "0.9.5"
  689. opam-check-npm-deps
  690. opam-compiler >= "0.2.0"
  691. opam-dune-lint
  692. opam-monorepo >= "0.3.0"
  693. opam-spin
  694. opam_bin_lib >= "0.9.5"
  695. opasswd >= "1.3.1"
  696. openapi
  697. openapi_router
  698. openstellina
  699. opentelemetry
  700. opentelemetry-client-cohttp-lwt
  701. opentelemetry-client-ocurl
  702. opentelemetry-cohttp-lwt
  703. opentelemetry-lwt
  704. opine
  705. opium >= "0.20.0"
  706. opium-testing >= "0.20.0"
  707. oplot != "0.50"
  708. optiml-transport
  709. opus >= "0.2.1"
  710. oraft >= "0.3.0"
  711. ordering
  712. ordinal
  713. orgeat
  714. oseq
  715. osh
  716. osnap
  717. otoggl
  718. otoml >= "0.9.3"
  719. ounit2 >= "2.2.7"
  720. ounit2-lwt >= "2.2.7"
  721. override >= "0.4.0"
  722. owi
  723. p5scm
  724. packstream
  725. pancake
  726. pandoc >= "0.2.1"
  727. pandoc-abbreviations >= "0.2.1"
  728. pandoc-comment >= "0.2.1"
  729. pandoc-crossref >= "0.2.1"
  730. pandoc-include >= "0.2.1"
  731. pandoc-inspect >= "0.2.1"
  732. pandoc-pdf2png >= "0.2.1"
  733. pandoc-replace >= "0.2.1"
  734. par_incr
  735. pari
  736. pari-bindings
  737. parmap >= "1.2.3"
  738. path_glob
  739. patoline >= "0.2"
  740. pbrt
  741. pbrt_yojson
  742. pcre >= "7.5.0"
  743. pcre2
  744. petrol
  745. pgx >= "1.0"
  746. pgx_async >= "2.2"
  747. pgx_lwt >= "2.2"
  748. pgx_lwt_mirage >= "2.2"
  749. pgx_lwt_unix >= "2.2"
  750. pgx_unix >= "2.2"
  751. pgx_value_core >= "2.2"
  752. pgx_value_ptime >= "2.2"
  753. phylogenetics >= "0.2.0"
  754. piece_rope
  755. plateau
  756. plist-xml
  757. plist-xml-lwt
  758. plotly
  759. plplot >= "5.12.0"
  760. polars
  761. polars_async
  762. poll
  763. popper
  764. portaudio >= "0.2.3"
  765. portmidi
  766. posix-base >= "2.0.1"
  767. posix-bindings >= "2.0.1"
  768. posix-getopt >= "2.0.1"
  769. posix-signal >= "2.0.1"
  770. posix-socket >= "2.0.1"
  771. posix-socket-unix >= "2.0.1"
  772. posix-time2 >= "2.0.1"
  773. posix-types >= "2.0.1"
  774. posix-uname >= "2.0.1"
  775. pp >= "1.2.0"
  776. pp-binary-ints
  777. pp_loc
  778. ppx_camlrack
  779. ppx_catch
  780. ppx_const >= "2.0"
  781. ppx_decimal
  782. ppx_default
  783. ppx_deriving_cad
  784. ppx_deriving_encoding >= "0.3.0"
  785. ppx_deriving_hash
  786. ppx_deriving_madcast >= "0.2"
  787. ppx_deriving_popper
  788. ppx_deriving_qcheck >= "0.2.0"
  789. ppx_deriving_scad
  790. ppx_deriving_yaml >= "0.2.0"
  791. ppx_distr_guards >= "0.3"
  792. ppx_dream_eml
  793. ppx_getenv >= "2.0"
  794. ppx_interact
  795. ppx_make
  796. ppx_map
  797. ppx_minidebug
  798. ppx_monad
  799. ppx_monoid >= "0.3.3"
  800. ppx_open
  801. ppx_optint
  802. ppx_parser
  803. ppx_pyformat
  804. ppx_repr != "0.2.0"
  805. ppx_seq
  806. ppx_subliner
  807. ppx_system
  808. ppx_trace
  809. ppx_ts
  810. ppx_update
  811. ppx_viewpattern
  812. ppx_yojson >= "1.3.0"
  813. ppxlib >= "0.22.0"
  814. pratter
  815. prbnmcn-basic-structures
  816. prbnmcn-cgrph
  817. prbnmcn-clustering
  818. prbnmcn-dagger
  819. prbnmcn-dagger-gsl
  820. prbnmcn-dagger-stats
  821. prbnmcn-dagger-test
  822. prbnmcn-gnuplot
  823. prbnmcn-linalg
  824. prbnmcn-mcts
  825. prbnmcn-proptest
  826. prbnmcn-stats
  827. prbnmcn-ucb1 >= "0.0.2"
  828. preface
  829. pretty_expressive
  830. printbox >= "0.2"
  831. printbox-html
  832. printbox-md
  833. printbox-text
  834. processor
  835. producer
  836. progress
  837. prometheus-liquidsoap >= "2"
  838. promise_jsoo
  839. prr
  840. psmt2-frontend >= "0.3.0"
  841. pulseaudio >= "0.1.5"
  842. pvec
  843. pyml >= "20210924"
  844. pyml_bindgen
  845. pyre-ast
  846. qbf >= "0.3"
  847. qcheck >= "0.9"
  848. qcheck-alcotest
  849. qcheck-core
  850. qcheck-lin
  851. qcheck-multicoretests-util
  852. qcheck-ounit
  853. qcheck-stm
  854. quick_print
  855. randii
  856. random
  857. randoml
  858. raygui
  859. raylib >= "0.3.1"
  860. rdf >= "0.13.0"
  861. rdf_json_ld
  862. rdf_lwt
  863. rdf_mysql
  864. rdf_postgresql
  865. rdf_ppx
  866. rea < "0.2.0"
  867. reactjs-jsx-ppx
  868. readline
  869. reason >= "3.9.0"
  870. reason-react
  871. reason-react-ppx
  872. reddit_api_async
  873. reddit_api_kernel
  874. redis >= "0.4"
  875. redis-lwt >= "0.4"
  876. redis-sync >= "0.4"
  877. refl >= "0.2.0" & < "0.3.0"
  878. reparse >= "2.0.0"
  879. reparse-lwt
  880. reparse-lwt-unix
  881. reparse-unix
  882. repr != "0.2.0"
  883. repr-bench
  884. repr-fuzz
  885. rescript-syntax
  886. reshowcase
  887. resto >= "0.7"
  888. rfsm >= "2.0"
  889. river >= "0.2"
  890. rock >= "0.20.0"
  891. roman
  892. routes >= "1.0.0"
  893. rpc >= "6.1.0"
  894. rsdd
  895. rtop >= "3.9.0"
  896. rtree
  897. runtime_events_tools
  898. SourceCode_ASCII
  899. safemoney
  900. sail >= "0.15"
  901. sail_c_backend
  902. sail_coq_backend
  903. sail_doc_backend
  904. sail_latex_backend
  905. sail_lem_backend
  906. sail_manifest
  907. sail_ocaml_backend
  908. sail_output
  909. sail_smt_backend
  910. sail_sv_backend
  911. samplerate >= "0.1.6"
  912. sanddb >= "0.2"
  913. sarek >= "20210823"
  914. sarif
  915. saturn >= "0.4.1"
  916. saturn_lockfree >= "0.4.1"
  917. scad_ml
  918. scfg
  919. sd_logic
  920. sdl-liquidsoap >= "3"
  921. sedlex >= "2.4"
  922. sel
  923. semver >= "0.2.1"
  924. semver2
  925. seqes
  926. sequence >= "1.1"
  927. serde
  928. serde_debug
  929. serde_derive
  930. serde_json
  931. serde_sexpr
  932. serde_xml
  933. server-reason-react
  934. sexp_decode
  935. sha >= "1.15.1"
  936. shades
  937. shine >= "0.2.2"
  938. shuttle
  939. shuttle_http
  940. shuttle_ssl
  941. shuttle_websocket
  942. sifun
  943. sihl >= "0.1.5"
  944. sihl-cache
  945. sihl-contract
  946. sihl-core
  947. sihl-email
  948. sihl-facade
  949. sihl-persistence
  950. sihl-queue
  951. sihl-session
  952. sihl-storage
  953. sihl-token
  954. sihl-type
  955. sihl-user
  956. sihl-web
  957. simlog
  958. smart-print >= "0.3.0"
  959. smol
  960. smol-helpers
  961. smtlib-utils
  962. snappy >= "0.1.2"
  963. snoke
  964. sodium-fmt
  965. solid
  966. solid_server
  967. solid_tools
  968. solidity-alcotest
  969. solidity-common
  970. solidity-parser
  971. solidity-test
  972. solidity-typechecker
  973. spatial-shell
  974. spawn >= "v0.15.0"
  975. spdx_licenses < "1.2.0"
  976. spectrum
  977. speex >= "0.4.1"
  978. spelll >= "0.3"
  979. spices
  980. spin
  981. spoc >= "20210823"
  982. spoc_ppx
  983. sqids
  984. sqlgg >= "20200521"
  985. sqlite3 >= "5.0.3"
  986. sqlite3_utils
  987. srt >= "0.2.1"
  988. ssl >= "0.7.0"
  989. sslconf
  990. starpath
  991. stdint = "0.7.0" | >= "0.7.2"
  992. stdint-literals
  993. stdlib-random
  994. stdune
  995. stk
  996. stk_iconv
  997. stog >= "0.20.0"
  998. stog_all
  999. stog_asy
  1000. stog_dot
  1001. stog_extern
  1002. stog_markdown
  1003. stog_multi_doc
  1004. stog_nocaml
  1005. stog_noexec
  1006. stog_plugins
  1007. stog_rdf
  1008. stog_rel_href
  1009. stog_server
  1010. stog_server_multi
  1011. stog_sitemap
  1012. stog_writing
  1013. stramon-lib
  1014. stringCodepointSplitter
  1015. sun
  1016. swhid
  1017. swhid_compute
  1018. swhid_core
  1019. swhid_types
  1020. swipl
  1021. taglib >= "0.3.7"
  1022. talaria-bibtex
  1023. tar >= "2.0.0"
  1024. tar-eio
  1025. tar-mirage >= "2.0.0"
  1026. tar-unix >= "2.0.0"
  1027. teash
  1028. telemetry
  1029. terminal
  1030. terminus
  1031. terminus-cohttp
  1032. terminus-hlc
  1033. testu01
  1034. textmate-language
  1035. textrazor
  1036. tezos-bls12-381-polynomial >= "0.1.3"
  1037. tezos-plompiler >= "0.1.3"
  1038. tezos-plonk >= "0.1.3"
  1039. tezt-bam
  1040. thread-table
  1041. tidy_email
  1042. tidy_email_mailgun
  1043. tidy_email_sendgrid
  1044. tidy_email_smtp
  1045. timed >= "1.1"
  1046. timedesc >= "0.8.0"
  1047. timedesc-json
  1048. timedesc-sexp
  1049. timedesc-tzdb
  1050. timedesc-tzlocal
  1051. timedesc-tzlocal-js
  1052. timere >= "0.8.0"
  1053. timmy
  1054. timmy-jsoo
  1055. timmy-unix
  1056. tiny_httpd
  1057. tiny_httpd_camlzip
  1058. tip-parser >= "0.4"
  1059. tls-liquidsoap
  1060. toc
  1061. togglelog
  1062. toml >= "5.0.0"
  1063. toml_cconv >= "7.0.0"
  1064. topojson
  1065. topojsone
  1066. touist >= "3.5.0"
  1067. trace
  1068. trace-fuchsia
  1069. trace-tef
  1070. tracy-client
  1071. traits
  1072. trampoline
  1073. transept
  1074. travesty >= "0.7.2"
  1075. trexio
  1076. tsdl-image >= "0.3.0"
  1077. tsdl-mixer >= "0.3.0"
  1078. tsdl-ttf >= "0.3"
  1079. tty
  1080. tyabt
  1081. type_eq
  1082. type_id
  1083. tyre >= "0.5"
  1084. tyxml >= "4.6.0"
  1085. tyxml-jsx >= "4.6.0"
  1086. tyxml-lwd >= "0.2"
  1087. tyxml-ppx >= "4.6.0"
  1088. tyxml-syntax >= "4.6.0"
  1089. ubase >= "0.20"
  1090. um-abt
  1091. unisim_archisec
  1092. uring
  1093. uritemplate >= "0.1.0"
  1094. urn
  1095. validate
  1096. validator
  1097. varray
  1098. vdom
  1099. vec >= "0.2.0"
  1100. vendredi
  1101. voqc >= "0.2.0"
  1102. vue-jsoo >= "0.3"
  1103. vue-ppx
  1104. wayland
  1105. waylaunch < "0.3.0"
  1106. websocket >= "2.15"
  1107. websocket-async >= "2.15"
  1108. websocket-lwt-unix >= "2.15"
  1109. win-eventlog >= "0.4"
  1110. winsvc >= "1.0.1"
  1111. wtr
  1112. wtr-ppx
  1113. wu-manber-fuzzy-search
  1114. xapi-stdext-date
  1115. xapi-stdext-encodings
  1116. xapi-stdext-pervasives >= "4.19.0"
  1117. xapi-stdext-std >= "4.19.0"
  1118. xapi-stdext-threads >= "4.19.0"
  1119. xapi-stdext-unix >= "4.19.0"
  1120. xapi-stdext-zerocheck
  1121. xcursor
  1122. xdg
  1123. xmelly
  1124. xmldiff >= "0.7.0"
  1125. xmldiff_js
  1126. xoshiro
  1127. xtmpl >= "0.19.0"
  1128. xtmpl_js
  1129. xtmpl_ppx
  1130. yocaml
  1131. yocaml_cmark
  1132. yocaml_git
  1133. yocaml_jingoo
  1134. yocaml_markdown
  1135. yocaml_mustache
  1136. yocaml_syndication
  1137. yocaml_unix
  1138. yocaml_yaml
  1139. yojson >= "2.0.0"
  1140. yuujinchou >= "0.10.0" & < "3.0.0"
  1141. zanuda
  1142. zar
  1143. zed >= "3.2.0"
  1144. zlib >= "0.6"
  1145. zlist >= "0.4.0"
  1146. zmq >= "5.2.1"
  1147. zmq-async >= "5.2.1"
  1148. zmq-lwt >= "5.2.1"

Conflicts

None