ocaml

The OCaml compiler (virtual package)
Description

This package requires a matching implementation of OCaml, and polls it to initialise specific variables like ocaml:native-dynlink

Install
Published
24 Sep 2018
Dependencies
ocaml-system
>= "4.07.1" & < "4.07.2~"
ocaml-variants
>= "4.07.1" & < "4.07.2~"
Reverse Dependencies
0install
< "2.8" | >= "2.14" & < "2.17"
alba
< "0.4.1"
alcotest
>= "0.8.0"
alsa
>= "0.2.3"
alt-ergo-free
< "2.3.3"
amf
>= "0.1.2"
amqp-client
>= "1.0.3" & != "1.1.1"
ancient
>= "0.9.1"
angstrom
>= "0.6.0"
ao
< "0.2.2"
arakoon
>= "1.8.6"
archetype
< "1.2.5"
archimedes
>= "0.4.18"
argon2
>= "1.0.0"
asn1-combinators
>= "0.2.0" & < "0.2.6"
astring
>= "0.8.2"
async
< "109.19.00" | >= "113.24.00" & != "113.33.03" & < "v0.13.0"
async_core
< "109.19.00"
async_durable
< "v0.13.0"
async_extended
>= "113.24.00" & != "113.33.03"
async_extra
< "109.19.00" | = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & != "v0.11.0" & < "v0.13.0"
async_find
!= "111.28.00" & != "113.33.03" & < "v0.13.0"
async_inotify
!= "113.00.00" & != "113.33.03" & < "v0.13.0"
async_js
>= "v0.9.1" & < "v0.13.0"
async_kernel
>= "113.24.00" & != "113.33.03" & != "v0.11.0" & < "v0.13.0"
async_parallel
>= "113.24.00" & < "113.33.03" | >= "v0.9.1"
async_rpc_kernel
>= "113.24.00" & != "113.33.03" & < "v0.13.0"
async_sendfile
< "v0.13.0"
async_shell
!= "109.28.03" & < "113.33.03" | >= "v0.9.1" & < "v0.13.0"
async_smtp
< "112.35.00" | >= "113.24.00" & != "113.33.03" & < "v0.13.0"
async_ssl
< "112.35.00" | = "113.24.00" | >= "113.33.06" & < "v0.13.0"
async_unix
< "109.19.00" | = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.1" & < "v0.13.0"
async_websocket
< "v0.15.0"
atd
< "2.3.3"
atdgen
>= "1.9.1" & < "2.3.3"
atdj
< "2.3.3"
atds
< "2.3.3"
atomic
< "base"
awa
< "0.0.2"
awa-lwt
< "0.0.2"
awa-mirage
< "0.0.2"
aws-s3
< "4.6.0"
aws-s3-async
< "4.6.0"
b0
< "0.0.2"
bap
= "0.9.5" | >= "1.2.0" & < "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-abi
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-api
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-arm
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-beagle
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-bil
>= "1.6.0" & < "2.2.0"
bap-build
< "2.2.0"
bap-bundle
< "2.2.0"
bap-byteweight
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-byteweight-frontend
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-c
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-cache
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-callsites
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-constant-tracker
>= "1.6.0" & < "2.2.0"
bap-cxxfilt
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-demangle
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-dump-symbols
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-dwarf
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-elf
!= "1.5.0" & < "2.2.0"
bap-frames
!= "2.1.1"
bap-frontc
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-frontend
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-fsi-benchmark
< "1.4.0" | = "1.6.0"
bap-future
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-ida
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-ida-plugin
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-ida-python
< "1.4.0" | >= "1.6.0" & < "2.3.0"
bap-knowledge
< "2.2.0"
bap-llvm
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-main
< "2.2.0"
bap-mc
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-microx
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-mips
>= "1.6.0" & < "2.2.0"
bap-objdump
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-optimization
>= "1.6.0" & < "2.2.0"
bap-phoenix
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-piqi
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-plugins
< "2.2.0"
bap-powerpc
>= "1.6.0" & < "2.2.0"
bap-primus
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-primus-dictionary
>= "1.6.0" & < "2.2.0"
bap-primus-lisp
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-primus-region
>= "1.6.0" & < "2.2.0"
bap-primus-support
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-primus-test
>= "1.6.0" & < "2.2.0"
bap-primus-x86
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-print
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-raw
< "2.2.0"
bap-recipe
< "2.2.0"
bap-relocatable
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-report
>= "1.6.0" & < "2.2.0"
bap-run
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-ssa
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-std
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-strings
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-symbol-reader
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-taint
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-taint-propagator
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-term-mapper
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-trace
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-traces
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-trivial-condition-form
>= "1.6.0" & < "2.2.0"
bap-veri
!= "0.2.2"
bap-warn-unused
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bap-x86
< "1.4.0" | >= "1.6.0" & < "2.2.0"
bare
>= "1.6.0" & < "2.2.0"
base
>= "v0.11.1" & < "v0.14.1"
base-bytes
>= "base"
base64
>= "1.1.0" & != "2.3.0"
base_bigstring
< "v0.15.0"
base_quickcheck
< "v0.15.0"
bastet
< "2.0.0"
batteries
= "2.5.0" | >= "2.9.0"
bau
>= "0.0.4"
bddapron
>= "2.3.2"
beluga
>= "0.8.1" & < "1.0"
benchmark
>= "1.4"
bencode
!= "0.2"
bibtex2html
>= "1.99"
bignum
< "112.35.00" | >= "113.24.00" & != "113.33.03" & < "v0.13.0"
bigstringaf
< "0.9.0"
bimage
< "0.3.0"
bimage-unix
< "0.3.0"
bin_prot
< "109.15.00" | >= "v0.9.2" & < "v0.14.1"
biniou
>= "1.1.0"
binsec
< "0.4.0"
biocaml
!= "0.5.0" & != "0.8.0" & != "0.10.0" & < "0.11.0"
bisect
>= "1.3.1"
bisect_ppx
>= "1.3.1"
bistro
< "0.6.0"
bitmasks
>= "1.2.0"
bitstring
>= "3.0.0"
bitv
>= "1.3"
bitvec
< "2.2.0"
bitvec-order
< "2.2.0"
bitvec-sexp
< "2.2.0"
bjack
< "0.1.6"
blake2
>= "0.2"
bls12-381
< "0.3.15"
bogue
< "20210514"
bolt
= "1.3"
bos
< "0.2.1"
ca-certs
< "0.2.1"
ca-certs-nss
< "3.64.0.1"
cairo2
>= "0.5"
calculon
< "0.7"
caldav
< "0.1.1"
calendar
!= "2.03.1"
camlimages
>= "4.2.5"
camllib
>= "1.3.2"
camlon
>= "2.0.0" & < "3.0.0"
camlp-streams
>= "5.0.1"
camlp4
= "4.02.0-1modular-implicits" | >= "4.07+1" & < "4.08+1"
camlp5
>= "7.06.10-g84ce6cc4" & != "7.09"
camlpdf
>= "2.2.1" & < "2.5"
camltc
>= "0.9.6"
camlzip
>= "1.06"
camomile
>= "0.8.6"
capnp-rpc
< "1.2"
capnp-rpc-net
< "0.9.0"
capnp-rpc-unix
!= "0.3" & < "0.9.0"
cbor
>= "0.2"
cconv
>= "0.2"
ccss
>= "1.6"
certify
>= "0.2"
cfg
>= "2.1.0" & < "2.3.0"
cfstream
>= "1.3.0"
cgi
>= "0.9"
charrua
< "1.4.0"
charrua-unix
< "0.5" | >= "0.10" & < "1.4.0"
cinaps
>= "v0.9.1"
clangml
!= "3.8.0" & != "3.9.1.2" & < "4.3.0"
clangml-transforms
>= "0.24" & < "0.26"
cloudi
>= "1.7.3"
cmdliner
= "0.9.4" | >= "1.0.0" & < "1.1.0"
coccinelle
!= "1.0.0-rc23"
codept
>= "0.10.2"
cohttp
!= "0.99.0" & < "3.0.0"
cohttp-async
< "3.0.0"
cohttp-lwt
< "3.0.0"
cohttp-mirage
< "3.0.0"
cohttp-top
< "3.0.0"
combinat
< "3.0"
combine
< "0.42"
command_rpc
< "v0.13.0"
comparelib
< "113.00.00"
conduit-mirage
!= "2.3.0"
conjury
< "2.1"
containers
>= "0.12" & < "2.1" | >= "2.3"
cookie
>= "0.1.8"
coq
>= "8.7.0" & < "8.16.0"
coq-serapi
< "8.7.2+0.4.13" | >= "8.8.0+0.5.2" & < "8.16.0+0.16.0"
coqide
!= "8.7.0" & < "8.10.0"
core
>= "113.24.00" & != "113.33.00" & != "113.33.02" & < "113.33.03" | >= "v0.9.2" & < "v0.11.0" | >= "v0.11.2" & < "v0.13.0"
core-lwt
!= "0.2.0"
core_bench
!= "112.35.00" & != "113.33.00" & != "113.33.03" & < "v0.13.0"
core_extended
>= "108.00.02" & < "109.19.00" | = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.1" & < "v0.13.0"
core_kernel
= "113.24.00" | >= "113.33.01+4.03" & < "113.33.03" | >= "v0.9.1" & != "v0.11.0" & < "v0.13.0"
core_profiler
>= "113.24.00" & != "113.33.03" & < "v0.13.0"
cow
>= "2.0.1"
cpdf
< "2.1.1" | = "2.3"
cppo
>= "1.6.1"
crc
>= "1.0.0"
crowbar
< "0.2"
crunch
>= "1.4.0" & < "3.3.0"
cry
>= "0.6.0" & < "0.6.5"
crypt
>= "1.2"
cryptodbm
>= "0.84.2"
cryptokit
>= "1.11" & < "1.17"
cstruct
>= "1.6.0" & < "1.8.0" | >= "2.4.1" & < "6.1.0"
cstruct-async
< "6.1.0"
cstruct-lwt
< "6.1.0"
cstruct-sexp
< "6.1.0"
csv
>= "1.4"
csvfields
>= "v0.9.1" & < "v0.13.0"
ctypes
>= "0.8.0"
cubicle
>= "1.1.2"
custom_printf
>= "111.21.00" & < "113.00.00"
DrawGrammar
>= "0.2.1"
datakit
< "0.10.0" | >= "0.11.0"
datalog
< "0.5" | >= "0.6"
decimal
< "0.1.1"
decompress
>= "0.3"
dedukti
< "2.7"
delimcc
>= "2017.03.02"
depyt
< "0.3.0"
deriving
>= "0.7.1"
devkit
>= "0.5"
digestif
< "1.1.2"
dlist
>= "0.0.3"
dns
!= "1.0.0" & < "6.0.1"
dns-certify
< "6.0.1"
dns-cli
< "4.6.0"
dns-client
< "6.0.1"
dns-mirage
< "6.0.1"
dns-resolver
< "6.0.1"
dns-server
< "6.0.1"
dns-stub
< "6.0.1"
dns-tsig
< "6.0.1"
doc-ock
>= "1.2.0"
dockerfile
< "1.3.0" | >= "1.7.2"
dolmen
< "0.5"
dolog
>= "1.1"
down
< "0.1.0"
dropbox
< "0.2"
dryunit
>= "0.4.0"
dssi
< "0.1.3"
dum
< "1.0.2"
dune-release
< "1.6.1"
duppy
>= "0.7.0" & < "0.9.0"
dyntype
>= "0.8.3"
earley
>= "1.0.1"
earlybird
>= "0.1.1" & < "1.0.0"
easy-format
< "1.3.3"
ecaml
< "v0.13.0"
edn
>= "0.1.6-1-gff9db95"
efl
>= "1.12.0"
electrod
< "0.8.0"
eliom
< "6.13.1"
email_message
< "112.35.00" | = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.1" & != "v0.11.0" & < "v0.13.0"
encore
!= "0.3"
enumerate
< "111.08.00"
erssical
< "1.1.0"
ethernet
< "2.2.1"
exenum
>= "0.7"
expect
>= "0.0.6"
extlib
= "1.7.0" | >= "1.7.5"
extprot
>= "1.1.2" & < "1.3.0" | >= "1.6.0"
extunix
>= "0.1.5"
ez_subst
< "0.2.0"
ezjs_min
< "0.3.0"
ezjsonm
>= "0.5.0" & < "1.3.0"
ezjsonm-lwt
>= "1.0.0"
ezresto
< "0.6"
ezxenstore
>= "0.4.1"
ezxmlm
>= "1.0.2"
FrontC
>= "3.4.1" & < "4.0.0"
faad
< "0.5.0"
faraday-async
< "0.7.2"
fat-filesystem
!= "0.12.0" & != "0.12.2"
fd-send-recv
>= "1.0.5"
fdkaac
< "0.3.2"
feather
< "0.2.0"
ffmpeg
< "1.0.0~beta1"
fftw3
>= "0.8"
fiat-p256
< "0.2.1"
fieldslib
< "109.19.00" | = "113.24.00" | >= "v0.9.0" & < "v0.15.0"
fileutils
>= "0.5.3"
flac
!= "0.1.2"
flow
>= "0.3"
flow_parser
>= "0.46.0" & < "0.159.0"
flowtype
>= "0.62.0" & < "0.87.0"
fluent-logger
< "1.1.0"
fmt
>= "0.8.0" & < "0.8.10"
frama-c
>= "11.0" & < "22.0"
frei0r
< "0.1.2"
frenetic
< "5.0.5"
fromager
< "0.5.0"
fstar
>= "0.9.6.0"
functoria
>= "2.2.1" & < "3.1.2"
functory
>= "0.6"
General
>= "0.6.0"
gammu
>= "0.9.3"
gapi-ocaml
>= "0.3.5"
gdal
< "0.3.0" | >= "0.9.0"
gdbprofiler
>= "0.2"
gen
= "0.2.2" | >= "0.5"
gen-bs
< "0.1.0"
gen_js_api
= "1.0.5"
genet
< "0.6"
geoip
>= "0.0.3"
get_line
< "5.0.0"
gettext
>= "0.3.8"
gg
>= "0.9.2" & < "1.0.0"
git
< "1.4.3" | >= "1.8.0" & < "3.2.0"
git-cohttp
< "3.2.0"
git-mirage
< "3.2.0"
git-unix
< "3.2.0"
github
< "1.0.0" | >= "3.0.0" & < "4.4.0"
github-jsoo
< "4.4.0"
github-unix
>= "3.1.0" & < "4.4.0"
glical
>= "0.0.3"
glMLite
= "0.03.52"
glpk
!= "0.1.7"
gperftools
>= "0.3"
gpr
< "1.5.0"
gr
< "0.0.2"
graphics
< "3.07" | = "4.07.1"
graphlib
< "1.4.0" | >= "1.6.0" & < "2.2.0"
graphql
< "0.14.0"
graphql-async
< "0.14.0"
graphql-cohttp
< "0.14.0"
graphql-lwt
< "0.14.0"
graphql_parser
< "0.14.0"
graphql_ppx
>= "0.7.1"
grenier
!= "0.5" & < "0.12"
gsl
< "1.24.2"
hacl-star
< "0.4.0"
hacl-star-raw
< "0.4.0"
hardcaml
< "v0.15.0"
hdf5
>= "0.1.4"
heptagon
< "1.01.00" | >= "1.03.03"
hevea
>= "2.25" & < "2.35"
hex
>= "1.2.0" & < "1.5.0"
hexstring
< "0.2.1"
higlo
!= "0.3" & < "0.8"
hmap
>= "0.8.1"
horned_worm
!= "0.3.1"
humane-re
!= "0.0.3"
hvsock
>= "0.6"
hxd
< "0.3.2"
i3ipc
>= "0.1.2"
ibx
< "0.8.1"
icalendar
< "0.1.5"
imagelib
>= "20171028"
imaplet-lwt
< "0.1.15"
incr_dom
< "v0.13.0"
incr_dom_widgets
< "v0.13.0"
incr_map
< "v0.13.0"
incr_select
< "v0.13.0"
incremental
>= "113.24.00" & != "113.33.03" & < "v0.13.0"
incremental_kernel
!= "113.33.03" & != "v0.11.0"
index
< "1.3.0"
inferno
< "20211222"
inotify
>= "2.1"
inquire
< "0.2.0"
io-page
>= "2.0.1" & < "3.0.0"
io-page-unix
>= "2.0.0"
io-page-xen
>= "2.0.0"
iocaml
>= "0.4.6"
iocaml-kernel
>= "0.4.6"
iocamljs-kernel
< "0.4.3" | >= "0.4.6"
ipaddr
>= "2.7.2" & < "5.3.1"
ipaddr-sexp
< "5.3.1"
irc-client
>= "0.4.0"
iri
< "0.5.0"
irmin
< "0.9.0" | >= "0.9.5" & != "0.9.10" & < "1.0.0" | >= "1.3.2" & < "2.4.0"
irmin-git
>= "1.1.0"
irmin-http
>= "1.3.1"
irmin-mirage
< "2.0.0"
irmin-pack
< "2.3.0"
irmin-unix
!= "1.3.0"
irrlicht
>= "0.0.5"
itv-tree
>= "2.1"
JsOfOCairo
>= "1.0.1"
javalib
!= "2.3.3"
jenga
< "109.19.00" | >= "113.24.00" & != "113.33.00" & != "113.33.03"
jingoo
>= "1.2.16"
jose
< "0.5.0"
js-build-tools
>= "113.33.04"
js_of_ocaml
>= "3.0"
json-wheel
>= "1.0.6+safe-string"
jsonm
!= "1.0.0"
jsonrpc
< "1.6.0"
jsoo_storage
>= "1.0.1"
jst-config
< "v0.15.0"
junit
< "2.0.1"
junit_ounit
< "2.0.1"
jupyter
< "2.7.8"
jwto
< "0.4.0"
KaSim
>= "4.0.0"
kafka
>= "0.3"
kaputt
>= "1.2"
ke
< "0.6"
ketrew
>= "1.1.1" & != "3.0.0"
key-parsers
!= "0.10.0" & < "1.2.1"
kind2
< "1.5.0"
lablgtk
>= "2.18.6"
lablgtk3
< "3.1.2"
lablqml
>= "0.5.2" & < "0.7"
labltk
>= "8.06.5" & < "8.06.12"
lacaml
< "11.0.6"
ladspa
< "0.2.0"
lambda-term
< "1.6" | >= "1.12.0" & < "3.2.0"
lambdapi
< "2.0.0"
lame
< "0.3.4"
landmarks
< "1.4"
lascar
< "0.6.0"
lastfm
= "0.3.2"
lazy-trie
>= "1.1.0"
lbfgs
>= "0.9"
lbvs_consent
< "2.0.0"
learn-ocaml
< "0.12"
ledit
>= "2.04"
lens
< "1.2.4"
letsencrypt
< "0.2.3"
letters
< "0.1.1"
leveldb
< "1.0.3" | >= "1.2.0"
libsvm
!= "0.9.3"
libudev
>= "0.2.1"
line-up-words
< "v0.13.0"
links
>= "0.8" & < "0.9.2"
links-postgresql
>= "0.7.3" & < "0.9.2"
links-sqlite3
< "0.9.2"
liquidsoap
>= "1.3.4" & < "1.4.0"
lmdb
>= "1.0"
lo
< "0.2.0"
logs
>= "0.6.2"
logtk
>= "1.5.1"
lpd
>= "1.2.2"
lsp
< "1.6.0"
lutils
>= "1.44"
lwt
>= "3.0.0" & < "5.6.0"
lwt_domain
< "0.2.0"
lwt_ppx
< "2.1.0"
lwt_react
< "1.2.0"
lwt_ssl
>= "1.1.1"
lz4_chans
>= "3.0.0"
lzo
>= "0.0.2"
macaddr
< "5.3.1"
macaddr-sexp
< "5.3.1"
macaque
!= "0.7.1"
macaroons
< "0.1.1"
mad
< "0.5.0"
mariadb
>= "0.9.0"
mbr-format
< "1.0.0"
md2mld
< "0.6"
mdx
>= "1.2.0" & < "2.0.0"
memcad
< "1.1.0"
menhir
>= "20130911" & != "20211125"
merlin
>= "3.2.1" & != "3.3.4~4.10preview1" & != "3.3.7~4.11preview1" & < "4.1-411"
mesh
>= "0.8.7"
metapp
< "0.3.0"
metaquot
< "0.3.0"
metrics-lwt
>= "0.3.0"
metrics-mirage
>= "0.3.0"
metrics-unix
>= "0.3.0"
mikmatch
>= "1.0.9"
milter
>= "1.0.2"
mindstorm
>= "0.6"
minisat
!= "0.3"
mirage
>= "2.0.0" & < "2.7.0" | >= "3.1.1" & < "3.9.0"
mirage-block
< "3.0.0"
mirage-block-unix
>= "2.0.0" & != "2.7.0"
mirage-clock
< "4.0.0"
mirage-console
!= "2.1.0" & < "4.0.0"
mirage-crypto
< "0.7.0"
mirage-flow
< "1.0.3" | >= "1.2.0" & < "3.0.0"
mirage-flow-unix
!= "1.4.0" & < "3.0.0"
mirage-fs
< "4.0.0"
mirage-fs-unix
>= "1.4.1"
mirage-kv
< "4.0.0"
mirage-nat
< "1.1.0" | >= "2.0.0" & < "2.2.4"
mirage-net
< "4.0.0"
mirage-net-solo5
< "0.4.3" | >= "0.6.1" & < "0.7.0"
mirage-net-xen
>= "1.4.2" & < "1.6.0" | >= "1.7.0" & < "2.0.0"
mirage-os-shim
>= "3.0.1"
mirage-qubes
< "0.9.0"
mirage-random
< "3.0.0"
mirage-solo5
< "0.6.5"
mirage-stack
< "3.0.0"
mirage-time
< "3.0.0"
mirage-types
< "3.9.0"
mirage-xen
>= "2.6.0" & < "6.0.0"
mkocaml
>= "1.2"
mlcuddidl
>= "3.0.2"
mldonkey
>= "3.1.7-2"
mlgmpidl
>= "1.2.6"
mlpost
>= "0.8.2"
mlt_parser
< "v0.13.0"
mm
>= "0.3.1" & < "0.5.0" | = "0.7.4"
modelica_ml
>= "0.2.0"
molenc
< "16.5.0"
monads
< "1.4.0" | >= "1.6.0" & < "2.2.0"
monomorphic
>= "1.2" & < "2.0"
mparser
>= "1.2"
mpp
>= "0.3.2"
mpris
>= "0.1.1"
mqtt
< "0.0.2"
mrmime
< "0.4.0"
msgpack
>= "1.3.0"
msgpck
< "1.5"
mstruct
>= "1.4.0"
mtime
>= "0.8.4" & < "1.4.0"
mustache
!= "2.0.0"
mysql
>= "1.2.1"
nbd
< "6.0.0"
netchannel
< "2.0.0"
netsnmp
< "v0.13.0"
nlopt-ocaml
>= "0.5.1"
nocrypto
>= "0.2.0" & != "0.5.3"
notty
!= "0.2.0" & < "0.2.3"
notty_async
< "v0.13.0"
npy
>= "0.0.7"
nsq
>= "0.1.1"
num
>= "1.0"
nunchaku
>= "0.5.1"
OCanren
< "0.2.0"
OCanren-ppx
< "0.3.0~alpha1"
oasis
>= "0.4.7"
oasis2opam
< "0.4.4" | >= "0.6.1"
obeam
< "0.1.0" | >= "0.1.2"
obelisk
< "0.5.0"
objsize
>= "0.18"
obuild
>= "0.1.9"
obus
= "1.1.8"
ocal
!= "0.2.0"
ocaml-basics
!= "0.4.0"
ocaml-freestanding
>= "0.3.1" & < "0.6.0"
ocaml-http
>= "0.1.6"
ocaml-lua
= "1.7"
ocaml-makefile
< "6.39.2"
ocaml-manual
= "4.07.0"
ocaml-migrate-parsetree
>= "1.0.10" & != "1.3.0~4.08.0+beta2"
ocaml-monadic
>= "0.3.2"
ocaml-r
>= "0.1.0" & < "0.4.0"
ocaml-src
= "4.07.1"
ocaml-top
< "1.1.0" | >= "1.1.5"
ocaml-variants
>= "4.07.1+32bit" & < "4.07.2+trunk"
ocaml_plugin
< "112.35.00" | >= "113.24.00" & != "113.33.00" & != "113.33.03" & < "v0.13.0"
ocamlbuild
!= "0.9.0"
ocamlclean
>= "2.1"
ocamlcodoc
< "1.0.1"
ocamldap
>= "2.3.0"
ocamldiff
>= "1.1"
ocamlfind
>= "1.8.0"
ocamlformat
!= "0.5" & != "0.13.0" & < "0.17.0"
ocamlgraph
>= "1.8.8"
ocamlmod
>= "0.0.8"
ocamlnet
>= "4.1.6"
ocamlpp
>= "1.1"
ocamlscript
< "3.0.0"
ocamltter
< "2.0.1" | = "2.1.1" | >= "4.1.0"
ocapic
>= "3.4"
ocf
= "0.5.0"
ocp-browser
!= "1.2.1" & < "1.3.4"
ocp-build
>= "1.99.18-beta"
ocp-indent
= "1.5.2" | >= "1.6.1"
ocp-index
>= "1.1.7" & < "1.3.4"
ocsigen-i18n
< "3.6.0"
ocsigenserver
!= "2.9" & < "2.18.0"
ocurl
>= "0.7.6"
odate
>= "0.6"
odds
< "1.1"
odepack
>= "0.6.7"
odig
!= "0.0.2" & < "0.0.6"
ogen
!= "0.1.2"
ogg
= "0.5.2" | = "0.6.1"
ogre
< "1.4.0" | >= "1.6.0" & < "2.2.0"
ojs-base
< "0.3.0" | = "0.5.0"
omake
>= "0.10.3"
omd
>= "1.3.1"
omod
< "0.0.3"
omonad
>= "0.3.2" & < "0.4.0"
opam-bin
>= "0.9.5"
opam-core
= "2.0.0~beta5" | >= "2.0.0~rc2"
opam-lib
< "0.9.4" | >= "1.0.0"
opass
< "2.15"
opasswd
>= "1.3.1"
operf-micro
>= "1.1.1"
opium
< "0.19.0"
optimization1d
!= "0.5.1"
opus
< "0.2.0"
orakuda
>= "1.2.0" & < "2.0.0"
orm
>= "0.7.0"
orsetto
< "1.1"
osbx
>= "1.2.4"
osc
= "0.1.4"
osdp
< "1.0.0"
otr
>= "0.3.2" & < "0.3.10"
ott
>= "0.26"
ounit
>= "2.0.0" & < "2.2.0"
ounit-lwt
< "2.2.0"
override
< "0.4.0"
owl
>= "0.3.0" & < "0.9.0"
owl-base
< "0.9.0"
owl-ode
< "0.4.0"
owl-ode-base
< "0.4.0"
owl-plplot
< "0.9.0"
owl-top
< "0.9.0"
owl-zoo
< "0.9.0"
pa_bench
< "113.00.00"
pa_ounit
< "112.35.00"
pa_test
< "112.24.00"
pam
< "v0.13.0"
pareto
>= "0.3"
parmap
>= "1.0-rc9"
parsexp
>= "v0.9.1" & < "v0.15.0"
parsexp_io
>= "v0.9.1" & < "v0.15.0"
patdiff
!= "113.00.00" & != "113.33.03" & < "v0.13.0"
patience_diff
!= "112.24.00" & != "113.33.03" & < "v0.13.0"
pattern
!= "0.1.1" & < "0.3.0"
pcap-format
< "0.6.0"
pci
>= "1.0.1"
pcre
>= "7.1.3" & < "7.4.2"
pfff
>= "0.37.1"
pgocaml
< "1.7" | >= "2.2"
pgx
< "1.0"
pgx_async
< "1.0"
pgx_lwt
< "1.0"
pgx_unix
< "1.0"
pilat
< "1.6"
pipebang
< "109.09.00"
pkcs11-cli
>= "1.0.1"
pkcs11-rev
>= "1.0.1"
planck
>= "2.2.0"
planets
>= "0.1.14"
plist
< "1.0.0"
plotkicadsch
< "0.4.0" | = "0.5.2"
podge
< "0.4"
pomap
>= "4.1.0"
portaudio
= "0.2.1"
portia
>= "1.1"
posix-getopt
< "2.0.0"
posixat
>= "v0.10.0" & < "v0.15.0"
postgresql
< "4.5.1"
pp
< "1.1.2"
pprint
>= "20171003"
ppx_assert
>= "113.24.00" & != "113.33.03" & < "v0.15.0"
ppx_ast
= "v0.9.2" | >= "v0.11.0"
ppx_base
< "v0.15.0"
ppx_bench
= "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.15.0"
ppx_bigarray
>= "2.0.0"
ppx_bin_prot
>= "113.24.00" & != "113.33.00" & != "113.33.03" & < "v0.15.0"
ppx_bitstring
= "1.1.0" | >= "1.3.3" & < "4.0.0"
ppx_blob
>= "0.2"
ppx_cold
< "v0.15.0"
ppx_compare
= "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.15.0"
ppx_conv_func
= "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.15.0"
ppx_core
>= "v0.9.2"
ppx_cstruct
< "6.1.0"
ppx_csv_conv
= "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.13.0"
ppx_custom_printf
= "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.15.0"
ppx_defer
< "0.5.0"
ppx_deriving
= "4.1.5" | >= "4.2.1"
ppx_deriving_protobuf
= "2.4" | >= "2.6"
ppx_deriving_yojson
< "2.0" | >= "3.1"
ppx_driver
= "113.24.00" | >= "113.33.00+4.03" & < "113.33.03" | >= "v0.9.2"
ppx_enumerate
= "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.15.0"
ppx_expect
!= "113.33.00" & != "113.33.01" & != "113.33.03" & < "v0.15.0"
ppx_fail
= "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0"
ppx_fields_conv
= "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.15.0"
ppx_getenv
>= "1.2"
ppx_hash
< "v0.15.0"
ppx_here
>= "113.24.00" & != "113.33.03" & < "v0.15.0"
ppx_import
>= "1.5"
ppx_include
>= "1.1"
ppx_inline_test
= "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.15.0"
ppx_irmin
< "2.3.0"
ppx_jane
!= "113.33.03" & < "v0.15.0"
ppx_js_style
< "v0.15.0"
ppx_jsobject_conv
>= "0.2.1" & < "0.6.0"
ppx_let
!= "113.33.00" & != "113.33.03" & < "v0.15.0"
ppx_log
< "v0.15.0"
ppx_meta_conv
= "4.0.0"
ppx_module_timer
< "v0.15.0"
ppx_monadic
>= "1.0.4"
ppx_netblob
>= "1.1"
ppx_optcomp
= "113.24.00" | = "113.33.01+4.03" | >= "v0.9.0" & < "v0.14.3"
ppx_optional
< "v0.15.0"
ppx_orakuda
= "3.0.1" | = "3.1.0" | >= "3.3.0"
ppx_pattern_bind
< "v0.15.0"
ppx_pipebang
= "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.15.0"
ppx_python
< "v0.15.0"
ppx_regexp
>= "0.3.0"
ppx_relit
>= "0.2.0"
ppx_sexp_conv
>= "113.24.00" & != "113.33.03" & < "v0.15.0"
ppx_sexp_message
!= "113.33.00" & != "113.33.03" & < "v0.15.0"
ppx_sexp_value
= "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.15.0"
ppx_stable
< "v0.15.0"
ppx_string
< "v0.15.0"
ppx_test
>= "1.4.0" & < "1.7.0"
ppx_tools
= "5.1+4.06.0"
ppx_type_conv
= "113.24.00" | >= "113.33.00+4.03" & != "113.33.03"
ppx_typerep_conv
= "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.15.0"
ppx_variants_conv
= "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.15.0"
ppx_xml_conv
>= "113.24.00" & != "113.33.03" & < "v0.13.0"
ppx_yojson
< "1.2.0"
ppx_yojson_conv
< "v0.15.0"
ppxlib
< "0.14.0" | >= "0.16.0" & < "0.19.0" | >= "0.21.0" & != "0.25.0~5.00preview"
ppxx
= "2.3.2"
pratter
< "2.0.0"
prettym
< "0.0.3"
proj4
>= "0.9.2"
prom
= "0.2"
proverif
>= "1.97pl3"
ptime
>= "0.8.1" & < "1.0.0"
ptmap
< "2.0.1" | >= "2.0.4"
ptset
>= "1.0.1"
pulseaudio
< "0.1.4"
pyml
!= "20171117"
pythonlib
< "v0.14.0"
qbf
< "0.3"
qcheck
>= "0.3" & < "0.5" | >= "0.5.2" & < "0.18"
qcheck-core
< "0.18"
qcow
< "0.8.1" | >= "0.10.0"
qocamlbrowser
= "0.2.10"
qrencode
>= "0.2"
qtest
>= "2.7"
quickcheck
!= "1.0.0"
radare2
>= "0.0.2"
ranger
>= "0.1.0"
rawlink
>= "0.6" & < "2.1"
rdbg
>= "1.175"
rdf
>= "0.5" & < "0.7.0" | = "0.11.0"
rdr
< "2.0.1"
re
>= "1.3.0"
re2
< "112.35.00" | = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.1" & < "v0.13.0"
react
= "1.0.0" | = "1.2.1"
reactiveData
< "0.3.0"
reanalyze
< "2.23.0"
reason
>= "3.3.5"
record_builder
< "v0.15.0"
redirect
>= "0.1.1"
redis
>= "0.3.6"
redis-lwt
>= "0.3.6"
redis-sync
>= "0.3.6"
refl
< "0.4.0"
regular
>= "1.2.0" & < "1.4.0" | >= "1.6.0" & < "2.2.0"
relit-reason
>= "0.0.2"
relit_helper
>= "0.2.0"
res
>= "4.0.7"
resource_cache
< "v0.13.0"
resp-mirage
< "0.10.0"
resp-unix
< "0.11.0"
resto
< "0.6"
resto-json
< "0.6"
rfc6287
!= "1.0.2"
rfsm
< "1.6.0"
riakc_ppx
!= "3.1.2"
ringo
< "1.0.0"
river
< "0.2"
rml
>= "1.09.00" & != "1.09.04"
root1d
!= "0.3"
rope
>= "0.6"
rpc
< "1.3.0" | >= "5.9.0" & != "8.0.0"
rpc_parallel
>= "113.24.00" & != "113.33.03" & < "v0.13.0"
rpclib
!= "8.0.0" & < "9.0.0"
rresult
>= "0.4.0" & < "0.7.0"
rtop
>= "3.3.5"
safepass
>= "2.0"
samplerate
< "0.1.5"
sarek
>= "20210823"
satyrographos
< "0.0.2.7"
sawja
!= "1.5.2"
sedlex
>= "1.99.3" & < "2.6"
seq
>= "0.2.2"
sequence
< "0.3" | >= "1.1"
sequencer_table
< "v0.13.0"
sexp
< "v0.13.0"
sexp_diff_kernel
< "v0.13.0"
sexp_macro
< "v0.13.0"
sexp_pretty
< "v0.15.0"
sexp_select
< "v0.15.0"
sexplib
>= "v0.9.3" & < "v0.15.0"
sexplib0
< "v0.15.1"
sfml
< "0.08.2" | >= "0.09"
sha
>= "1.10" & < "1.13" | >= "1.15.1"
shared-block-ring
< "2.3.0" | >= "3.0.0"
shared-memory-ring
< "1.2.0" | >= "3.0.0" & < "3.1.1"
shcaml
>= "0.2.1"
shell
< "v0.13.0"
shexp
< "v0.11.0" | >= "v0.12.0" & < "v0.15.0"
slacko
>= "0.11.0" & < "0.15.0"
slap
>= "3.0.1"
snappy
!= "0.1.0"
socketcan
>= "0.8.12-0"
sodium
!= "0.2.0"
sosa
>= "0.2.0"
soupault
< "1.7.0"
spdx_licenses
< "1.1.0"
speex
!= "0.4.0"
spelll
= "0.2" | >= "0.4"
spf
>= "2.0.2"
spin
< "0.6.0"
splay_tree
< "v0.13.0"
spoc
>= "20170724"
spotify-cli
>= "0.3.0"
spotlib
>= "4.0.2" & < "4.1.0"
sqlexpr
< "0.7.1" | >= "0.9.0"
sqlite3
< "5.0.3"
srs
>= "2.0.0"
srt
< "0.1.1"
ssh-agent
< "0.4.0"
ssl
>= "0.5.4"
statverif
>= "1.97pl1.1"
stdio
>= "v0.9.1" & < "v0.15.0"
stemming
>= "0.2.1"
stog
>= "0.15.0" & < "0.19.0"
stog-writing
< "0.19.0"
stone
>= "0.5.1"
string_dict
< "v0.15.0"
stringext
>= "1.2.0"
syndic
>= "1.2"
syslog
>= "2.0.0"
systemverilog
< "0.0.2"
taglib
!= "0.3.7"
tar
>= "0.9.0" & < "2.0.0"
tar-mirage
>= "0.9.0" & < "2.0.0"
tar-unix
>= "0.9.0"
tcpip
< "3.0.0" | >= "3.3.1" & < "6.3.0"
tdk
>= "0.1.1"
tensorflow
!= "0.0.10"
terminal_size
< "0.2.0"
text
>= "0.8.0"
text-tags
< "1.4.0" | >= "1.6.0" & < "2.2.0"
textutils
!= "112.17.00" & != "113.33.03" & < "v0.13.0"
textutils_kernel
< "v0.13.0"
textwrap
>= "0.2"
tgls
!= "0.8.3" & < "0.8.6"
theora
< "0.4.0"
thrift
>= "0.10.0"
time_now
< "v0.15.0"
timed
< "1.1"
timedesc
< "0.8.0"
tiny_json
>= "1.1.5"
tip-parser
< "0.5"
tls
< "0.12.2"
tls-mirage
< "0.12.2"
toml
>= "5.0.0"
tophide
>= "1.0.4"
toplevel_expect_test
< "113.33.02" | >= "v0.9.2" & < "v0.13.0"
topological_sort
< "v0.15.0"
torch
< "0.11"
tptp
>= "0.3.2"
travesty
< "0.7.0"
trax
< "0.4.0"
treeprint
>= "2.1.1"
tsdl
< "0.8.1" | >= "0.9.1" & < "0.9.9"
tuntap
>= "1.3.0"
type_conv
>= "113.00.02"
typerep
< "112.35.00" | = "113.24.00" | >= "v0.9.0" & < "v0.15.0"
typerep_extended
!= "113.00.00" & != "113.33.03"
typerex-attic
>= "1.0.2"
tyxml
< "3.0.0" | >= "3.3.0" & != "4.1.0"
uchar
>= "0.0.2"
uecc
>= "0.3"
uint
>= "1.2.1"
ulex
>= "1.2"
unison
>= "2.48.15v4" & < "2.52.0"
uri
>= "1.3.13" & < "1.9.2" | >= "1.9.5"
uritemplate
>= "0.2.0"
usb
>= "1.3.1"
usbmux
>= "1.2.0"
utop
>= "2.2.0"
uucd
>= "4.0.0"
uucp
>= "2.0.0"
uuidm
>= "0.9.6" & < "0.9.8"
uunf
< "1.0.0" | >= "2.0.1"
uuseg
!= "1.0.0"
uutf
>= "1.0.1"
variantslib
!= "109.15.03" & != "113.33.03" & < "v0.15.0"
vcardgen
< "1.2"
vchan
< "6.0.0"
vchan-unix
>= "4.0.0" & < "6.0.0"
vchan-xen
< "6.0.0"
vector3
>= "0.2.1"
vg
< "0.8.1" | >= "0.9.0"
vhd-format
!= "0.8.0" & != "0.9.2"
vhd-format-lwt
!= "0.9.2"
virtual_dom
>= "v0.9.1" & < "v0.13.0"
visitors
>= "20171124"
vmnet
< "1.2.0" | >= "1.3.1"
vorbis
< "0.6.2" | >= "0.7.1"
vpnkit
!= "0.1.1"
vpt
< "5.0.0"
vue-jsoo
>= "0.2"
wasm
>= "1.0" & < "1.1"
webdav
>= "1.1.5"
weberizer
!= "0.7.2" & != "0.7.7"
webidl
>= "1.0"
websocket
!= "2.12"
why
>= "2.32"
why3
>= "0.85"
winsvc
>= "1.0.1"
wyrd
>= "1.4.6"
x509
< "0.12.0"
xapi-inventory
!= "1.2.1"
xapi-rrd
< "1.0.2" | >= "1.9.0"
xen-evtchn
>= "1.0.6"
xen-gnt
< "4.0.1"
xen-gnt-unix
< "4.0.1"
xenctrl
>= "0.9.29" & < "0.9.32"
xenstore
< "1.3.0" | >= "2.0.0"
xenstore_transport
< "0.9.2" | >= "0.9.6"
xmldiff
< "0.6.0"
xmlm
>= "1.3.0"
xtmpl
= "0.10" | >= "0.14.0" & < "0.18.0"
yajl-extra
< "0.7.3"
yaml
< "3.0.1"
yojson
>= "1.4.0"
yurt
>= "0.3"
z3
< "4.8.14"
zarith
>= "1.3"
zed
>= "1.6"
zenon
>= "0.8.4"
zero
< "109.19.00"
zlist
< "0.4.0"
zmq
< "4.0-1" | >= "4.0-8"
zstandard
< "v0.13.0"