ocaml

The OCaml compiler (virtual package)
Description

This package requires a matching implementation of OCaml, and polls it to initialise specific variables like ocaml:native-dynlink

Install
Published
21 Oct 2019
Authors
Maintainers
Dependencies
ocaml-system >= "4.11.0" & < "4.11.1~"
ocaml-variants >= "4.11.0" & < "4.11.1~"
Reverse Dependencies
0install < "2.8" | >= "2.14.1"
abella < "2.0.3" | >= "2.0.7"
acpc < "2.0.0"
albatross < "1.5.0"
alcotest >= "0.8.0"
alsa >= "0.2.3"
alt-ergo-free < "2.3.3"
amf >= "0.1.2"
amqp-client >= "1.0.3" & != "1.1.1"
ancient >= "0.9.1"
angstrom >= "0.6.0"
ao < "0.2.2"
arakoon >= "1.8.6"
archimedes >= "0.4.18"
argon2 >= "1.0.0"
asak >= "0.3"
astring >= "0.8.2"
async < "109.19.00" | >= "113.24.00" & != "113.33.03"
async-uri >= "0.2"
async_core < "109.19.00"
async_extended >= "113.24.00" & != "113.33.03"
async_extra < "109.19.00" | = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & != "v0.11.0"
async_find != "111.28.00" & != "113.33.03"
async_inotify != "113.00.00" & != "113.33.03"
async_js >= "v0.9.1"
async_kernel >= "113.24.00" & != "113.33.03" & != "v0.11.0"
async_parallel >= "113.24.00" & < "113.33.03" | >= "v0.9.1"
async_rpc_kernel >= "113.24.00" & != "113.33.03"
async_shell != "109.28.03" & < "113.33.03" | >= "v0.9.1"
async_smtp < "112.35.00" | >= "113.24.00" & != "113.33.03" & < "v0.15.0"
async_ssl < "112.35.00" | = "113.24.00" | >= "113.33.06"
async_unix < "109.19.00" | = "113.24.00" | = "113.33.00+4.03" | >= "v0.13.1"
atdgen >= "1.9.1"
atdj < "20151001.01"
atomic < "base"
bamboo >= "0.0.02"
bap = "0.9.5" | >= "1.2.0" & < "1.4.0" | >= "2.2.0"
bap-abi < "1.4.0" | >= "2.2.0"
bap-api < "1.4.0" | >= "2.2.0"
bap-arm < "1.4.0" | >= "2.2.0"
bap-beagle < "1.4.0" | >= "2.2.0"
bap-bil >= "2.2.0"
bap-build >= "2.2.0"
bap-bundle >= "2.2.0"
bap-byteweight < "1.4.0" | >= "2.2.0"
bap-byteweight-frontend < "1.4.0" | >= "2.2.0"
bap-c < "1.4.0" | >= "2.2.0"
bap-cache < "1.4.0" | >= "2.2.0"
bap-callsites < "1.4.0" | >= "2.2.0"
bap-cxxfilt < "1.4.0" | >= "2.2.0"
bap-demangle < "1.4.0" | >= "2.2.0"
bap-dump-symbols < "1.4.0" | >= "2.2.0"
bap-dwarf < "1.4.0" | >= "2.2.0"
bap-elementary >= "2.2.0"
bap-elf < "1.5.0" | >= "2.2.0"
bap-frames < "2.1.1"
bap-frontc < "1.4.0" | >= "2.2.0"
bap-frontend < "1.4.0" | >= "2.2.0"
bap-fsi-benchmark < "1.4.0" | >= "2.2.0"
bap-future < "1.4.0" | >= "2.2.0"
bap-ida < "1.4.0" | >= "2.2.0"
bap-ida-plugin < "1.4.0" | >= "2.2.0"
bap-ida-python < "1.4.0" | >= "2.3.0"
bap-knowledge >= "2.2.0"
bap-llvm < "1.4.0" | >= "2.2.0"
bap-main >= "2.2.0"
bap-mc < "1.4.0" | >= "2.2.0"
bap-microx < "1.4.0" | >= "2.2.0"
bap-mips >= "2.2.0"
bap-objdump < "1.4.0" | >= "2.2.0"
bap-phoenix < "1.4.0" | >= "2.2.0"
bap-piqi < "1.4.0" | >= "2.2.0"
bap-plugins >= "2.2.0"
bap-powerpc >= "2.2.0"
bap-primus < "1.4.0" | >= "2.2.0"
bap-primus-lisp < "1.4.0" | >= "2.2.0"
bap-primus-x86 < "1.4.0" | >= "2.2.0"
bap-print < "1.4.0" | >= "2.2.0"
bap-raw >= "2.2.0"
bap-recipe >= "2.2.0"
bap-relocatable < "1.4.0" | >= "2.2.0"
bap-report >= "2.2.0"
bap-run < "1.4.0" | >= "2.2.0"
bap-server < "0.3.0"
bap-ssa < "1.4.0" | >= "2.2.0"
bap-std < "1.4.0" | >= "2.2.0"
bap-strings < "1.4.0" | >= "2.2.0"
bap-symbol-reader < "1.4.0" | >= "2.2.0"
bap-taint < "1.4.0" | >= "2.2.0"
bap-taint-propagator < "1.4.0" | >= "2.2.0"
bap-term-mapper < "1.4.0" | >= "2.2.0"
bap-trace < "1.4.0" | >= "2.2.0"
bap-traces < "1.4.0" | >= "2.2.0"
bap-veri < "0.2.2"
bap-warn-unused < "1.4.0" | >= "2.2.0"
bap-x86 < "1.4.0" | >= "2.2.0"
bare >= "2.2.0"
base >= "v0.13.1" & != "v0.15.1~5.0preview"
base-bytes >= "base"
base64 >= "1.1.0" & != "2.3.0"
batteries = "2.5.0" | >= "3.1.0"
beluga >= "0.8.1"
benchmark >= "1.4"
bencode != "0.2"
bibtex2html >= "1.99"
bignum < "112.35.00" | >= "113.24.00" & != "113.33.03"
bigstring >= "0.2"
bin_prot < "109.15.00" | >= "v0.9.2"
binaryen < "0.11.0"
biniou >= "1.1.0"
binsec >= "0.4.0" & != "0.6.0"
biocaml != "0.5.0" & != "0.8.0" & < "0.10.0"
bisect >= "1.3.1"
bisect_ppx >= "1.3.1"
bitmasks >= "1.3.0"
bitstring >= "3.0.0"
bitv >= "1.3"
bitvec >= "2.2.0"
bitvec-binprot >= "2.2.0"
bitvec-order >= "2.2.0"
bitvec-sexp >= "2.2.0"
bitwuzla < "1.0.0"
bjack < "0.1.6"
blake2 >= "0.2"
bnfgen >= "3.0.0"
bolt = "1.3"
brotli < "1.2.0" | >= "2.0.0"
bwd < "2.0.0"
bytearray >= "1.0.1"
cairo2 >= "0.5"
calendar != "2.03.1"
camelot < "1.3.0" | >= "1.4.2"
camlimages >= "4.2.5"
camllib >= "1.3.3"
camlon >= "2.0.0"
camlp-streams >= "5.0.1"
camlp4 = "4.02.0-1modular-implicits" | >= "4.11+1" & < "4.12+1"
camlp5 >= "7.12"
camlpdf >= "2.3"
camltc >= "0.9.6"
camlzip >= "1.06"
camomile >= "0.8.6"
camyll < "0.2.0"
carray >= "0.0.2"
catala < "0.7.0"
cbor >= "0.2"
cca < "0.6.2"
cconv >= "0.2"
ccss >= "1.6"
certify >= "0.2"
cfg >= "2.1.0"
cfstream >= "1.3.0"
cgi >= "0.9"
charrua-unix < "0.5" | >= "0.10"
cinaps >= "v0.10.0"
clangml != "3.8.0" & != "3.9.1.2" & != "4.0.0beta1"
cloudi >= "1.8.0"
cmdliner = "0.9.4" | >= "1.0.0"
coccinelle != "1.0.0-rc23" & != "1.0.7"
codept >= "0.11.0"
cohttp != "0.99.0"
combine < "0.42"
comparelib < "113.00.00"
containers >= "2.6" & < "2.7" | >= "3.0"
coq >= "8.11.1"
coq-serapi < "8.7.2+0.4.13" | >= "8.8.0+0.5.2"
coqide != "8.7.0" & < "8.10.0"
core >= "113.24.00" & != "113.33.00" & != "113.33.02" & < "113.33.03" | >= "v0.9.2" & < "v0.11.0" | >= "v0.11.2" & < "v0.12.0" | >= "v0.12.2"
core-lwt < "0.2.0"
core_bench != "112.35.00" & != "113.33.00" & != "113.33.03"
core_extended >= "108.00.02" & < "109.19.00" | = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.1"
core_kernel = "113.24.00" | >= "113.33.01+4.03" & < "113.33.03" | >= "v0.9.1" & != "v0.11.0" & < "v0.12.0" | >= "v0.12.2" & != "v0.13.0"
core_profiler >= "113.24.00" & != "113.33.03"
cow >= "2.0.1"
cpdf < "2.1.1" | >= "2.3"
cppo >= "1.6.1"
crc >= "1.0.0"
crunch >= "1.4.0"
cry >= "0.6.0"
crypt >= "1.2"
cryptodbm >= "0.84.2"
cryptokit >= "1.11"
cstruct >= "1.6.0" & < "1.8.0" | >= "3.0.0"
cstruct-unix >= "4.0.0"
csv >= "1.4"
csvfields >= "v0.9.1"
ctypes >= "0.8.0"
cubicle >= "1.1.2"
current_incr < "0.6.1"
custom_printf >= "111.21.00" & < "113.00.00"
DrawGrammar >= "0.2.1"
daft < "0.0.4"
datakit < "0.10.0" | >= "0.11.0"
datalog < "0.5" | >= "0.6"
decompress >= "0.8"
delimcc >= "2020.10.08"
depyt >= "0.2.0"
deriving >= "0.7.1"
devkit >= "0.5"
digestif != "0.6"
dlist >= "0.0.3"
dmap < "0.5"
dns != "1.0.0"
dockerfile < "1.3.0" | >= "1.7.2"
dolog >= "1.1"
dot-merlin-reader != "4.4~5.0.preview"
down < "0.1.0"
dropbox < "0.2"
dryunit >= "0.4.0"
dssi < "0.1.3" | >= "0.1.5"
dum != "1.0.2"
dune >= "1.6.0" & < "1.7.0" | >= "1.11.0"
dune-build-info < "2.0.0" | >= "3.0.2"
duppy >= "0.7.0" & < "0.9.0"
dyntype >= "0.8.3"
earley >= "1.0.1" & != "2.0.0"
earlybird >= "1.0.0"
edn >= "0.1.6-1-gff9db95"
efl >= "1.12.0"
eliom < "6.5.0" | >= "6.8.0" & < "6.10.1" | >= "6.12.1"
email_message < "112.35.00" | = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.1" & != "v0.11.0"
encore != "0.3"
enumerate < "111.08.00"
erssical < "1.1.0"
exenum >= "0.7"
expect >= "0.0.6"
extlib = "1.7.0" | >= "1.7.5"
extprot >= "1.1.2" & < "1.3.0" | >= "1.6.0"
extunix >= "0.1.5"
ezjs_fetch < "0.3"
ezjsonm >= "0.5.0"
ezjsonm-lwt >= "1.0.0"
ezxenstore >= "0.4.1"
ezxmlm >= "1.0.2"
FrontC >= "3.4.1"
faad < "0.5.0"
fat-filesystem != "0.12.0" & != "0.12.2"
fd-send-recv >= "1.0.5" & < "2.0.2"
fdkaac < "0.3.2"
feather_async >= "0.2.0"
ff >= "0.5.0"
fftw3 >= "0.8.4"
fiat-p256 < "0.2.1"
fieldslib < "109.19.00" | = "113.24.00" | >= "v0.9.0"
fileutils >= "0.5.3"
flac != "0.1.2"
flow >= "0.3"
flow_parser >= "0.80.0"
flowtype >= "0.62.0" & < "0.87.0"
fluent-logger < "1.1.0"
fmt >= "0.8.0"
frama-c >= "11.0" & < "16.0" | >= "19.1" & < "26.0~beta"
frei0r < "0.1.2"
fstar >= "2021.06.06"
functoria >= "2.2.1"
functory >= "0.6"
GuaCaml < "0.04"
gammu >= "0.9.3"
gapi-ocaml >= "0.3.5"
gdal < "0.3.0" | >= "0.9.0"
gdbprofiler >= "0.2"
gen = "0.2.2" | = "0.5" | >= "0.5.3"
gen-bs < "0.1.0"
gen_js_api >= "1.0.6"
genet < "0.6"
geoip >= "0.0.3"
get_line < "5.0.0"
gettext = "0.3.8" | >= "0.4.2"
gg >= "0.9.2"
git < "1.4.3" | >= "1.8.0" & != "1.10.0"
github < "1.0.0" | >= "3.0.0"
github-unix >= "3.1.0"
gles3 < "20160505.alpha"
glical >= "0.0.3"
glMLite >= "0.03.53"
glpk != "0.1.7"
goblint >= "1.1.1"
gopcaml-mode >= "0.0.2"
gperftools >= "0.5"
graphics >= "5.1.0"
graphlib < "1.4.0" | >= "2.2.0"
graphql_ppx >= "0.7.1"
grenier >= "0.11"
hardcaml < "1.1.1" | >= "v0.12.0"
haxe >= "4.0.0"
hdf5 >= "0.1.5"
hdfs >= "0.3"
headache >= "1.06"
heptagon < "1.01.00" | >= "1.03.03"
hevea >= "2.25"
hex >= "1.2.0"
higlo != "0.3" & < "0.8"
hmap >= "0.8.1"
horned_worm != "0.3.1"
humane-re != "0.0.3"
hvsock >= "0.6"
i3ipc >= "0.1.2"
ibx < "0.8.1"
imagelib >= "20171028"
imaplet-lwt < "0.1.15"
incremental >= "113.24.00" & != "113.33.03"
incremental_kernel != "113.33.03" & != "v0.11.0"
inotify >= "2.1"
interval < "1.6"
io-page >= "2.0.1"
io-page-unix >= "2.0.0"
io-page-xen >= "2.0.0"
iocaml >= "0.4.6"
iocaml-kernel >= "0.4.6"
iocamljs-kernel < "0.4.3" | >= "0.4.6"
ipaddr >= "2.7.2"
irc-client >= "0.4.0"
iri < "0.5.0"
irmin < "0.9.0" | >= "0.9.5" & != "0.9.10" & < "1.0.0" | >= "1.3.2"
irmin-git >= "1.1.0"
irmin-http >= "1.3.1"
irmin-mirage < "2.0.0"
irmin-tezos >= "3.2.1" & < "3.4.0"
irmin-unix != "1.3.0"
iter >= "1.2.1"
itv-tree >= "2.1"
JsOfOCairo >= "1.0.1"
javalib != "2.3.3"
jbuilder >= "1.0+beta20.1"
jenga < "109.19.00" | >= "113.24.00" & != "113.33.00" & != "113.33.03"
jingoo >= "1.2.16"
js-build-tools >= "113.33.04"
js_of_ocaml >= "3.5.0"
json-wheel >= "1.0.6+safe-string"
jsonm != "1.0.0"
jsonxt >= "1.0.1"
jsoo_storage >= "1.0.1"
junit < "2.0.1"
junit_ounit < "2.0.1"
jupyter >= "2.7.2"
KaSim >= "4.0.0"
kafka >= "0.3"
kaputt >= "1.2"
ketrew >= "1.1.1" & != "3.0.0"
key-parsers != "0.10.0"
kqueue < "0.2.0"
kremlin >= "1.0.0"
lablgtk >= "2.18.11"
lablgtk3 >= "3.1.1"
lablgtk3-gtkspell3 >= "3.0.beta8"
lablqml >= "0.6.2"
labltk >= "8.06.6"
ladspa < "0.2.0" | >= "0.2.2"
lambda-term < "1.6" | >= "1.12.0"
lame < "0.3.4"
landmarks >= "1.3"
lastfm = "0.3.2"
lazy-trie >= "1.1.0"
lbfgs >= "0.9"
lbvs_consent < "2.0.0"
learn-ocaml < "0.12"
ledit >= "2.04"
lens < "1.2.0" | >= "1.2.4"
leveldb < "1.0.3" | >= "1.3.0"
libsvm != "0.9.3"
libudev >= "0.2.1"
linenoise < "1.1.0" | >= "1.3.1"
links >= "0.9.1"
liquidsoap >= "1.4.0" & < "2.0.4"
lmdb >= "1.0"
lo < "0.2.0"
loga >= "0.0.5"
logical >= "0.2.0"
logs >= "0.6.2"
logtk >= "1.5.1"
lpd >= "1.2.2"
lru != "0.3.0-1"
lsp < "1.6.1"
lutils >= "1.44"
lwt >= "4.2.0"
lwt_domain < "0.3.0"
lwt_eio < "0.2"
lwt_ppx_let >= "5.6.0"
lwt_ssl >= "1.1.1"
lz4_chans >= "3.0.0"
lzo >= "0.0.2"
macaque != "0.7.1"
macaroons < "0.1.1"
mad < "0.5.0"
malfunction != "0.3"
mariadb >= "1.1.4"
mccs >= "1.1+11"
mdx >= "1.7.0"
menhir >= "20130911"
merlin >= "3.3.7~4.11preview1" & != "4.1-412" & != "4.2-412" & < "4.3.1-412" | = "4.4-411" | = "4.5-411"
mesh >= "0.8.7"
metapp >= "0.2.0"
metaquot >= "0.2.0"
metrics-lwt >= "0.3.0"
metrics-mirage >= "0.3.0"
metrics-unix >= "0.3.0"
mikmatch >= "1.0.9"
mindstorm >= "0.6"
minisat != "0.3"
mirage >= "2.0.0" & < "2.7.0" | >= "3.1.1"
mirage-block-unix >= "2.0.0" & != "2.7.0"
mirage-console != "2.1.0"
mirage-flow < "1.0.3" | >= "1.2.0"
mirage-fs-unix >= "1.4.1"
mirage-nat < "1.1.0" | >= "2.0.0"
mirage-net-solo5 < "0.4.3" | >= "0.6.1"
mirage-net-xen >= "1.4.2" & < "1.6.0" | >= "1.7.0"
mirage-os-shim >= "3.0.1"
mirage-profile != "0.7.0"
mirage-solo5 >= "0.6.2"
mirage-xen >= "2.6.0"
mkocaml >= "1.2"
mlcuddidl >= "3.0.6"
mlgmpidl >= "1.2.11"
mlpost >= "0.8.2"
mm >= "0.3.1" & < "0.7.0" | = "0.7.4"
modelica_ml >= "0.2.0"
molenc < "16.15.0"
monads < "1.4.0" | >= "2.2.0"
monomorphic >= "1.2"
mparser >= "1.2"
mpp >= "0.3.2"
mpris >= "0.1.1"
mqtt < "0.0.2"
msgpack >= "1.3.0"
mstruct >= "1.4.0"
mtime >= "0.8.4"
mula >= "0.1.1"
mustache != "2.0.0"
mysql >= "1.2.1"
nlopt-ocaml >= "0.5.1"
nocrypto >= "0.2.0" & != "0.5.3"
not-ocamlfind != "0.07" & < "0.09"
notty != "0.2.0"
npy >= "0.0.7"
nsq >= "0.1.1"
num >= "1.0"
nunchaku >= "0.6"
nuscr >= "2.0.0"
oasis >= "0.4.7"
oasis2opam < "0.4.4" | >= "0.6.1"
obeam < "0.1.0" | >= "0.1.2"
objsize >= "0.18"
obuild >= "0.1.9"
obuilder < "0.5"
obus >= "1.1.8"
ocal != "0.2.0"
ocaml-basics != "0.4.0"
ocaml-freestanding >= "0.6.2" & < "0.7.0"
ocaml-http >= "0.1.6"
ocaml-lua >= "1.8"
ocaml-makefile < "6.39.2"
ocaml-manual = "4.11.0"
ocaml-monadic >= "0.3.2"
ocaml-r >= "0.1.0"
ocaml-src = "4.11.0"
ocaml-top < "1.1.0" | >= "1.1.5"
ocaml-variants >= "4.11.0+32bit" & < "4.11.1+32bit"
ocaml_plugin < "112.35.00" | >= "113.24.00" & != "113.33.00" & != "113.33.03"
ocamlbrowser = "4.11.0"
ocamlbuild < "0.9.0" | >= "0.14.0"
ocamlclean >= "2.3"
ocamldap >= "2.3.0"
ocamldiff >= "1.1"
ocamlfind >= "1.8.1"
ocamlformat != "0.5" & < "0.9" | >= "0.15.0" & != "0.19.0~4.13preview"
ocamlgraph >= "1.8.8"
ocamlmod >= "0.0.8"
ocamlnet >= "4.1.8"
ocamlpp >= "1.1"
ocamltter < "2.0.1" | = "2.1.1" | >= "4.1.0"
ocapic >= "3.5"
ocluster < "0.2"
ocolor >= "1.1"
ocp-build >= "1.99.21"
ocp-indent = "1.5.2" | >= "1.6.1"
ocp-index >= "1.2.1"
ocp-pp < "1.99.19-beta"
ocsigen-i18n >= "3.5.0"
ocsigenserver >= "2.12.0"
octavius != "1.2.0"
ocurl >= "0.7.6" & < "0.8.0" | >= "0.9.1"
odate >= "0.6"
odds < "1.1"
odepack >= "0.6.7"
odig != "0.0.2"
odoc < "1.3.0" | >= "1.5.1"
ogen != "0.1.2"
ogg = "0.5.2" | = "0.6.1" | >= "0.7.2"
ogre < "1.4.0" | >= "2.2.0"
ojs-base < "0.3.0" | = "0.5.0"
omake >= "0.10.3"
omd >= "1.3.1"
oml < "0.0.5" | >= "0.0.7"
omonad >= "0.4.0"
opam-bin >= "0.9.5"
opam-core = "2.0.0~beta5" | >= "2.0.0~rc2"
opam-grep >= "0.2.0"
opam-lib < "0.9.4" | >= "1.0.0"
opass < "2.15"
opasswd >= "1.3.1"
openQASM >= "0.4.0"
operf-micro >= "1.1.1"
optimization1d != "0.5.1"
opus < "0.2.0" | >= "0.2.2"
orakuda >= "1.2.0" & < "2.0.0"
orm >= "0.7.0"
orpie >= "1.6.1"
orsetto >= "1.0.2"
osbx >= "1.2.4"
osc >= "0.1.4"
otr >= "0.3.2"
ott >= "0.26"
ounit >= "2.0.0" & < "2.2.0"
ounit-lwt < "2.2.0"
override >= "0.3.0"
owee >= "0.3"
owl >= "0.3.7" & != "0.6.0"
pa_bench < "113.00.00"
pa_ounit < "112.35.00"
pa_ppx >= "0.02"
pa_test < "112.24.00"
parany < "13.0.0"
pareto >= "0.3"
parmap >= "1.0-rc11"
parsexp >= "v0.9.1"
parsexp_io >= "v0.9.1"
patdiff != "113.00.00" & != "113.33.03"
patience_diff != "112.24.00" & != "113.33.03"
pattern >= "0.2.0"
pcap-format < "0.5.0" | >= "0.5.2"
pci >= "1.0.1"
pcre >= "7.1.3" & < "7.5.0"
pfff >= "0.40.4"
pgocaml < "1.7" | >= "2.2" & != "3.2"
pipebang < "109.09.00"
piqi < "0.7.0" | >= "0.7.6"
pkcs11-cli >= "1.0.1"
pkcs11-rev >= "1.0.1"
pla >= "1.2"
planck >= "2.2.0"
planets >= "0.1.14"
plist < "1.0.0"
plotkicadsch < "0.4.0" | >= "0.5.2"
podge < "0.4"
pomap >= "4.1.0"
portaudio = "0.2.1"
portia >= "1.1"
posix-getopt < "2.0.0"
posixat >= "v0.10.0"
pprint >= "20171003"
ppx_assert >= "113.24.00" & != "113.33.03"
ppx_ast >= "v0.11.0"
ppx_bench = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0"
ppx_bin_prot >= "113.24.00" & != "113.33.00" & != "113.33.03" & != "v0.12.0"
ppx_bitstring = "1.1.0" | >= "1.3.3"
ppx_blob >= "0.2"
ppx_compare = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0"
ppx_const >= "2.0"
ppx_conv_func = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0"
ppx_core >= "v0.9.2"
ppx_cstubs >= "0.4.1"
ppx_csv_conv = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0"
ppx_custom_printf = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & != "v0.12.0"
ppx_deriving_protobuf = "2.4" | >= "3.0.0"
ppx_deriving_yojson < "2.0" | >= "3.5.3"
ppx_driver = "113.24.00" | >= "113.33.00+4.03" & < "113.33.03" | >= "v0.9.2"
ppx_enumerate = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0"
ppx_expect != "113.33.00" & != "113.33.01" & != "113.33.03"
ppx_factory != "0.1.0"
ppx_fail = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0"
ppx_fields_conv = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0"
ppx_getenv >= "2.0"
ppx_here >= "113.24.00" & != "113.33.03"
ppx_import >= "1.7.1"
ppx_inline_test = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0"
ppx_irmin < "2.4.0" | >= "3.0.0"
ppx_jane != "113.33.03"
ppx_jsobject_conv >= "0.2.1" & < "0.6.0" | >= "0.9.0"
ppx_let != "113.33.00" & != "113.33.03"
ppx_meta_conv >= "4.0.0" & < "4.1.0"
ppx_monad >= "0.2.0"
ppx_monadic >= "1.0.4"
ppx_monoid != "0.2"
ppx_netblob >= "1.1"
ppx_optcomp = "113.24.00" | = "113.33.01+4.03" | >= "v0.9.0"
ppx_orakuda = "3.0.1" | = "3.1.0" | >= "3.3.0"
ppx_pipebang = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0"
ppx_regexp >= "0.3.0"
ppx_sexp_conv >= "113.24.00" & != "113.33.03"
ppx_sexp_message != "113.33.00" & != "113.33.03"
ppx_sexp_value = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0"
ppx_test >= "1.4.0"
ppx_tools >= "6.2"
ppx_type_conv = "113.24.00" | >= "113.33.00+4.03" & != "113.33.03"
ppx_typerep_conv = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0"
ppx_variants_conv = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0"
ppx_xml_conv >= "113.24.00" & != "113.33.03"
ppxlib >= "0.12.0" & != "0.25.0~5.00preview"
ppxx >= "2.4.0"
prbnmcn-ucb1 >= "0.0.2"
proj4 >= "0.9.2"
proverif >= "1.97pl3"
ptime >= "0.8.1"
ptmap < "2.0.1" | >= "2.0.5"
ptset >= "1.0.1"
pulseaudio < "0.1.4"
pxp != "1.2.8"
pyml < "20171117" | >= "20200222"
qcheck >= "0.3" & < "0.5" | >= "0.5.2"
qcow < "0.8.1" | >= "0.10.0"
qfs >= "0.12"
qocamlbrowser = "0.2.11"
qrencode >= "0.2"
qtest >= "2.7"
quickcheck != "1.0.0"
radare2 >= "0.0.2"
ranger >= "0.1.0"
rawlink >= "0.6"
rdbg >= "1.175"
rdf >= "0.5" & < "0.7.0" | = "0.11.0"
rdr < "2.0.1"
re >= "1.3.0"
re2 < "112.35.00" | = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.1"
react = "1.0.0" | >= "1.2.1"
reanalyze >= "2.14.0"
reason >= "3.6.2"
records != "0.6.0"
redirect >= "0.1.1"
redis >= "0.3.6"
redis-lwt >= "0.3.6"
redis-sync >= "0.3.6"
regular >= "1.2.0" & < "1.4.0" | >= "2.2.0"
res >= "4.0.7"
rfc6287 != "1.0.2"
riakc_ppx != "3.1.2"
rml >= "1.09.00" & != "1.09.04"
rmlbuild >= "0.14.0-00"
root1d != "0.3"
rope >= "0.6"
rpc < "1.3.0" | >= "5.9.0"
rpc_parallel >= "113.24.00" & != "113.33.03"
rpclib != "6.0.0"
rpclib-async != "6.0.0"
rpclib-lwt != "6.0.0"
rresult >= "0.4.0"
rtop >= "3.6.2"
Snowflake < "0.02.03"
safepass >= "2.0"
sail < "0.15"
samplerate < "0.1.5"
sarek >= "20210823"
sawja != "1.5.2"
sedlex >= "1.99.4"
seq >= "0.2.2"
sequence < "0.3"
sexplib >= "v0.9.3"
sfml >= "0.08.3"
sha >= "1.10"
shared-block-ring < "2.3.0" | >= "3.0.0"
shared-memory-ring < "1.2.0" | >= "3.0.0"
shcaml >= "0.2.1"
shexp < "v0.11.0" | >= "v0.12.0"
shuttle_http < "0.8.1"
sihl < "3.0.0"
slacko >= "0.11.0" & < "0.15.0"
slap >= "4.1.1"
snappy < "0.1.0" | >= "0.1.2"
socketcan >= "0.8.12-0"
sodium != "0.2.0"
sosa >= "0.2.0"
soupault < "4.3.1"
spacetime_lib >= "0.3.0"
speex != "0.4.0"
spelll = "0.2" | >= "0.4"
spf >= "2.0.2"
spoc >= "20210823"
spotify-cli >= "0.3.0"
spotlib >= "4.0.2" & < "4.3.0"
sqlexpr < "0.7.1" | >= "0.9.0"
sqlgg >= "0.4.4"
sqlite3 < "5.0.3"
srs >= "2.0.0"
srt < "0.1.1"
ssl >= "0.5.4"
statverif >= "1.97pl1.1"
stdcompat < "2" | >= "14"
stdio >= "v0.9.1"
stemming >= "0.2.1"
stog >= "0.15.0" & < "0.19.0"
stog-writing < "0.19.0"
stone >= "0.5.1"
stringext >= "1.2.0"
syndic >= "1.2"
syslog >= "2.0.0"
systemverilog < "0.0.2"
taglib = "0.3.6" | >= "0.3.8"
tar >= "0.9.0"
tar-mirage >= "0.9.0"
tar-unix >= "0.9.0"
tcpip < "3.0.0" | >= "3.3.1"
tdk >= "0.1.1"
tensorflow != "0.0.10"
text >= "0.8.0"
text-tags < "1.4.0" | >= "2.2.0"
textutils != "112.17.00" & != "113.33.03"
textwrap >= "0.2"
tezos-hacl < "15.0"
tezos-protocol-environment-sigs < "8.0" | >= "9.0" & < "11.0"
tezt < "2.0.0"
tgls != "0.8.3"
theora < "0.4.0"
thrift >= "0.10.0"
tiny_json >= "1.1.5"
tip-parser < "0.5"
toml >= "5.0.0"
tophide >= "1.0.4"
toplevel_expect_test < "113.33.02" | >= "v0.9.2" & < "v0.12.0" | >= "v0.12.2"
tptp >= "0.3.2"
traverse >= "0.2.0"
travesty < "0.6.0" | >= "0.6.2" & < "0.7.2"
trax < "0.4.0"
treeprint >= "2.1.1" & < "2.3.0"
tsdl < "0.8.1" | >= "0.9.1"
tuntap >= "1.3.0"
type_conv >= "113.00.02"
typerep < "112.35.00" | = "113.24.00" | >= "v0.9.0"
typerep_extended != "113.00.00" & != "113.33.03"
typerex-attic >= "1.0.2"
tyxml < "3.0.0" | >= "3.3.0" & != "4.1.0"
tyxml-lwd < "0.2"
ubase < "0.20"
uchar >= "0.0.2"
uecc >= "0.3"
uint >= "1.2.1"
ulex >= "1.2"
um-abt < "0.1.5"
unison >= "2.51.4"
uri >= "1.3.13" & < "1.9.2" | >= "1.9.5"
uritemplate >= "0.2.0"
usb >= "1.3.1"
usbmux >= "1.2.0"
utop >= "2.6.0"
uucd >= "4.0.0"
uucp >= "2.0.0"
uuidm >= "0.9.6"
uunf < "1.0.0" | >= "2.0.1"
uuseg != "1.0.0"
uutf >= "1.0.1"
variantslib != "109.15.03" & != "113.33.03"
vcardgen < "1.2"
vchan-unix >= "4.0.0"
vector3 >= "0.2.1"
vg < "0.8.1" | >= "0.9.0"
vhd-format != "0.8.0" & != "0.9.2"
vhd-format-lwt != "0.9.2"
virtual_dom >= "v0.9.1"
visitors >= "20190711"
vmnet < "1.2.0" | >= "1.3.1"
voqc >= "0.2.0"
vorbis < "0.6.2" | >= "0.7.1"
vpnkit != "0.1.1"
vpt < "5.0.0"
vue-jsoo = "0.2"
wall >= "0.4"
wasm >= "1.0.1"
weberizer != "0.7.2" & != "0.7.7"
webidl >= "1.0"
websocket != "2.12"
why >= "2.32"
why3 >= "0.85" & < "1.0.0" | >= "1.2.1"
winsvc >= "1.0.1"
wyrd >= "1.4.6"
xapi-rrd != "1.0.2" & < "1.9.1"
xen-evtchn >= "1.0.6"
xenctrl >= "0.9.29" & < "0.9.32"
xenstore < "1.3.0" | >= "2.0.0"
xenstore_transport < "0.9.2" | >= "0.9.6"
xmldiff < "0.6.0"
xmlm >= "1.3.0"
xtmpl = "0.10" | >= "0.14.0" & < "0.18.0"
yajl-extra < "0.7.3"
yaml < "3.1.0"
yojson >= "1.4.0"
yurt >= "0.3"
yuujinchou < "2.0.0"
zarith >= "1.3"
zed >= "1.6"
zenon >= "0.8.4"
zero < "109.19.00"
zlib >= "0.6"
zlist < "0.4.0"
zmq < "4.0-1" | >= "4.0-8"